XAMPP + Subversion auf Windows Server 2008 R2

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP + Subversion auf Windows Server 2008 R2

Postby Skalli » 01. February 2010 12:49

Hallo Freunde,

ich habe nochmal ein kleines Einsteigerproblem.
Ich habe mir die Tage einen neuen Server gekauft. Nun wollte ich den ordentlich Aufsetzen und dann Subversion und XAMPP darauf installieren. Soweit lief auch alles ohne Probleme. Jedoch kann ich den Apache nicht mit Subversion starten. Jedes mal wenn ich es versuche kommt die Meldung: "httpd.exe: Syntax error on line 133 of D:/xampp/apache/conf/httpd.conf: Cannot load D:/xampp/apache/modules/mod_dav_svn.so into server: Das angegebene Modul wurde nicht gefunden."
So, nun denkt man natürlich das ich die beiden Module von Subversion nicht in das Verzeichnis von Apache/modules gelegt habe. Das ist aber falsch. Denn beide Module liegen dort. Wenn ich meinen XAMPP Ordner von einem Windows XP rüberziehe, dann geht es auch nicht, obwohl auf dem XP PC alles korrekt läuft.
In der httpd.conf ist also alles korrekt. Die Module liegen in den richtigen Verzeichnissen, nur der Apache lässt sich nicht starten.
Das Serversystem ist ein Xen-Server 5.5 mit Windows Server 2008 R2 als Virtuelle Maschine. Ich habe die neuesten Versionen von XAMPP (1.7.3) und Subversion (1.6.6). Hat jemand eine Ahnung woher das Problem stammen könnte? Mir fällt dort kein Fehler auf. Vielleicht habe ich aber auch etwas ganz einfaches übersehen.

Viele Grüße,
Skalli
Skalli
 
Posts: 4
Joined: 04. January 2010 13:18

Re: XAMPP + Subversion auf Windows Server 2008 R2

Postby Skalli » 02. February 2010 16:05

Hat niemand eine Ahnung woran es liegen könnte?
Skalli
 
Posts: 4
Joined: 04. January 2010 13:18

Re: XAMPP + Subversion auf Windows Server 2008 R2

Postby B.Nutzer » 22. July 2013 12:42

Hi
eben über deinen Post gestolpert ..
da er von 2010 ist habe ich die Hoffnung das Problem ist gelöst.

Bei mir sieht es ähnlich aus
Umzug von
    Windos 2003 Server (32Bit)
    XAMPP v1.6.3a (32Bit)
    Subversion v1.6.16 (32Bit)
auf neue "Virtuelle Maschine"
    Windows 2008 R2 (64Bit)
    XAMPP v1.8.2 (32Bit)
    Subversion v1.8.0-1 (32Bit)

Apache läuft ...
aber wenn ich versuche die Module mod_dav_svn.so und authz_svn_module.so zu laden kommt der bekannte Fehler
httpd.conf: Cannot load modules/mod_dav_svn.so into server: Die angegebene Prozedur wurde nicht gefunden.
Code: Select all
http.conf

LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so

LoadModule dav_svn_module     "C:/Program Files (x86)/Subversion/bin/mod_dav_svn.so"
LoadModule authz_svn_module   "C:/Program Files (x86)/Subversion/bin/mod_authz_svn.so"



Nach einiger Recherche und Tipps habe ich schon diverse libs von
Subversion/bin in den Apache/bin kopiert leider ohne Funktion :-(

Eventuell ist die Kombination 64/32Bit kontraproduktiv?

Für jeden Tipp oder Hilfreichen Link wäre ich dankbar.

THX B.Nutzer
B.Nutzer
 
Posts: 2
Joined: 22. July 2013 12:15
XAMPP Version: 1.7.4
Operating System: Windows 2003 Server

Re: XAMPP + Subversion auf Windows Server 2008 R2

Postby B.Nutzer » 23. July 2013 10:56

... Nerven verloren ...
Die Kombination 32/64 Bit oder die Reihenfolge des ladens von Modulen nicht mehr durchblickend,
habe ich (bekennender XAMPP Fan) eine andere Distribution (WANdisco) ausprobiert, nur mal so.
Und siehe da, es funktioniert :-)

Die Differenzen zwischen den beiden Installation noch nicht erfasst, eigentlich müßte es ja auch mit dem XAMPP funktionieren.
Jetzt läuft
    Windows 2008 R2 (64Bit)
    Apache v2.2.25 (32Bit)
    Subversion v1.8.0-2 (32Bit)
Die für mich noch fehlende PHP Unterstützung habe ich per Installer (msi) hinzugefügt.
    PHP 5.3.27 (32Bit)

Wenn ich jetzt noch mal Nerv habe untersuche ich das Ganze nochmal ...
aber wie das wahrscheinlich immer so ist never change a running system

B.Nutzer
B.Nutzer
 
Posts: 2
Joined: 22. July 2013 12:15
XAMPP Version: 1.7.4
Operating System: Windows 2003 Server


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests