Xdebug in 1.7.3

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xdebug in 1.7.3

Postby rAcHe kLoS » 07. January 2010 10:31

Moin,

leider funktioniert Xdebug in 1.7.3 nicht mehr richtig, es lassen sich lokale Variablen nicht mehr auslesen. Das Problem ist wohl auch bekannt, sowie auch einige abstürze den den Apache selbst zum Absaufen bringen.

Ich würde ja gerne die neuste Xdebug Version 2.1.0 die nun endlich Beta ist verwenden, nur leider wird diese warum auch immer für PHP 5.3.x nur in VC9 kompiliert angeboten. VC6 habe ich hier leider auch nicht mehr, könnte event. einer der Devs bitte die Version hier zur Verfügung stellen?
rAcHe kLoS
 
Posts: 1
Joined: 07. January 2010 10:10

Re: Xdebug in 1.7.3

Postby jyd44 » 09. January 2010 20:55

As I have exactly the same issue, ie. Apache thread crashing when I reach a breakpoint, could you post replies to the initial post in english (sorry, I don't understand german). My configuration: Vista 32 bits Home Premium, Service Pack 2, XAMPP 1.7.3 default installation + xdebug enabling.

PHP 5.3.1 with "This program makes use of the Zend Scripting Language Engine: Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
with Xdebug v2.0.6-dev, Copyright (c) 2002-2009, by Derick Rethans" from phpinfo() menu in apache admin.

xdebug
xdebug support enabled
Version 2.0.6-dev

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.125.2.7 $
GDB - GNU Debugger protocol $Revision: 1.87.2.1 $
PHP3 - PHP 3 Debugger protocol $Revision: 1.22 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.idekey nous no value
xdebug.manual_url http://www.php.net http://www.php.net
xdebug.max_nesting_level 100 100
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir C:\xampp-173\xampp\tmp C:\xampp-173\xampp\tmp
xdebug.profiler_output_name xdebug_profile.%p xdebug_profile.%p
xdebug.remote_autostart On On
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir C:\xampp-173\xampp\tmp C:\xampp-173\xampp\tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

Debug Client: Netbeans 6.8
Thanks for your help

Just want to add that with XAMPP 1.7.0 and php_xdebug-2.0.0-5.2.2.dll, it works perfectly on same OS.
jyd44
 
Posts: 1
Joined: 09. January 2010 20:47

Re: Xdebug in 1.7.3

Postby Othella » 14. February 2010 19:54

I got the same problem.
Die 2.1.0 beta2 Version VC6 von xdebug wird nicht erkannt, und alle andere Versionen zeigen die Variablen als <uninitialized>....
Gibt es eine Lösung um PHP 5.3.x zu debuggen in XAMPP?

Danke im Voraus!
Othella
 
Posts: 2
Joined: 14. February 2010 18:03

Re: Xdebug in 1.7.3

Postby fabrizio » 22. February 2010 22:05

Hallo an alle,
habe das gleiche Problem, mit Windows 7 HP x64 und XAMPP 1.7.3 (PHP 5.3.1, VC6 und TS) finde ich einfach keine DLL für XDebug, die mit dieser Konstellation klar kommt. Hat evtl. jemand eine VC6-x64 DLL zu PHP 5.3.x kompiliert und kann diese in irgendeiner Form zur Verfügung stellen, oder weitere Lösungen anbieten?

Vielen Dank im Voraus!

Fabrizio
fabrizio
 
Posts: 3
Joined: 22. February 2010 22:02

Re: Xdebug in 1.7.3

Postby Othella » 08. March 2010 13:34

So, mit XAMPP 1.7.3 (PHP 5.3.1) und Xdebug 2.1.0rc1-dev (php_xdebug-2.1.0beta3-5.3-vc6.dll) scheint alles jetzt gut zu laufen mit Windows x64 :-)
Othella
 
Posts: 2
Joined: 14. February 2010 18:03


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests