neuer Xamp führt kein php aus

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

neuer Xamp führt kein php aus

Postby Robina » 28. December 2009 14:02

Wir haben unserer Testumgebung der Webpräsenz neu aufsetzen wollen und dazu den neuen Xamp installiert.
Der Ordner der Inhalte wurde in die htdocs kopiert, die Datenbank auch an die gewohnte Stelle.
Mit phpmyadmin kann ich die Datenbank auch wie gewohnt öffnen und bearbeiten.

Wenn ich jetzt bei gestartetem Xampp wie früher die Seiten im Browser aufrufen will (http://localhost/.....)
funktioniert das nur bei html dateien, und php-dateien, die keine Datenbank benötigen. (wenn ich das jetzt richtig beobachtet habe)

Sobld ich einen Datenbankaufruft im Programm habe, wird mir nur gesagt, dass ich die Datei im Editor öffnen oder speichern kann. Sie ist nicht so wie im Netz aufzurufen.

Seit der Neuinstallation reagiert auch ein alter Xampp (vom USB-Stick kopiert) genauso. Ist da bei der Installation etwas in den Windows-Einstellungen verändert worden?

Das gleiche Problem hatte ich auch schon, als ich Xamp auf vista aufspielte, habe es da aber auf Vista geschoben und nach vielen hoffnungslosen Versucehn nicht weiter verfolgt

bin jetzt nach erneutem stundenlangem Probieren völlig ratlos
Robina
 
Posts: 3
Joined: 28. December 2009 12:40

Re: neuer Xamp führt kein php aus

Postby Pitze » 28. December 2009 15:47

Ist da bei der Installation etwas in den Windows-Einstellungen verändert worden?

Nein
Funktioniert den die Xampp-Startseite komplett?
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: neuer Xamp führt kein php aus

Postby Robina » 28. December 2009 16:17

http://localhost/xampp/
auch phpmyadmin und html seiten mit http://localhost/xy/xy.htm werden probelmlos gefunden und angezeigt.
beim Starten von Phpseiten bekomme ich eine Alertbox zum beispiel bei index.php

möchten Sie diese Datei öffnen oder speichern

Name: indes.php
typ php_auto_file, 5,14 KB
von: localhost

öffnen speichern abbrechen


statt dass die seite angezeigt wird
Robina
 
Posts: 3
Joined: 28. December 2009 12:40

Re: neuer Xamp führt kein php aus

Postby Pitze » 28. December 2009 16:27

Stellt sich die Frage nach dem PHP-Cod Anfang <? oder<?php erstere ist in der php.ini deaktiviert um verwechselungen mit anderen Scriptsprachen zu vermeiden. Wäre zumindest eine möglichkeit warum die PhP-Seiten zum Download angeboten werden da sie in dem Fall nicht PHP-konform sind. Was an der Config geändert?
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: neuer Xamp führt kein php aus

Postby Hanspeter Thöni » 28. December 2009 17:47

Soweit ich weiss, wurde in XAMPP mit PHP 5.3 die Einstellung Short-Tags deaktiviert.
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Re: neuer Xamp führt kein php aus

Postby beckj » 29. December 2009 10:27

Ist ganz sicher das. Hatte das Problem auch. Habe dann konsequent <? in <?php geändert und seither is alles wieder OK.

Jürg
beckj
 
Posts: 4
Joined: 04. March 2007 11:26

Re: neuer Xamp führt kein php aus

Postby Robina » 29. December 2009 14:53

danke für die Hinweise,

Das Problem hatte eine recht "triviale" Lösung.

Durch mehrfaches Installieren und Deinstallieren verschiedener Versionen war wohl irgendwo ein Datenrest übrig gebleiben. So wurden einige .php5 ausgeführt einige nicht.
Als ich mit php anfing verlangte Strato noch die Endung php5 für den Online-Einsatzt von php5. So war dann auch alles programiert.
Ich habe jetzt überall die 5 gestrichen, (hatte da einiges nicht mitbekommen) und alles läuft nach kompletter Löschung/Deinstallation aller Xampps, Defragmentierung und Aufräumaktion. :D
Robina
 
Posts: 3
Joined: 28. December 2009 12:40


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests