Eine Mögichkeit, Fehler OS10038 zu beheben

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Eine Mögichkeit, Fehler OS10038 zu beheben

Postby RamonDave » 27. November 2009 15:44

Nach der Installation von XAMPP 1.7.2 funktionierte 'nichts', besser gesagt, Apache startete, war aber über localhost oder 127.0.0.1 nicht erreichbar. Der Fehler im error.log war dieser:
[error] (OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?
Und das, obwohl eigentlich IPv6 via Konfigurationsscript (besten Dank Apachefriends!) abgeschaltet war. Nun denn, eine Suche in diesem Forum ergab, daß eine Lösung das Anhängen von
Win32DisableAcceptEx
an die httpd.conf ist. Die Erklärung für diese Direktive gibt es hier (in Englisch): http://httpd.apache.org/docs/2.2/mod/mp ... leacceptex
Auf meinem Server (2003 32bit) benutze ich derzeit PCTools, weil es sonst anscheinend keinen anderen kostenlosen Virenscanner für Server gibt (funzt auch, crasht nur oft, suche Ersatz, hat nichts hiermit zu tun).

Nach einem Neustart war der Fehler beseitigt, es gab diesmal aber einen neuen Fehler:
[error] (OS 10038)An operation was attempted on something that is not a socket. : Too many errors in select loop. Child process exiting.
Die Suche nach einer Lösung war zunächst erfolglos und nach einigen Stunden habe ich diesen Tip gefunden:
In der DOS-Box diesen Befehl eingeben und Eingabetaste drücken:
netsh winsock RESET
Danach Windows neu booten und das Problem ist beseitigt, zumindest in meinem Fall. Die Erklärung hierfür gibt es hier (auch in Englisch): http://support.microsoft.com/kb/811259

Es kann durchaus sein, daß hiernach die Win32DisableAcceptEx Direktive nicht mehr benötigt wird. Das war in meinem Falle so, insofern habe ich die Zeile in der httpd.conf auskommentiert und Apache neu gestartet.

Da dieses Malheur einen ganzen Nachmittag verschwendet hat, dachte ich mir, es ist hilfreich, meine Erkenntnisse hier aufzuschreiben. Vielleicht hilft es ja jemandem.

Nur zu Information: ich hatte auf dem Server testweise den IBM Director Service installiert, der den Tivoli mit Tomcat installiert und sich nicht sauber (oder besser gesagt, gar nicht) deinstallieren ließ. Mit Hilfe des Revo Uninstaller habe ich zumindest die meisten Dinge wegbekommen, es kann aber durchaus sein, daß da irgendwas die Winsock durcheinandergewirbelt hat.
Ach ja, und den XAMPP 1.7.1 hatte ich installiert, aber der konnte sauberst deinstalliert werden und da glaube ich nicht, daß das der Grund war.
RamonDave
 
Posts: 3
Joined: 13. February 2009 02:50

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests