Apache startet nicht -> Win7

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht -> Win7

Postby nofear87 » 24. November 2009 23:21

Hallo,
ich habe folgendes Problem, habe Xampp (neuste Version) installiert,
wenn ich jedoch den Apache im Controlpanel starte, dann kommt unten erst Busy dann Apache started...aber das Grüne Symbol taucht nicht auf.
Und der Server ist auch nicht unter localhost bzw 127.0.0.1 zu erreichen.
Mysql hingegen startet ordnungsgemäß.
Habt ihr Hinweise für mich, wie ich dieses Proble beseitigen könnte.
Liebe Grüße
Robert
nofear87
 
Posts: 1
Joined: 24. November 2009 23:17

Re: Apache startet nicht -> Win7

Postby Stepke-DSL » 25. November 2009 07:45

Hallo,

Schau mal in die Logs und starte den Apache mal aus der Konsole heraus.

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Re: Apache startet nicht -> Win7

Postby sarvo » 26. November 2009 14:51

Ich hab genau das selbe Problem hab schon einiges Versucht und bin auch schon die Liste mit den Programmen durchgegangen.

Bei mehrmaligen klicken auf Apache starten kommt Fehlermeldung "terminating worker thread"
Der Systemdienst startet sich ebenfalls nicht.

Alle Ports sind frei, laut Xampp (neuste Version) Portcheck

Wenn ich Apache über die Console starten will, kommt nach einiger zeit einfach die Meldung das Apache nicht gestartet werden konnte.
In der Errog.log ist kein Eintrag .

Meine Programme auf Win7 Ultimate :

Sykpe -> Port ist umgestellt
Personal Antivir + Guard -> Guard war mal aus, gleicher Effekt
Windows Firewall -> Apache wird erlaubt
Mircosoft Visual Studio 2008 -> dort nur C++
Netzwerküberwachung hab ich ausgeschaltet
Benutzerkontosteuerung ist aus

Das komische ist, ich hab mir den Apache mal seperat runtergeladen und dort ist der Apache Service gestartet und ich konnte über localhost:8080 auf den Apache zugreifen.
Alle anderen XAMPP Dienste starten ganz normal
Wollte jetzt aber XAMPP benutzen, damit ich nicht die einzelnen Packete manuell installieren muss(PHP , MYSQL etc)
sarvo
 
Posts: 4
Joined: 26. November 2009 14:44

Re: Apache startet nicht -> Win7

Postby Wiedmann » 26. November 2009 15:17

sarvo wrote:Ich hab genau das selbe Problem

Stepke-DSL wrote:Schau mal in die Logs

--> "error.log" :?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht -> Win7

Postby sarvo » 26. November 2009 15:26

ja die error.log (xampp/apache/logs/error.log)

gibt es noch andere Logs indenen ich nachschauen könnte ?
sarvo
 
Posts: 4
Joined: 26. November 2009 14:44

Re: Apache startet nicht -> Win7

Postby Wiedmann » 26. November 2009 15:30

Welchen XAMPP hast du?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht -> Win7

Postby sarvo » 26. November 2009 15:32

Xampp (neuste Version)


also Version Win32 - 1.7.2
sarvo
 
Posts: 4
Joined: 26. November 2009 14:44

Re: Apache startet nicht -> Win7

Postby Wiedmann » 26. November 2009 15:36

Irgendwas in den Event Logs (Anwendung und System) von Windows?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht -> Win7

Postby sarvo » 26. November 2009 15:37

ich hab eben mal aus spaß xampplite drauf gemacht und JEEEEEEAHHHH

APACHE LÄUFT !

Aber woran liegst ?
sarvo
 
Posts: 4
Joined: 26. November 2009 14:44

Re: Apache startet nicht -> Win7

Postby xubble » 29. November 2009 12:16

Ich hatte auch das Problem... musst wirklich in der error.log Datei schauen. In meinem Fall war z.B. die Localhost Angabe ungültig. Schonmal xampp_setup ausgeführt?
xubble
 
Posts: 14
Joined: 25. July 2007 03:42
Location: Berlin


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests