Konfigurations file

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Konfigurations file

Postby Chris_ex_nihil » 06. November 2009 18:19

Liebe Xampp- Gemeinde,

Wir haben vor kurzem eine eine neue,dynamische Website bekommen die tadellos
im Web laeuft , der provider verwendet auch den Apachen;
Um nun diese Seiten auch local darstellen zu koennen habe ich es zuerst mit Xampp 1.7.1 wie
bei unserer alten Site die statisch war,versucht ,bekomme aber immer wieder unten stehende Fehlermeldung.
Unter 1.7.2 geht auch nichts - aber unter Wampp 1.1 laeuft sie gut ,von Problemen mit dem CMS abgesehen
die ich aber hier im moment nicht diskutierern moechte.
Die Meldung :

Warning: include(c: mpp\htdocs\admin\/config_sql.php) [function.include]: failed to open stream: Invalid argument in C:\xampp\htdocs\include\config.php on line 67

Diese Meldung ist noch laenger und bezieht sich auch noch auf die anderen 2 Config. files.
Das aufaellige : c: mpp........... ohne shlash und dem fehlenden Buchstaben ist das was mich irritiert da die konfigurationsdateien auf den vollstaendigen Pfad : C:\xampp\htdocs............umgeschrieben wurden.
Haette ich das nicht getan wuerden sie ja auch unter Wampp nicht laufen!

Vielleicht ist einem von Euch ja dieses problem schon einmal begegnet.

Gruesse von
Chris
Chris_ex_nihil
 
Posts: 3
Joined: 06. November 2009 17:51

Re: Konfigurations file

Postby Altrea » 06. November 2009 18:31

Hi,

könnte es sein, dass ein Teil deines Pfades als hexadezimalzahl interpretiert wird? Darauf deuten das fehlende \xa hin.
poste doch bitte mal deine include Anweisung wie sie in deinem Quelltext steht.

[edit]eine andere Möglichkeit wäre, dass der Backslash das x terminiert. In doppelten Anführungszeichen gibt es so ein paar Zeichen, die man nicht einfach so benutzen kann ohne sie zu terminieren ;)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Konfigurations file

Postby Chris_ex_nihil » 06. November 2009 19:21

guten abend Altrea,

Ich poste Dir mal die ganze Meldung ; ich glaube er findet schlicht den ROOT pfad
nicht.

Darunter setze ich mal die include Anweisungen aus dem Config files ,
...htdocs\include\config.php und ...htdocs\include\include.php die ja auch beanstandet sind.



(...htdocs\admin\config.php - und ...htdocs\admin\config_sql.php. gibt es auch noch; Die beiden sind wohl
fuer das CMS. )
Die Site ist noch neu fuer mich,sieh mir also nach das ich Dir nicht immer genaue Angaben machen kann.
Ich lebe und arbeite derzeit in Warschau und die Kommunikation mit dem Programmierer der ansonsten
sehr gute arbeit geleistet hat, gestaltet sich etwas schwierig fuer mich.



Warning: include(c: mpp\htdocs\admin\/config_sql.php) [function.include]: failed to open stream: Invalid argument in C:\xampp\htdocs\include\config.php on line 67

Warning: include() [function.include]: Failed opening 'c: mpp\htdocs\admin\/config_sql.php' for inclusion (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\include\config.php on line 67

Warning: require_once(c: mpp\htdocs\admin\/classes/mysql.class.php) [function.require-once]: failed to open stream: Invalid argument in C:\xampp\htdocs\include\include.php on line 43

Fatal error: require_once() [function.require]: Failed opening required 'c: mpp\htdocs\admin\/classes/mysql.class.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\include\include.php on line 43

____________________________________________________________________________________________

config .php Root und Main definition : define('_MAIN' , "c:\xampp\htdocs\/");

define('_ROOT' , "c:\xampp\htdocs\admin\/");


include: if(defined("_IS_MODULE")):

include _ROOT."config_sql.php";

else:

include _ROOT."config_sql.php";

______________________________________________________________________________

include\include require_once _CLASSES . "mysql.class.php";

require_once _CLASSES . "smarty/Smarty.class.php";


Danke fuer Deine Hilfe!

Chris
Chris_ex_nihil
 
Posts: 3
Joined: 06. November 2009 17:51

Re: Konfigurations file

Postby Altrea » 06. November 2009 19:30

Keine Angst, hier wird niemandem der Kopf abgerissen, der nach Hilfe fragt (zumindest nicht oft *g*).

Der Grund für den Fehler besteht wirklich darin, dass der Backslash in diesem Zusammenhang eine besondere Bedeutung einnimmt.
Das erkennst du ganz leicht, indem du nach deiner define-Funktion einfach mal den Wert ausgibst:
Code: Select all
define('_ROOT' , "c:\xampp\htdocs\admin\/");
echo _ROOT;


ersetze die doppelten Anführungszeichen in deiner define() Funktion mal durch einfache. Also so:
Code: Select all
define('_ROOT' , 'c:\xampp\htdocs\admin\/');


möglich wäre auch sowas hier, wenn auch etwas schwieriger zu lesen:
Code: Select all
define('_ROOT' , "c:\\xampp\\htdocs\\admin\/");


Wenn du noch Fragen hast, scheu dich nicht zu fragen :)
Ansonsten wünsche ich dir noch ein schönes Wochenende
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Konfigurations file

Postby Chris_ex_nihil » 06. November 2009 19:58

Vielen Dank Altrea,

Die einfachen Anfuehrungszeichen haben es gebracht, auf anhieb.

Ich habe keine einfache Loesung mehr angenommen nachdem ich tagelang mit unserem

Programmierer kommuniziert habe ,und das ohne Ergebnis .Da habe ich nicht mehr daran

geglaubt das es ganz easy im netz zu finden ist ,wie Wole ja nicht ganz unrecht hatte ,wenn ich auch

seine Art nicht mag zurechtzuweisen ohne Kenntnis des Hintergrundes.

also noch mal danke und alles gute von

chris_ex_nihil
Chris_ex_nihil
 
Posts: 3
Joined: 06. November 2009 17:51


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests