mysqli geht nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mysqli geht nicht

Postby chris_bbg333 » 26. October 2009 21:49

Hi,
so ein mist ich hab eine anfängerfrage die ich einfach nicht gebacken bekomme. will meine piwik auswertungen mit xampp machen. Ich bekomme folgende Fehlermeldung

Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.

Also ich muss mysqli irgendwie aktivieren, nur wie?
Ich habe in foren gelesen dass ich in php.ini die extensions einkommentieren muss. Funzt nicht. Biite helft mir was ich da machen muss. dankeschön
chris_bbg333
 
Posts: 12
Joined: 26. October 2009 21:44

Re: mysqli geht nicht

Postby Wiedmann » 26. October 2009 22:46

Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.

Sind alle 3 beim XAMPP aktiviert (siehe phpinfo()).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: mysqli geht nicht

Postby chris_bbg333 » 27. October 2009 09:55

Hallo Wiedmann,
erstmal Danke. Also bei mir kommt die Fehlermeldung. Ich habe das normale xampp, also kein xampp light. Das System ist Windows XP, SP 2.
hmm wo ist dann der Haken wenn es eigentlich schon aktiviert sein müsste?
da hänge ich irgendwie...
Danke
chris_bbg333
 
Posts: 12
Joined: 26. October 2009 21:44

Re: mysqli geht nicht

Postby Wiedmann » 27. October 2009 14:40

wenn es eigentlich schon aktiviert sein müsste?

"müsste" ... also hast du das jetzt noch nicht mit phpinfo() verifiziert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: mysqli geht nicht

Postby chris_bbg333 » 27. October 2009 15:24

sorry ich versteh das nicht ganz.
phpinfo() verifiziert?

also ich habe mal in dem ordner php in die datei php.ini geschaut und manche
extensions= ....
waren durch einen strichpunkt auskommentiert. ich habe das aber so gelassen, also alles standardeinstellung. vielelicht kannst du nochmal schreiben was ich tun muss damit dieses mysqli funktioniert. danke
chris_bbg333
 
Posts: 12
Joined: 26. October 2009 21:44

Re: mysqli geht nicht

Postby Wiedmann » 27. October 2009 17:06

also ich habe mal in dem ordner php in die datei php.ini geschaut und manche

Du sollst im Browser auf http://localhost/xampp/phpinfo.php gehen, und dort schauen ob es Abschnitte für MySQLI und/oder PDO_mysql gibt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: mysqli geht nicht

Postby chris_bbg333 » 28. October 2009 10:23

danke ;)
beide bereich e gibt es. für pdo_mysql ist version 5.1.37 enables,
für mysqli genauso.
klingt so also ob es mit xampp nichts zu tun hat. aber bei der installation von piwik bekomme ich bei der systemüberprüfung die fehlermeldung. weis auch nicht weiter.
gruß
chris_bbg333
 
Posts: 12
Joined: 26. October 2009 21:44


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests