Include Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Include Problem

Postby Lukii91 » 11. October 2009 10:33

Hallo,

ich benutzt (leider) Windows Vista und bin am verzweifeln.

Xampp funktioniert einwandfrei, doch er includet meine Dateien nicht.

Es erscheint auf der Seite KEINE Fehlermeldung aber im Quellcode steht der volle PHP-Script.

Hat jemand dafür ne erklärung wie ich das hinbekomme?

Lg Lukii91
Lukii91
 
Posts: 2
Joined: 11. October 2009 10:28

Re: Include Problem

Postby Nobbie » 11. October 2009 11:00

Nicht "<?" sondern "<?php" verwenden.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Include Problem

Postby Lukii91 » 11. October 2009 11:06

Danke! Hat funktioniert.

Gibt es dafür auch einen Grund, warum das unter Vista nur mit <?php läuft?
Lukii91
 
Posts: 2
Joined: 11. October 2009 10:28

Re: Include Problem

Postby Nobbie » 11. October 2009 14:10

Lukii91 wrote:Danke! Hat funktioniert.

Gibt es dafür auch einen Grund, warum das unter Vista nur mit <?php läuft?


Nö, das hat mit Vista überhaupt nichts zu tun. Das ist einfach eine Einstellung in php.ini und nennt sich short_open_tag
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Include Problem

Postby weboase » 12. October 2009 21:03

Hallo,

danke vielmals, ich hatte genau gleiches problem - exact mit windows vista! jetzt habe ich in der php.ini short_open_tag auf on geändert und es hat geholfen...

ich habe fast 4 tagen gebraucht es herauszufinden !!!!

Es liegt wirklich am windows vista, es ist offensichtlich so, da ich 2 maschinen benutze... eine ist mit XP und da gabs dieses problem nicht, alles gleich selbe xampp - selbe script .

die andere ist mit vista, die mit vista habe ich mir vor kurzem gekauft... und als ich wollte da mit xampp ein script starten es kamm immer so eine meldung "Fatal error: Call to undefined function". weil kein include funktionierte...

so sah dieser fehler bei mir aus:

0) { extract(${'HTTP_' . $type . '_VARS'}, EXTR_OVERWRITE); }}} include("config.inc.php"); include("core.class.php"); include("del_ins.php"); $checkID = md5(microtime()); $logcheckID = md5(microtime()); $town = str_replace("_","",$_GET[ort]); $town = ucfirst($town); ?> .">

Fatal error: Call to undefined function genURL() in C:\xampp\htdocs\webseiten\kleinanzeigen-abisz\menubar.php on line 7
weboase
 
Posts: 5
Joined: 12. October 2009 20:40


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests