XAMPP und 2 Rechner

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP und 2 Rechner

Postby kdw-online » 29. September 2009 11:57

Hallo

Ich habe folgendes Problem

Ich nutze insgesamt 3 Rechner

1 Rechner - zum Arbeiten für das Büro/zu Hause
1 Netbook - nur für E-Mail und Daten
1 Notebook - für das Arbeiten Unterwegs (Wochenendhäuschen)

nun mein eigentliches Problem
das Notebook und der Rechner sind Identisch eingerichtet (eigentlich 1:1) gleiche Laufwerke, gleiche Programme und gleiche entsprechende Pfade
das Netbook ist bisher nur für die E-Mails da gewesen und für wichtige Daten

nun will ich aber das Netbook auch für den Server (XAMPP) einrichten
auf diesen Netbook soll am Ende auf PLatte 2 nur das Verzeichnis "htdocs" vom Server sein

Auf dem Notebook und den Rechner sind jeweils XAMPP installiert und wenn ich dann beim Rechner "localhost" eintippse soll die
Daten (Webseite, Scripte) vom Netbook geholt werden

Ich bekomme das nicht hin, auf dem Netbook habe ich die 2. Platte freigegeben
und dann diese Platte auf dem Rechner sowie den Notebook als Netzwerklaufwerk eingerichtet
dieses Laufwerk (S) habe ich dann in der httpd.conf an entsprechender Stelle eingegeben
allerdings startet der Apache nicht....

Kann jemand helfen wenn jemand verstanden hat...was ich hier geschrieben habe...

unten mal eine Skizze
Image
kdw-online
 
Posts: 17
Joined: 30. September 2004 07:55

Re: XAMPP und 2 Rechner

Postby Nobbie » 29. September 2009 14:18

und dann diese Platte auf dem Rechner sowie den Notebook als Netzwerklaufwerk eingerichtet
dieses Laufwerk (S) habe ich dann in der httpd.conf an entsprechender Stelle eingegeben
allerdings startet der Apache nicht....


Laufwerksmapping wird ja erst nach dem Booten und Einloggen durch einen Windowsbenutzer betrieben. Zu diesem Zeitpunkt sind die Dienste (Apache usw.) schon längst gestartet. Mit anderen Worten: wenn Apache via Dienst gestartet wird, gibt es kein Laufwerk S: - und das steht als Fehlermeldung sicherlich auch im error_log (wenn Du da hineingeschaut hättest).

Entweder mußt Du bei der htdocs-Angabe statt des Laufwerks den Freigabename angeben ('//Netbookname/Freigabe/htdocs' ), oder Du startest Apache nicht als Dienst beim Booten, sondern direkt aus der Xampp Controlbox heraus.

Wenn Du Apache als Dienst starten willst, mußt Du außerdem berücksichtigen, dass Apache normalerweise vom User "System" ausgeführt wird, der ggf. weniger Rechte hat als der eingeloggte User, um auf die Freigabe //Netbookname/Freigabe/htdocs zuzugreifen. Von daher ist es in jedem Fall unproblematischer, Apache nicht als Dienst zu starten, sondern manuell. Dann wäre auch die Angabe das Laufwerksbuchstaben S: möglich.

So oder so: immer erst einmal in den error_log schauen, wenn etwas nicht funktioniert - dazu ist er da.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests