Tomcat startet nicht aus Eclipse heraus

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Tomcat startet nicht aus Eclipse heraus

Postby Raphalon » 23. September 2009 14:39

Hallo,

ich verwende den Apache Tomcat/6.0-snapshot mit JVM Version 1.5.0_20-b02 unter Windows XP Version 5.1. Dazu habe ich Eclipse installiert und möchte dort einen Server erstellen und starten, welcher auf den Tomcat zeigt. Erstellen kann ich den Server, aber beim Starten kommt folgende Fehlermeldung

Code: Select all
23.09.2009 15:27:39 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Programme\Java\jdk1.6.0_16\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:/Programme/Java/jdk1.6.0_16/bin/../jre/bin/client;C:/Programme/Java/jdk1.6.0_16/bin/../jre/bin;C:\Programme\Java\jdk1.6.0_16\bin;C:\Programme\oracle10\bin;C:\Programme\oracle10\jre\1.4.2\bin\client;C:\Programme\oracle10\jre\1.4.2\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\IDM Computer Solutions\UltraEdit-32;C:\Programme\Java\jdk1.6.0_16\bin;C:\Programme\Maven\apache-maven-2.2.1\bin
java.lang.reflect.InvocationTargetException
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
Caused by: java.lang.UnsatisfiedLinkError: org.apache.tomcat.jni.Pool.create(J)J
   at org.apache.tomcat.jni.Pool.create(Native Method)
   at org.apache.tomcat.util.net.AprEndpoint.init(AprEndpoint.java:589)
   at org.apache.coyote.http11.Http11AprProtocol.init(Http11AprProtocol.java:107)
   at org.apache.catalina.connector.Connector.initialize(Connector.java:1058)
   at org.apache.catalina.core.StandardService.initialize(StandardService.java:677)
   at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:795)
   at org.apache.catalina.startup.Catalina.load(Catalina.java:535)
   at org.apache.catalina.startup.Catalina.load(Catalina.java:555)
   ... 6 more


Was muß ich da einbinden? Mir ist zwar klar, daß diese Frage eher in ein Eclipse - Forum gehört, aber vermutlich hat das Problem hier schon jemand gelöst.

Gruß,

Raphalon
Raphalon
 
Posts: 5
Joined: 23. September 2009 14:33

Re: Tomcat startet nicht aus Eclipse heraus

Postby Raphalon » 29. September 2009 12:47

Hallo nochmal,

habe wohl die falsche "Fehlermeldung" gepostet. Hier die "richtige". Ich wäre sehr dankbar über Hinweise.

Code:
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
Caused by: java.lang.UnsatisfiedLinkError: org.apache.tomcat.jni.Pool.create(J)J
at org.apache.tomcat.jni.Pool.create(Native Method)
at org.apache.tomcat.util.net.AprEndpoint.init(AprEndpoint.java:589)
at org.apache.coyote.http11.Http11AprProtocol.init(Http11AprProtocol.java:107)
at org.apache.catalina.connector.Connector.initialize(Connector.java:1058)
at org.apache.catalina.core.StandardService.initialize(StandardService.java:677)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:795)
at org.apache.catalina.startup.Catalina.load(Catalina.java:535)
at org.apache.catalina.startup.Catalina.load(Catalina.java:555)
... 6 more

Kann mir da jemand helfen? Wenigstens einen Hinweis? Die Servereinstellungen unter Eclipse habe ich variiert, doch hat das nichts gebracht. Der Tomcat allein läßt sich vom xampp - Control aus ohne Probleme starten.

Edigno
Raphalon
 
Posts: 5
Joined: 23. September 2009 14:33


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests