Windows 7 64 bit und xampp funzt nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows 7 64 bit und xampp funzt nicht!

Postby DJ4Zappa » 20. September 2009 19:50

hallo gemeinde,

bevor jetzt wieder haufenweise leute auf die "suchfunktion" hinweisen; ich habe diese bemüht, aber leider nix gefunden (auf den ersten 5 seiten (von 330).

folgendes: habe windows 7 ultimate 64 auf meinem rechner: xampp läuft zwar halbwegs, aber in joomla 1.5 kommen massenweise fehlermeldungen im text (den man nicht löschen kann).

ebenso läuft kein apache, wenn man xampp 1.7.2 normal installiert (habe natürlich den kompatibilitätsmodus ausgereizt).

wie kann ich also unter WIN 7 64 eine vernünftige serverumgebung für meine joomla webseiten erreichen? am liebsten würde ich hier xampp nehmen...aber das geht ja leider nicht wie gewünscht.

ich freue mich auf die antworten

lg

zappa
DJ4Zappa
 
Posts: 1
Joined: 20. September 2009 19:37

Re: Windows 7 64 bit und xampp funzt nicht!

Postby Wiedmann » 20. September 2009 20:19

ebenso läuft kein apache, wenn man xampp 1.7.2 normal installiert

Was bedeutet "normal installiert", bzw. wie hast du ihn dann "unnormal" installiert damit er läuft?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows 7 64 bit und xampp funzt nicht!

Postby zwaen » 09. October 2009 18:00

Hallo,
ich habe das gleiche problem mit Windows 7 Pro x86.
bekomme ebenfalls bei joomla 1.5 fehlermeldungen angezeigt.
wäre für hilfe dankbar.
zwaen
 
Posts: 2
Joined: 09. October 2009 17:58

Re: Windows 7 64 bit und xampp funzt nicht!

Postby Dungeonwatcher » 09. October 2009 18:11

Hi! 8)

Nicht Xampp ist "schuldig", sondern das extrem unsauber programmierte Joomla. Ich habe Joomla mal Testweise unter Xampp 1.7.1 und XP Pro am laufen gehabt und wurde bei jedem Seitenaufruf mit Warnungern nur so zugesch****n. Seitdem flog es wieder vom Rechner. Vor ca. 2 Jahren hatte ich die Joomla Programmierer mal darauf angesprochen dieses System mal langsam W3C valide zu gestalten und wurde daraufhin aus deren Forum "geekelt". Nee, Joomla hat sich seitdem nicht zum besseren entwickelt.

Bye
User avatar
Dungeonwatcher
 
Posts: 94
Joined: 15. August 2007 02:53
Operating System: XP

Re: Windows 7 64 bit und xampp funzt nicht!

Postby zwaen » 09. October 2009 18:26

hi,
deine antwort hilft mir leider nicht weiter :/
wie oder wo kann ich denn die fehlermeldungen abschalten? das würde mir ja erstmal weiterhelfen...
zwaen
 
Posts: 2
Joined: 09. October 2009 17:58

Re: Windows 7 64 bit und xampp funzt nicht!

Postby Dungeonwatcher » 09. October 2009 20:07

Hi! 8)

zwaen wrote:wie oder wo kann ich denn die fehlermeldungen abschalten?


Fehlermeldungen haben einen Sinn und sollten nicht abgeschaltet/ignoriert werden denn sie weisen oft auf Sicherheitsprobleme hin :!: :!: :!:
Nerve die Programmierer von Joomla mit diesem Problem bis diese es begriffen haben und beseitigen.

Suche in der php.ini einfach nach display_errors.

Bye
User avatar
Dungeonwatcher
 
Posts: 94
Joined: 15. August 2007 02:53
Operating System: XP

Re: Windows 7 64 bit und xampp funzt nicht!

Postby Nobbie » 09. October 2009 21:54

zwaen wrote:hi,
deine antwort hilft mir leider nicht weiter :/


Dann heul nicht hier herum, sondern im Joomla Forum: die haben diesen grausamen Schrott verbrochen. Ich habe mich auch notgedrungenerweise wegen dieser Fehlermeldungen der letzten Wochen ein wenig in den Source eingearbeitet und bin entsetzt! Wer so einen Sch**ß zusammenschustert, soll sich auch um die geplagten Anwender kümmern.

Es ist schon unglaublich, dass PHP vormals diesen ganzen Müll hat durchgehen lassen.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: Windows 7 64 bit und xampp funzt nicht!

Postby brunick » 11. October 2009 12:36

hallo,
ich habe windows 7 pro (64 bit und 32 bit) mit xampp und php 5.3 ausprobiert und muss sagen das ich einigermaßen unzufrieden bin..
ich weiß nicht was da schiefläuft, aber diverse selbstprogrammierte scripts crashen meinen kompletten server, nicht mal sql abfragen laufen einigermaßen flüssig...

da mein provider auch geschrieben hat, das er erstmal nicht auf php 5.3 umsteigen wird hab ich wieder auf 5.2 umgestellt, alles läuft und das unter windows 7 ohne kompatibilitätsmodus.
ich werd in der nächsten zeit mal den changelog durchgehen, was und warum sich das geändert hat... ich hab kein bock, alle meine scripte neuzuschreiben, aber allein die short tags umschreiben nervt schon...
brunick
 
Posts: 1
Joined: 11. October 2009 12:20

Re: Windows 7 64 bit und xampp funzt nicht!

Postby JuliusCaesar » 11. November 2009 23:30

also bei mir kann ich noch nicht mal apache und sql starten
ich kann zwar auf den Start Button drücken aber da passiert dann nix :shock:

mfg Julius :)
JuliusCaesar
 
Posts: 14
Joined: 30. January 2007 12:15

Re: Windows 7 64 bit und xampp funzt nicht!

Postby Rkan » 17. December 2009 02:32

Hey leutz hab mich wegen diessen beitrag hier angemeldet ich hab das problem auch dadurch kann ich leider nimmer richtig arbeiten..

wie ich bemerkt habe liegt es net an scripten sondern an den apache und php modulen die nicht richtig gestarten werden können

ich habe vielle script benutzt nur um zutesten ob die fliessend laufen
ausser prestashop und mein kleines eigenes script sind gelaufend
ich habe
joovili installiert ging nicht irgend welche fehler meldungen
dolphin ging auch nicht
joomla ging nicht
vivvo ging nicht
magento ging nicht
social engine ging nicht
wordpress ging aber sehhr problematich ging er zum laufen
vbulletin ging auch nicht..
und bitte glaubt mir ich habeee viel viell mehrere scripts aus probiert die nicht zum laufen karmen.. sogar paar script die ich selbs programiert habe sind laufen nicht ich habe dann xampp komplet gelöscht hab wampserver installiert und bei ihn ging die nicht da muss doch einer ein lösung finden oder muss ich sonts wieder zu vista umsteigen =(
Rkan
 
Posts: 5
Joined: 17. December 2009 02:23


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests