Windows 7 - htdocs auf Partition legen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows 7 - htdocs auf Partition legen

Postby Blacksorrow » 27. August 2009 08:05

Moinsen, ich hoffe mal ihr könnt mir weiterhelfen.

Ich hab mir grad mal ein frisches Windows 7 System aufgesetzt und xampp auf einer Partition für Projekte installiert. Soweit funktioniert das ganze auch, also ich kann über localhost den voreingestellten htdocs Ordner problemlos aufrufen.

Ich möchte nun jedoch das Verzeichnis auf die Partition legen. Dazu habe ich die Angabe DocumentRoot in der httpd.conf angepasst. (von D:\xampp\htdocs auf D: bzw D:\ - beides probiert) und eine dummy index.php Seite erstellt.

Leider bekomme ich beim Aufruf nur eine Fehlermeldung, dass nicht darauf zugegriffen werden kann. Also habe ich bei den Eigenschaften bei Sicherheit die Zugriffsberechtigungen für alle User die man da auswählen kann auf Vollzugriff erweitert. Mit ebenso wenig Erfolg habe ich die Benutzerkontensteuerung deaktiviert.

Habe zu Testzwecken auch innerhalb des xampp Verzeichnisses einen 2. Ordner "htdocs2" erstellt und versucht die DocumentRoot darauf zu legen. Ging leider auch nicht.

Wie schaffe ich es, dass ich auf die komplette Partition per localhost mit directory listing zugreifen kann?
Blacksorrow
 
Posts: 2
Joined: 27. August 2009 07:57

Re: Windows 7 - htdocs auf Partition legen

Postby Nobbie » 27. August 2009 10:38

>Dazu habe ich die Angabe DocumentRoot in der httpd.conf angepasst. (von D:\xampp\htdocs auf D: bzw D:\ - beides probiert) und eine dummy index.php Seite erstellt.

Das genügt ja nicht, wie Du wissen solltest. Schau in die httpd.conf und suche mal den Begriff "htdocs", der steht noch an einer anderen Stelle, wo die Zugriffsrechte definiert werden. Das musst Du auch anpassen.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Windows 7 - htdocs auf Partition legen

Postby Blacksorrow » 27. August 2009 17:31

ah, mist... ja dummer fehler.. da kann ich natürlich lange an allen möglichen anderen schrauben drehen -.-

falls jemand das gleiche problem haben sollte und hier auf diesen thread stößt:

1. Schritt
An 2 Stellen in der httpd.conf den Pfad anpassen:
DocumentRoot "D:/"
<Directory "D:/">

2. Directory Listing aktivieren (sofern gewünscht ist die Ordnerstruktur abzubilden)

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

ändern in

<Directory />
Options Indexes
AllowOverride None
Order deny,allow
Deny from all
</Directory>
Blacksorrow
 
Posts: 2
Joined: 27. August 2009 07:57


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests