href link problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

href link problem

Postby pete-bremen » 25. August 2009 23:44

Hallo,

bis vor kurzem ging noch alles, doch nun kann ich, nachdem ich eine Datei in einem anderen Verzeichnis umverlegt habe, einige links <a href="file.php">Name</a> nicht mehr anklicken - weder offline, noch online. Woram könnte das liegen ?
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57

Re: href link problem

Postby Nobbie » 26. August 2009 10:18

Nicht einmal "anklicken"? Dann ist wahrscheinlich die Maus kaputt.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: href link problem

Postby pete-bremen » 26. August 2009 10:25

Nobbie wrote:Nicht einmal "anklicken"? Dann ist wahrscheinlich die Maus kaputt.

Nein, überall sonst geht es, gar in anderen Verzeichnissen, und online auf anderen Seiten - aber auf einer einfachen Seite geht es auch, und bislang ging es eh immer - doch nun plötzlich - warum auch immer, geht es nicht mehr. Selbst die "Hand" erscheint noch nicht einmal mit dem, über dem an zu klickenden Link.

Also, wenn ich eine einfache index Datei in php, oder html mit <a href=".">Name</a>mache, geht es - doch habe ich einige includes, und div´s mit drin, und rund um den Inhalt noch Infos und auch gar anklickbare links, die in den oberen reihen, doch nicht mehr aber der zweiten <tr> Reihe liegen, gehen sie nicht ...... Mit anderen Worten, einige kann ich anklicken, andere nicht. Hatte nun zwischendurch auch den xampp 1.7.2 darauf, aber wieder deinstalliert und gar die Platte (Datenplatte zweitplatte), noch extern formatiert vorher - und mit 1.6.4 geht´t immer noch nicht wieder normal. Woran kann das liegen ?
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57

Re: href link problem

Postby Nobbie » 26. August 2009 11:25

Da wird sicherlich fehlerhaftes HTML generiert - aber mangels Beispiel und mangels Sourcecode kann ich da nicht mehr zu sagen. Kann ich die Seite irgendwo anschauen?
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: href link problem

Postby pete-bremen » 26. August 2009 12:31

Nobbie wrote:Da wird sicherlich fehlerhaftes HTML generiert - aber mangels Beispiel und mangels Sourcecode kann ich da nicht mehr zu sagen. Kann ich die Seite irgendwo anschauen?

Ja, http://ording.h4f.biz/politisches/ da ist ganz unten auf der Seite und oben in dem Mittleren Menue was nicht ok. Meine Ziele kann ich niht anklicken,obwohl "organisieren" geht. Und unten in der Seite ist GG Art. 20 und darunter Regeln geht auch nicht.
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57

Re: href link problem

Postby pete-bremen » 26. August 2009 12:47

ich stelle gerade fest, in einem anderen Verzeichnis geht es gar bis jetzt alles.
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57

Re: href link problem

Postby Nobbie » 26. August 2009 13:11

Das generierte HTML ist der schimmste Schrott (sorry) den ich je gesehen habe. Da fehlt die Hälfte (es gibt keine <html> TAGs und keinen <body> Tag usw.), da werden kreuz und quer wüßt irgendwelche Tags geöffnet (<font>, <b> usw.) aber nicht geschlossen, andere werden geschlossen, die nirgends geöffnet wurden, in Tabellen (<table>..) steht irgendein Code drin, ohne dass vorher <tr> und/oder <td> steht, da werden mit <iframes> innerhalb solcher kaputten Tabellen andere Inhalte angezeigt - GRAUSAM!!!

Mich wundert, dass da überhaupt irgendwas angezeigt wird.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: href link problem

Postby pete-bremen » 26. August 2009 13:18

Nobbie wrote:Das generierte HTML ist der schimmste Schrott (sorry) den ich je gesehen habe. Da fehlt die Hälfte (es gibt keine <html> TAGs und keinen <body> Tag usw.), da werden kreuz und quer wüßt irgendwelche Tags geöffnet (<font>, <b> usw.) aber nicht geschlossen, andere werden geschlossen, die nirgends geöffnet wurden, in Tabellen (<table>..) steht irgendein Code drin, ohne dass vorher <tr> und/oder <td> steht, da werden mit <iframes> innerhalb solcher kaputten Tabellen andere Inhalte angezeigt - GRAUSAM!!!

Mich wundert, dass da überhaupt irgendwas angezeigt wird.

Naja, wie perfekt, oder schlecht das ist, ist ja im prinzip irrelevant - wenn´s halt funktioniert. Und das das Schrott ist, mag auch noch sein, ich bin ja auch kein Webdesigner, sondern versuche nur mein bestes - was leider oft nicht funktioniert. Aber die Abschließungen sind doch auch gar nicht notwendig, wie ich gemerkt habe, oder ? Aber ne Tabelle ohne <td> drin, geht doch gar nicht - habe ich mal festgestellt. Aber, weißt Du nun, wo der Fehler liegen mag ? Wie kann es sein, das es in einem Verzeichnis geht, und in nem anderen wiederum nicht ?
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57

Re: href link problem

Postby Nobbie » 26. August 2009 13:34

Natürlich spielt das eine Rolle, ob HTML Tags geschlossen werden oder nicht. Deine Seite ist so "kaputt" programmiert, dass es unmöglich ist, vorherzusagen, was da ein Browser anzeigen wird.

Das Problem mit den nicht anklickbaren Links hat etwas mit dem Menu zu tun, was links eingeblendet werden kann. Das scheint mir ein CSS-gesteuertes Menu zu sein, welches mittels <div>-Anweisungen die Untermenus aufbaut. Diese überlappen (unsichtbar) die nicht anklickbaren Links.

Möglicherweise wird in einem anderen Verzeichnis das Menu links gar nichts erst aufgebaut oder angezeigt - das würde erklären, warum manchmal die Links anklickbar sind.

Fakt ist, dass Du diese Seiten neu (und sauber!) erstellen mußt; du bist jetzt an einem Punkt angelangt, wo es so chaotisch wird, dass Du keine gezielten Verbesserungen mehr machen kannst, weil man den Wald vor lauter Bäumen nicht mehr erkennen kann.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04

Re: href link problem

Postby pete-bremen » 26. August 2009 13:44

Nobbie wrote:Natürlich spielt das eine Rolle, ob HTML Tags geschlossen werden oder nicht. Deine Seite ist so "kaputt" programmiert, dass es unmöglich ist, vorherzusagen, was da ein Browser anzeigen wird.

Das Problem mit den nicht anklickbaren Links hat etwas mit dem Menu zu tun, was links eingeblendet werden kann. Das scheint mir ein CSS-gesteuertes Menu zu sein, welches mittels <div>-Anweisungen die Untermenus aufbaut. Diese überlappen (unsichtbar) die nicht anklickbaren Links.

Möglicherweise wird in einem anderen Verzeichnis das Menu links gar nichts erst aufgebaut oder angezeigt - das würde erklären, warum manchmal die Links anklickbar sind.

Fakt ist, dass Du diese Seiten neu (und sauber!) erstellen mußt; du bist jetzt an einem Punkt angelangt, wo es so chaotisch wird, dass Du keine gezielten Verbesserungen mehr machen kannst, weil man den Wald vor lauter Bäumen nicht mehr erkennen kann.

Verstehe - scheiße, die Befürchtung hatte ich auch schon - mist. Und wenn ich hier und dort mal nen Hinweis für nen Code brauchen könnte, wärest Du bereit, mir dabei auch zu helfen - mir den einen, oder anderen Code dafür zu geben, oder ne Einstellung zu nennen ?
pete-bremen
 
Posts: 6
Joined: 25. August 2009 21:57


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests