PHP in anderem DocumentRoot wird nicht geparst

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP in anderem DocumentRoot wird nicht geparst

Postby seek » 17. August 2009 18:44

Hi,

ja - so sieht das aus. Ich bin beim Lesen irgendwo gestolpert über "PHP wird ausgeführt in den Ordner X und Y" (kein genauer Wortlaut). X ist der DocumentRoot nach der Installation.

Ich habe einen VHost:

<VirtualHost *:8080>
ServerAdmin mail@domain.tld
DocumentRoot C:\data\htdocs\8080
ServerName *
</VirtualHost>

Auch einen Listener auf Port 8080.

Defacto so, wie ich es vorher hatte. Aber anscheinend doch nicht. Ich kriege zwar eine Seite, die wird aber nicht geparst. Warum? phpMyAdmin funktioniert tadellos. Wie bekomme den dazu, nicht nur im Standard-DocumentRoot php zu parsen?

Dank' euch
seek
 
Posts: 4
Joined: 17. August 2009 18:33

Re: PHP in anderem DocumentRoot wird nicht geparst

Postby seek » 18. August 2009 11:55

Hi,

jetzt habe ich ein wirklich interessantes Verhalten:

meine Anwendung wird "so halb" geparst. Sowas habe ich noch nie gesehen. Ich sehe den kompletten Quellcode der Includes, doch dann plötzlich eine PHP-Fehlermeldung, dass eine Klasse nicht gefunden wurde: Fatal error: Class '...' not found in ... on line ...

Ich will nicht sagen, dass ich am Verzeifeln bin, doch irgendwie kommt mir das spanisch vor. Was mache ich falsch? Bzw. was muss ich richtig machen? Kennt das jemand?

viele Grüße
seek
 
Posts: 4
Joined: 17. August 2009 18:33

Re: PHP in anderem DocumentRoot wird nicht geparst

Postby seek » 18. August 2009 12:35

Gelöst! Ich geh' am Stock!

Ich habe jetzt mal die alte php.ini geöffnet und geschaut, was da bei short_open_tag steht.

Na? Was stand in der alten Version als Standard da?

ON

Und was steht in der neuen Version an dieser Stelle?

OFF

Das wars. Ich habe fertig.

Danke für eure Hilfe.
seek
 
Posts: 4
Joined: 17. August 2009 18:33


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests