Nach Update 170 - 171 startet apache nicht mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Nach Update 170 - 171 startet apache nicht mehr

Postby MasterJM » 11. August 2009 12:03

Hallo,

habe schon etwas gesucht und gelesen, aber bis lang nichts passendes gefunden.
Ich habe gerade meinen XAMPP per Update (EXE Installer) von 1.7.0 auf 1.7.1 updated.
Jetzt startet mein apache nicht mehr. Das Control Panel meldete gar nichts,
hab dann die Bat versucht, dort kam folgendes:
Apache 2 is starting ...
httpd.exe: Syntax error on line 480 of F:/XAMPP/apache/conf/httpd.conf: Syntax error on line 7 of F:/XAMPP/apache/conf/extra/
httpd-xampp.conf: API module structure 'php5_module' in file F:/XAMPP/apache/bin/php5apache2.dll is garbled - expected signature 41503232 but saw 41503230 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?
Apache konnte nicht gestartet werden
Apache could not be started


Installiert hatte ich damals die Version "xampp-win32-1.6.6a-installer.exe"
und dann halt nach und nach mal updated.

Wo liegt das Problem bzw. wie kann ich es fixen?

Danke, Gruß

PS: Xampp rennt auf Windows XP SP3
MasterJM
 
Posts: 10
Joined: 04. December 2006 13:59

Re: Nach Update 170 - 171 startet apache nicht mehr

Postby Wiedmann » 11. August 2009 12:06

Syntax error on line 7 of F:/XAMPP/apache/conf/extra/httpd-xampp.conf: API module structure 'php5_module' in file F:/XAMPP/apache/bin/php5apache2.dll is garbled

Da sollte die Datei "php5apache2_2.dll" geladen werden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Nach Update 170 - 171 startet apache nicht mehr

Postby MasterJM » 11. August 2009 12:09

Argh, sorry war ja klar.... so bald ich poste finde ich was.

Scheinbar ist der Fehler so behebbar:
In der XAMPP\apache\conf\extra\httpd-xampp.conf
folgendes finden
LoadModule php5_module "/xampp/apache/bin/php5apache2.dll"
und durch
LoadModule php5_module "/xampp/apache/bin/php5apache2_2.dll"
ersetzen.

Jetzt rennt der Apache wieder.


EDIT:
ja - gerade selber gefunden, - in deinem Posting.
Danke! :)
MasterJM
 
Posts: 10
Joined: 04. December 2006 13:59


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests