xampp startet nicht mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp startet nicht mehr

Postby Kirzz » 28. July 2009 10:42

Hallo im Forum

Ich nutze xampp seit einigen Jahren und hatte nie Probleme.

Leider habe ich jetzt eines, dass ich nicht gelöst bekomme.
Wenn ich die xampp_start.exe starte popt das Fenster auf (Starting "Xampp"...), und verschwindet gleich wieder.
Ich vermute, das ich vergessen habe das xampp_stop.exe zu starten, bevor ich den Rechner herunter gefahren habe. Ich denke die Ports sind belegt und xampp lässt sich daher nicht starten???

Was kann ich tun?

Vielen Dank im Voraus!

ps: Derzeit nutze ich die aktuelle xampp 1.7.1 (ZIP-Archiv)
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Wiedmann » 28. July 2009 11:42

Was passiert wenn du die Server separat mit den Batchdateien startest?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp startet nicht mehr

Postby Kirzz » 28. July 2009 12:34

Was passiert wenn du die Server separat mit den Batchdateien startest?

Ich habe Apache über die apache_start.bat gestartet, und es funktioniert. Das DOS-Cmd-Fenster bleibt stehen und Apache ist aktiv. Ich habe es über apache_stop.bat dann wider beendet, und:

Ich habe es danach noch einmal über die xampp_start.exe probiert, aber das DOS-Cmd-Fenster schließt sich wie gehabt. Ich habe trotz dieses Umstandes den Browser geöffnet und http://localhost/ eingegeben, und siehe da - im XAMPP-Status ist MySQL bis Server Side Includes als "AKTIVIERT" gekennzeichnet. Mir fehlt nur das DOS-Cmd-Fenster, das will nicht offen stehen bleiben und bringt außer Starting "Xampp"... keine weiteren Meldungen, ...

Das über apache_start.bat gestarte DOS-Cmd-Fenster hingegen bleibt stehen.
Ist es in Version 1.7.1 vielleicht so geregelt, dass das Fenster verschwindet, ich meine, wirklich brauchen tut's ja niemand?
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Wiedmann » 28. July 2009 16:07

Ist es in Version 1.7.1 vielleicht so geregelt, dass das Fenster verschwindet,

Yup. Die *.exe Dateien in \xampp schließen sich nach Ausführung. In den Batchdateien steht dagegen am eine ein "pause" drin, so bleiben die geöffnet.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp startet nicht mehr

Postby Kirzz » 28. July 2009 18:20

Danke, gut zu wissen!
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Kirzz » 03. August 2009 14:39

Ich habe wieder das gleiche Problem wie anfangs. Ich kriege XAMPP nicht gestartet. Keine Fehlermeldung, nichts.

Ich habe es über die .exe, wie auch über die .bat-Dateien versucht, ich bekommen es nicht mehr gestartet. Ist es vielleicht möglich ältere XAMPP-Versionen zu downloaden, die neue läuft bei mir einfach nicht?

Falls im Hintergrund noch etwas aktiv ist, was den Start verhindert, gibt es ein Tool mit dem ich laufende XAMPP-Prozesse vollständig beenden kann?
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Wiedmann » 03. August 2009 14:43

Ich kriege XAMPP nicht gestartet. Keine Fehlermeldung, nichts ... Ist es vielleicht möglich ältere XAMPP-Versionen zu downloaden,

Du redest nach wie vor von XAMPP für Windows 1.7.1 und die z.B. apache_start.bat gibt nichts aus?

gibt es ein Tool mit dem ich laufende XAMPP-Prozesse vollständig beenden kann?

z.B. der Taskmanager von Windows.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp startet nicht mehr

Postby Kirzz » 03. August 2009 18:04

Du redest nach wie vor von XAMPP für Windows 1.7.1 und die z.B. apache_start.bat gibt nichts aus?

Apache 2 is starting ...
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


z.B. der Taskmanager von Windows.

Ein Tool existiert nicht. Apache u. MySQL finde ich im TaskManager noch, das ist aber doch sich nicht alles, oder doch?


Noch gar nicht erwähnt, mein OS: Win XP Home SP3
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Wiedmann » 03. August 2009 18:11

(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to address 0.0.0.0:443

Es läuft bereits ein Server/Programm welches den Apache Port 443 benutzt. Beeende dieses, und du kannst den Apache starten. Bzw. wenn der Apache schon läuft, kann man ihn nicht nochmals starten.
(Das hättest du aber mit einer Suche nach der Fehlernummer bestimmt auch selbst gefunden...)

Apache u. MySQL finde ich im TaskManager noch, das ist aber doch sich nicht alles, oder doch?

Wenn das die einzigsten 2 Server sind die du gestartet hast, dann ist das alles. (4 Server sind ja beim XAMPP dabei)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp startet nicht mehr

Postby Kirzz » 03. August 2009 18:33

Es läuft bereits ein Server/Programm welches den Apache Port 443 benutzt. Beeende dieses, und du kannst den Apache starten. Bzw. wenn der Apache schon läuft, kann man ihn nicht nochmals starten.

Ich habe unter Nutzung von xampp-control.exe gerade gesehen das 443 von Skype\Phone\Skype.exe belegt ist.

Den Haken hatte ich aus den Skype / Verbindungen "Ports 80 und 443 als Alternative für eingehende Verbindungen verwenden" vorab schon herausgenommen. Trotzdem ist 443 mit Skype belegt.
In den Verbindungen steht noch:
Verwende Port "443" für eingehende Verbindungen. Das ist aber grau dargestellt, ich hatte angenommen dass das herausnehmen des Hakens ausreichend ist? Anscheinend nicht? Ich benötige Skype, welchen Port kann ich als Alternative für 443 verwenden?
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31

Re: xampp startet nicht mehr

Postby Wiedmann » 03. August 2009 18:45

Das ist aber grau dargestellt, ich hatte angenommen dass das herausnehmen des Hakens ausreichend ist? Anscheinend nicht?

Wenn man es neu startet nach der Konfigänderung sollte das so sein. Ansonsten muss man sich natürlich bei dem Hersteller beschweren. (insb., warum überhaupt für Webserver spezifizierte Ports benutzt werden.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp startet nicht mehr

Postby Kirzz » 03. August 2009 19:05

Ich brauche Skype beruflich. Ich habe als Port "8080" (eingehende Verbindungen) eingetragen, und habe nun beides am laufen. Puuhhh.

Vielen Dank für deine Unterstützung!
Kirzz
 
Posts: 14
Joined: 28. July 2009 10:31


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests