Apache startet nicht, jedoch mySQL

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht, jedoch mySQL

Postby web272 » 14. July 2009 12:35

Ich teste meine Drupal Installationen auf XAMPLight. Bisher erfolgreich.

Dann ließ sich der Apache nicht mehr starten. Die apache_start.bat roeutine ergab folgende Fehlermeldung. Vorher hatte ich den XAMPlight vorsichthalber neu installiert, Weil ich vorher einen Virus mit einer CD beseitigt habe (AntiVir- Rescue auf Linux-Basis). Das Problem ändert sich nicht. Auch ein NeuBoot des Rechners bring nur den Null-Zustand mit anschließend gleichem Fehler. MySQL läuft dagegen. localhost ist natürlich nicht zu finden.

Fehlermeldung:
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to
address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .
web272
 
Posts: 2
Joined: 14. July 2009 12:31

Re: Apache startet nicht, jedoch mySQL

Postby Wiedmann » 14. July 2009 12:43

Dann ließ sich der Apache nicht mehr starten.

Siehe deine Fehlermeldung:
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
Anschluss) nur jeweils einmal verwendet werden. :

Es läuft bereits ein Server/Programm, was den Apache Port 80 belegt. Stoppe dieses und du kannst den Apache starten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht, jedoch mySQL

Postby scarlett » 15. July 2009 19:28

Hallo Leute,

ich habe ein ähnliches Problem mit meinem Apache. Das ganze funktionierte bis gestern ohne Probleme, aber nun bekomme ich, wenn ich über apache_start.bat starte, folgende Meldung:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
Das System kann den angegebenen Pfad nicht finden.

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


Starte ich den Apache wiederrum über apache_start.bat, dieses mal aber mit Administratorenrechten (rechte Maustaste und anschließend Als Administrator ausführen), erhalte ich folgende Meldung:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
Das System kann den angegebenen Pfad nicht finden.

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


Hoffe Ihr könnt mir weiterhelfen.

Besten Dank im voraus!

liebe Grüße Scarlett
scarlett
 
Posts: 4
Joined: 15. July 2009 19:18

Re: Apache startet nicht, jedoch mySQL

Postby glitzi85 » 15. July 2009 20:01

Äh, die Meldungen sind doch gleich, oder?

Egal, hast du was an der httpd.conf geändert? Schau dir mal die error.log an, ob da was drin steht. Zu finden unter xampp\apache\logs\error.log
Wenn nicht, dann schau bitte in der httpd.conf, httpd-vhosts.conf und httpd-ssl.conf (je nachdem ob du die beiden letzteren verwendest) nach, ob irgendwelche Pfadangaben bei CustomLog oder ErrorLog nicht stimmen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Apache startet nicht, jedoch mySQL

Postby Wiedmann » 15. July 2009 21:05

Das System kann den angegebenen Pfad nicht finden.

Gibt es denn das Verzeichnis "\xampp\apache" oder "\xampp\apache\bin" noch?
(Nur bei Zugriff auf etwas in einem nicht vorhandenen Verzeichnis (Pfad) kommt so eine Mledung)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht, jedoch mySQL

Postby scarlett » 16. July 2009 19:29

Sorry glitzi,

ist mir beim kopieren wohl ein Fehler unterlaufen :oops: Nun also die Meldung ohne Administratorenrechte:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Socke
ts unzulõssig. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


In der httpd.conf habe ich nichts geändert. im error.log steht einiges drin, aber nichts aus den letzten Tagen vo ich ohne Erfolg versucht habe den Apache zu starten.

@Wiedemann
Gibt es denn das Verzeichnis "\xampp\apache" oder "\xampp\apache\bin" noch?

Ist alles noch vorhanden.

Schon einmal vielen Dank für eure Bemühungen.

liebe Grüße Scarlett
scarlett
 
Posts: 4
Joined: 15. July 2009 19:18

Re: Apache startet nicht, jedoch mySQL

Postby Wiedmann » 16. July 2009 20:06

(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Socke
ts unzulõssig. : make_sock: could not bind to address 0.0.0.0:80

Dann solltest du deine Firewall o.ä. überprüfen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht, jedoch mySQL

Postby scarlett » 17. July 2009 15:53

Hallo,

habe eine kleine Batchdatei zum überprüfen laufen lassen und dies ist dabei herausgekommen:


****************************
* *
* XAMPP-Port-Checker *
* *
****************************
*
*
* --> Port 80 wird von der Anwendung "System" belegt
* --> Port 443 ist derzeit *NICHT* belegt
*
*
*********** ENDE ***********


Ich habe leider keine Ahnung was für ein Programm bzw. Dienst nun meinen Port belegt, da ich keine genauen Angaben bekomme.

liebe Grüße Scarlett
scarlett
 
Posts: 4
Joined: 15. July 2009 19:18

Re: Apache startet nicht, jedoch mySQL

Postby Wiedmann » 17. July 2009 16:21

Ich habe leider keine Ahnung was für ein Programm bzw. Dienst nun meinen Port belegt, da ich keine genauen Angaben bekomme.

Du kannst ein Programm wie tcpview oder netstat benutzen, welches dir diese Angaben liefert.
(Da du augenscheinlich Vista benutzt, deses Programm dann "als Administrator" starten.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache startet nicht, jedoch mySQL

Postby scarlett » 17. July 2009 18:43

Hallo,

habe das Problem gelöst :D

Aus irgendeinem Grund hatte sich Windows irgendwann entschieden den IIS Server zu installieren. Da dieser den Port 80 belegt konnte der Apache nicht mehr starten. Einfach den IIS unter "Programme und Funktionen"/"Windows Funktionen ein- oder ausschalten" deinstallieren, dann ist Port 80 für den Apache frei.

Mit netstat hatte ich bereits versucht, aber leider bekommt man hier nicht den entsprechenden Dienst angezeigt der den Port belegt. Wie bereits geschrieben erhält man lediglich den Hinweis das Port 80 von der Anwendung "System" belegt ist.

Vielen Dank für eure Hilfe :!: :!: :!:

liebe Grüße Scarlett
scarlett
 
Posts: 4
Joined: 15. July 2009 19:18


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests