das leidige Problem mit dem Apachen im XAMPP (unter Vista)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

das leidige Problem mit dem Apachen im XAMPP (unter Vista)

Postby o_kiki_o » 10. July 2009 10:59

Hallo Leute,

etwas verzweifelt habe ich gerade eine Lösung gesucht, aber eben nicht hier oder anderswo im Internet gefunden.

Worum geht es: Der Apache Server lässt sich nicht starten.
    1. Check: Sind die Ports belegt? Angabe bei MySQL Port 3306: SYSTEM --> also dieser Port ist in Benutzung
    Bei allen anderen Ports wird "free" angezeigt, also läuft auch kein anderer Dienst auf den besagten Port 80 und 443 (SSL).

    2. Skype ist nicht installiert oder deaktiviert (man sollte die Fremdnutzung von fest deklarierten Ports einfach verbieten ;-)

    3. Die Windows Firewall hat eine Regel für den Apachen hinzugefügt --> alles i.O.

    4. Die Installation ist mit Administratorrechten ausgeführt worden.
Was nun? --> Hier ist für jeden normalo-User das Ende erreicht.


Was ist meiner Meinung nach der häufig gemachte Fehler?

der Apache kommt mit einer sehr primitiven Einstellung im XAMPP daher:
Code: Select all
Listen 80

und anschließend in der SSL Config:
Code: Select all
Listen 443


Das bedeutet: Der Apache soll auf allen IP´s auf dem Port 80 und für SSL auf dem Port 443 laufen.

Da ist doch schon vorprogrammiert, das der Apache auf einem einigermaßen sicheren System nicht starten darf.

WARUM sollte eine so simple Webserverumgebung, die üblichweise zum Testen oder lernen bwz. entwickeln benutzt wird, auf allen Netzen der Arbeitsstation laufen? Und wozu bitte SSL auf einem Localhost???


3. Aufruf der Apache Startdatei per Hand
    1. Eingabeaufforderung öffnen und zum XAMPP Verzeichnis wechseln (Sinnvollerweise: C:\XAMPP\)
    Code: Select all
    c:
    cd \
    cd XAMPP

    2. In das Apache-Bin Verzeichnis wechseln und den Apachen per Hand starten
    Code: Select all
    cd apache
    cd bin
    apache.exe

    3. nun sollte eine Fehlermeldung ausgegeben werden. Bei Vista wird hier meistens der Port 443 (SSL Socket) angemeckert.
    4. Nun sollte man erstmal den Apachen etwas einschränken:
      1. Die Angabe der Erreichbarkeit der Webservers: änderen
      Code: Select all
      Listen 80
      zu
      Code: Select all
      Listen 127.0.0.1:80
      somit wäre der Werbserver nur auf euerem lokalen Rechner erreichbar (nicht einmal von einem anderen Client innerhalb des Netzwerkes erreicht ihr somit den frisch aufgesetzen und ungeschützen Webserver)
      2. Den SSL Bereich deaktivieren (wozu SSL auf einem Localhost): editieren der hhtpd.conf
      Explorer öffnen --> Zum Verzeichnis "C:\XAMPP\apache\conf" navigieren --> die httpd.conf suchen --> klick mit rechter Maustaste --> "öffnen mit" --> Programm Notepad auswählen --> folgende Zeile suchen:
      Code: Select all
      Include conf/extra/httpd-ssl.conf
      und diese mit einem "#" auskommentieren -->
      Code: Select all
      #Include conf/extra/httpd-ssl.conf
      --> Datei speichern und schließen.
      3. Nun den Apachen neu starten und schauen ob er läuft

Was sollte anders gemacht werden:
Um den vielen Usern die sich an das Thema Webserver mit Apache und MySQL heran trauen, den Weg dorthin etwas einfacher zu gestalten, sollte der XAMPP mit einer etwas abgespeckteren Grundkonfig daher kommen. "Einfache Installation"
Für alle erfahrenen User sollte man eine "Erweiterte Installation" anbieten, in der man anschließend die Ports, SSL, die geladenen Module, die PHP Version, uvm. konfigurieren kann.

Das waren meine Anregungen zu diesem sonst sehr schönen Projekt :-)

LG kiki
o_kiki_o
 
Posts: 1
Joined: 10. July 2009 10:22

Re: das leidige Problem mit dem Apachen im XAMPP (unter Vista)

Postby Pitze » 10. July 2009 11:50

Hej,
um es kurz zu machen will man ein Projekt entwickeln sind die momentan enthaltenen Dinge schon wichtig.
Warum haben so viele schwirigkeiten bei Vista aber auch XP??.
Schaut doch mal in der Autostartumgebung nach was da alles mitgestartet wird "Adobe, Logitech, ICQ" das alles birgt schon eine mögliche fehlerquelle in sich. Dann in Vista und XP die IIS Funktion deinstalieren falls installiert. Zu letzt noch sollte man sich als Anfänger sehr viel Zeit nehmen und alle nur möglichen Internetquellen nutzen, zumal das Apachemanual mitlerweile auf deutsch gibt, um mit der Configuration klar zu kommen dann ist das umstellen des Ports keine so ark grosses Problem.
Pitze
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: das leidige Problem mit dem Apachen im XAMPP (unter Vista)

Postby Nobbie » 10. July 2009 12:13

o_kiki_o wrote:Um den vielen Usern die sich an das Thema Webserver mit Apache und MySQL heran trauen, den Weg dorthin etwas einfacher zu gestalten, sollte der XAMPP mit einer etwas abgespeckteren Grundkonfig daher kommen. "Einfache Installation"


Und Du beantwortest ab dann die zig-fach auftauchende Frage, wieso Xampp ums Verrecken nicht im LAN erreichbar ist (was ebenfalls von Neulingen als selbstverständlich empfunden wird), weil Apache nicht mehr auf dem Netzwerkadapter "lauscht". Und ebenso beantwortest Du die nächste Frage, wieso https: nicht funktioniert (denn viele Anwender, gerade auch Neulinge, wollen das lokal probieren, bevor sie es hochladen).

Und gerade weil es Neulinge sind, würden diese sicherlich bei der Installation nicht die dafür notwendige Option "erfahrener Anwender" ankreuzen - womit sich die Katze in den Schwanz beißt.

Das ist alles nicht so einfach zu entscheiden - was für DICH persönlich das normale Einsatzgebiet ist, ist für andere durchaus nicht normal - das beweisen eindrucksvoll die entsprechenden Fragen hier im Forum.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests

cron