Ein paar Fragen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Ein paar Fragen

Postby Karsten » 21. February 2003 21:30

Hallo liebes ApacheFriends Team :)

ich habe mir soeben wampp-0.2.6c.zip runtergeladen und erfolgreich installiert, klappt alles super ( Windows XP SP1 )

wenn ich jetzt http://localhost in den browser eingebe komme ich zu dieser lila seite wo ich dann auch die mysql datenbank testen kann.
Alle funktionen haben funktioniert.

so jetzt zu meinen fragen

Muss ich jetzt irgendwie sicherheitshalber dinge umstellen dass nicht jeder der auf diese seite kommt dinge an meinem server umstellen kann ?
Und wenn was, dann bitte mit erläuterung :)

Jetzt möchte ich meine private homepage genauer gesagt PHPNUKE laufen lassen, was muss ich einstellen damit jeder der auf meine IP adresse geht direkt zu dem PHP Nuke kommt, sagen wir php nuke liegt im ordner C:\wampp2c\phpnuke
Wie geht es jetzt dass wirklich JEDER nur auf das PHPNuke kommt, und nicht auf diesen lila "admin panel" ?

Und wenn das geschehen ist, wie komme ich dann sonst noch zu diesem lila admin panel ?

ich hoffe ich habe meine fragen klar geschildert und warte auf baldige hilfe, bedanke mich schonmal

mfg

Karsten
Karsten
 
Posts: 3
Joined: 21. February 2003 21:22

Postby DigitalPixel » 22. February 2003 13:03

moin karsten
hab meinen server ähnlich laufen so wie du das vor hast
leg dir in deinem htdocs verzeichnis einen neuen ordner an sagen wir mal der heißt "administration" dann nimmste alle dateien die jetzt im root liegen (deinem htdocs verzeichnis) und kopierst die nach "administration" gegebenfalls mußte evt noch pfade anpaßen.
jetzt kannste dein phpnuke nehmen und es direkt in dein htdocs verzeichnis installiern hat den vorteil wenn jetzt jemand deine ip anwählt er gleich auf'm nuke is (ich weiß es gibt auch andere möglichkeiten dies zu regeln) .
wenn dir lustig ist kannste jetzt auch noch ne htaccess und pw anlegen damit wirklich niemand in dein administrations ordner kommt
DigitalPixel
 
Posts: 2
Joined: 22. February 2003 12:39
Location: Berlin

Postby Karsten » 22. February 2003 14:04

hallo und danke für deine antwort,

ich hab noch gestern im board gelesen dass man diese startseite auch über die "httpd.conf" im verzeichnis "wampp2c\apache\conf" ändern kann.
So habe ich es jetzt in

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/wampp2c/web">

geändert und auch meine html startseite in den ordner web kopiert.
Alle die jetzt auf meine IP kommen sehen jetzt auch die startseite.
Mein problem liegt jetzt aber nur noch daran dass ich nicht mehr in dieses lila admin panel komme, normalerweise wurden dann immer 2 dos applikationen ausgeführt, nur jetzt wenn ich dann zb das PHP teste oder eine andere funktion klappt es nicht mehr :(

was muss ich denn jetzt sonst noch ändern dass ich wieder die ganzen funktionen nutzen kann ?
Karsten
 
Posts: 3
Joined: 21. February 2003 21:22

Postby Karsten » 22. February 2003 14:13

Juhuu hallo DigitalPixel,

ich habe jetzt alles so gemacht wie du gesagt hast, einen neuen ordner administration angelegt und alle dateien dort hineinkopiert, jetzt ist nur noch meine startseite drin, so wie es sein sollte !!!!
Vielen vielen dank !!!!

<Directory "/wampp2c/web">

hab ich alles wieder in den standart wert zurückgesetzt, nur die mysql_start.bat muss ich jetzt immer manuell starten damit sie funzt, sonst klappt alles, dankeschön nochmal

MySQL funktioniert nicht.
Vielleicht ist er nicht gestartet?
Benutze \wamppxxx\mysql_start.bat um MySQL zu starten!

Vorher muß die my (bzw. my.cnf) als c:\my vorliegen!

Neu Laden, um den MySQL-Status erneut zu überprüfen


jetzt probier ich noch den ordner administration mit htaccess zu schützen

mfg

Karsten
Karsten
 
Posts: 3
Joined: 21. February 2003 21:22


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests