PEAR BUG???

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PEAR BUG???

Postby UltraViolence » 11. December 2003 16:06

Hi Leutz,

hab mir den neusten XAMPP für Windows (Version 1.2 vom 05.11) mal gezogen und wollte nen paar Pear-Extensions installieren. Dabei ist mir aufegfallen, dass es dort wohl einen Fehler gibt? (Oder ich hab da was verpasst, was ich nicht ausschließen will :lol: )

Also wenn ich versuche über :

Code: Select all
pear install <pfad>/<zum>/<neuen>/<pear>/<package>/package.xml


ausführe, erhalte ich folgende Fehlermeldung:

Code: Select all
Fatal error: Call to undefined function:  getoptions() in D:\Programme\xampp\php\pear\scripts\pear.in on line 35


Mhh - hab mir dann mal die Datei pear.in angeschaut und dort steht:
in Zeile 35
Code: Select all
$cmd_options  = PEAR_Command::getOptions();


Also fluchs in die Command.php geschaut (wo die Klasse PEAR_Command liegt) und dort mußte ich dann feststellen, dass es die Methode getOptions() gar nicht mehr gibt :(

Hab ich jetzt Tomaten auf den Augen, oder ist da evtl. wirklich ein Versionkonflikt zwischen alten/neuen PEAR Strukturen??

Viele Grüße,
Ultra.
User avatar
UltraViolence
 
Posts: 4
Joined: 11. December 2003 15:39
Location: Lower East Side

Postby Thhunder » 13. December 2003 16:50

also ich kenn mich da mit nicht so aus.... aber ich denke es wäre wohl möglich das es ein versionkonflikt ist wobei die neuste version am server abwärstkompatibel sein sollte....
Image
Thhunder
 
Posts: 87
Joined: 03. August 2003 22:42

Postby UltraViolence » 14. December 2003 16:24

Hi,

ich denke auch das es nen Versionkonflikt ist - wobei ich schon bei http://pear.php.net in die ChangeLogs geschaut hab und nix gesehen.

Aber klar ist - wenn man sich aus der 4.3.4 Version den PEAR-Teil installiert, das sich die Klassen geändert haben.

Ich habe folgendes gemacht, um den Teil dennoch zum Laufen zu bringen... das PEAR Package aus der 4.3.4er Version installiert und die Klassen übernommen. (Also den existierenden Teil gelöscht und es läuft soweit ich getetstet hab eigentlich alles) Ich denke es ist nen Kopierfehler, um die jpGraph Klassen zu übernehmen. Ich hab Kay auch schon ne mail geschrieben.

Gruß,
Ultra.
Praxis: Jeder kann´s, aber keiner weiß wie´s geht...
Theorie: Jeder weiß wie´s geht, aber keiner kann´s ...
Microsoft vereint Praxis und Theorie: Nix geht und keiner weiß warum
User avatar
UltraViolence
 
Posts: 4
Joined: 11. December 2003 15:39
Location: Lower East Side


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests