Probleme mit eignen 404 Error Dokument

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit eignen 404 Error Dokument

Postby carschrotter » 29. June 2009 16:39

So fangen wir gleich mal an. Also ich habe Probleme mit meinen selbst erstellten Error Dokument unter Xampp.
Folgendes hatte auf meinen Virtual Host versucht bei einen 404 Fehler weiterzuleiten auf /error/404.html

Allerdings bekomme ich dann nur folgendes zurück:
Not Found

The requested URL /gibt/es/leider/nicht/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 Server at beispiel Port 80

Und Hier meine Einträge:

Virtual Host:
Code: Select all
<VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/beispiel
    ServerName beispiel
    DirectoryIndex index.html index.php
    <Directory "C:/xampp/htdocs/ beispiel ">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>
</VirtualHost>


.htaccess:
Code: Select all
ErrorDocument 404 /error/404.html
RewriteEngine on
RewriteBase /
# Wenn kein / slash in Adresse dan weiterleiten an AdressURI/ Add trailing slash
RewriteCond %{REQUEST_URI} ^/[^\.]+[^/]$
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1/ [R=301,L]
# RewriteRules um Namen und Strucktur der Ordner an Datei als QUERY STRING zu uebergeben.
RewriteRule ^([-0-9a-zA-Z]+)/([-0-9a-zA-Z]+)/seite([0-9]+).?$   index.php/?id=$2&seite=$3&kategorie=$1&%{QUERY_STRING} [QSA,L]
RewriteRule ^([-0-9a-zA-Z]+)/seite([0-9]+).?$                   index.php/?id=$1&seite=$2&kategorie=$1&%{QUERY_STRING} [QSA,L]
RewriteRule ^([-0-9a-zA-Z]+)/([-0-9a-zA-Z]+).?$                 index.php/?id=$2&kategorie=$1&seite=0.1&%{QUERY_STRING} [QSA,L]
RewriteRule ^([-0-9a-zA-Z]*).?$                                 index.php/?id=$1&kategorie=$1&seite=0.1&%{QUERY_STRING} [QSA]


Auf meiner echten Homepage bei Funpic funktioniert das allerdings alles ohne Probleme und zeigt mir bei einem ungültigen link die gewünschte Fehlerseite an.

Auch musste ich feststellen das wenn ich die .htaccess Datei nur mit ErrorDocument 404 /error/404.html ins htdocs lege.
Zum Beispiel beim Aufruf von http://localhost/gibtnicht die gleiche Fehlermeldung bekomme wie oben beschriebne.
Kann somit eigentlich auch nichts mit dem VirtualHost zutun haben.
Die Datei und der Ordner ist aber auf jeden fall vorhanden schaue ich mit den Windows Explorer existiert sie unter „C:\xampp\htdocs\error\404.html“.

Einen Teilerfolg habe ich mittlerweile auch zustande gebracht. Lege ich die Datei unter „C:\xampp\htdocs\404.html“ und gebe dies auch in der .htaccess Datei an so kommt beim Aufruf von http://localhost/gibtnicht die gewünschte Fehlerseite das gleiche beim VirtualHost.
Aber es muss doch auch möglich sein die Fehlerseite in ein eigenes Verzeichnis zulegen?
Da ich mit Googeln und der Apache Dokumentation nichts Hilfreiches zu meinen Problem finden konnte hoffe ich nun auf ein paar Hilfreiche Antworten.
Mit freundlichen Grüßen carschrotter.
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26

Re: Probleme mit eignen 404 Error Dokument

Postby Wiedmann » 29. June 2009 17:11

Code: Select all
DocumentRoot C:/xampp/htdocs/beispiel
ErrorDocument 404 /error/404.html

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Gibt es die Datei "C:\xampp\htdocs\beispiel\error\404.html"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit eignen 404 Error Dokument

Postby carschrotter » 29. June 2009 17:18

Ja wie ich schon schrieb:
Die Datei und der Ordner ist aber auf jeden Fall vorhanden schaue ich mit den Windows Explorer existiert sie unter „C:\xampp\htdocs\error\404.html“.
habe es auch in beiden Verzeichnissen mehrmals kontrolliert und mein funpic server hat auch die gleiche Ordnerstruktur sollte also von daher keine Probleme geben
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26

Re: Probleme mit eignen 404 Error Dokument

Postby Wiedmann » 29. June 2009 17:21

Ja wie ich schon schrieb

Hmm, dein von dir geposteter Pfad ist aber nicht der Selbe wie meiner...

Bzw:
Gibt es (noch) den standardmäsigen Alias "/error" bei dir? Dann sucht Apache die Datei in "C:\xampp\apache\error".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Probleme mit eignen 404 Error Dokument

Postby carschrotter » 29. June 2009 17:47

Wiedmann wrote:Hmm, dein von dir geposteter Pfad ist aber nicht der Selbe wie meiner...

Bzw:
Gibt es (noch) den standardmäsigen Alias "/error" bei dir? Dann sucht Apache die Datei in "C:\xampp\apache\error".

ja den gibt es schon noch sonst gäbe es wohl ja auch garkeine Fehlermeldung mehr.
Aber mein Pfad bezieht sich ja auch auf die Änderungen durch .htaccess.
Mit:
Code: Select all
 ErrorDocument 404 /error/404.html
im htdocs sage ich im ja das er die Datei unter localhost/error/404.html findet also sollte der error Ordner im htdocs Verzeichnis richtig aufgehoben sein.
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26

Neue Erkenntnis, neues Problem

Postby carschrotter » 29. June 2009 19:47

Ok, ich habe noch ein wenig herum experimentiert und einfach mal den Ordnernahmen geändert anstelle error in Fehlerseite umbenannt und das ganze geht jetzt. Benenne ich den Ordner aber wieder in error bekomme ich immer den gleichen Fehler.
Auch habe ich einfach mal versucht den Ordner error aufzurufen bekomme dann aber nur diese Meldung:
mein localhost wrote:
Zugriff verweigert!

Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403
localhost
06/29/09 20:34:03
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9

Scheinbar habe ich grundsätzlich keine Zugriff auf einen Ordner wenn ich ihn error nenne.
Egal ob ich ihn als meine Ordner für die Fehlerseiten nutze, oder als normalen Dateiordner.
Heißt ein Ordner error habe ich keinen Zugriff mehr.
Gibt es dafür irgend einen Lösungsansatz?
Nachtrag:
Laut error log scheint mein Server scheinbar beim Aufruf von http://localhost/error/
nicht auf C:\xampp\htdocs\error zuzugreifen sondern auf C:\xampp\apache\error
Code: Select all
[Mon Jun 29 20:33:36 2009] [error] [client 127.0.0.1] Directory index forbidden by Options directive: C:/xampp/apache/error/
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26

Re: Probleme mit eignen 404 Error Dokument

Postby Nobbie » 29. June 2009 20:10

Den Alias löschen.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: Probleme mit eignen 404 Error Dokument

Postby carschrotter » 29. June 2009 20:25

Nobbie wrote:Den Alias löschen.

Weiß leider nicht genau was du meinst in der httpd.conf habe ich nichts geändert oder meinst du den Eintrag für den und VirtualHost
Code: Select all
<Directory "C:/xampp/htdocs/beispiel ">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>

Mit den kann es eigentlich nicht zu tun haben, weil es ja auch unter localhost nicht funktioniert.
MfG. carschrotter
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26

Re: Probleme mit eignen 404 Error Dokument

Postby Xardas der Dunkle » 29. June 2009 20:39

Code: Select all
<Directory "C:/xampp/htdocs/ beispiel ">

Code: Select all
<Directory "C:/xampp/htdocs/beispiel ">

Schmeiß da mal die Leerzeichen raus.
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Re: Probleme mit eignen 404 Error Dokument

Postby carschrotter » 29. June 2009 20:52

Xardas der Dunkle wrote:
Code: Select all
<Directory "C:/xampp/htdocs/ beispiel ">

Code: Select all
<Directory "C:/xampp/htdocs/beispiel ">

Schmeiß da mal die Leerzeichen raus.

Danke für den Tipp,
aber im Originale gibt es die Leerzeichen nicht habe für das Beispiel einfach nur für den Originalnamen "beispiel" eingetragen, und da ist das Leerzeichen als kleiner Flüchtigkeitsfehler reingerutscht.
Mit freundlichen Grüßen Carschrotter
User avatar
carschrotter
 
Posts: 6
Joined: 29. June 2009 16:26


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests