Pfad zu Bildern/CSS/JS - Dateien werden nicht gefunden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Pfad zu Bildern/CSS/JS - Dateien werden nicht gefunden

Postby fehler_sind » 25. May 2009 10:02

Hallo zusammen.

Ich habe einige Anwendungen (Zend Framework), die in den Templates Bilder/JSS/CSS einbinden über:

Code: Select all
src="/img/bild.png"
src="/js/javas.js"
etc.


Nun werden diese von XAMPP nicht gefunden. Bei meinem selbst kompilierten Apachen/PHP funktioniert alles einwandfrei. Auch bei verschiedenen Serveranbietern funktioniert es. Nun ist mir klar das ich über:

Code: Select all
src="img/bild.png"
src="js/javas.js"
etc.


die Inhalte angezeigt bekomme. Was muss ich ändern das auch "/img/bild.png" angezeigt wird? Also mit vorangestelltem Schrägstrich.

Vielen Dank schon für eure Hilfe.

Beste Grüße
fehler_sind
 
Posts: 2
Joined: 25. May 2009 09:56

Re: Pfad zu Bildern/CSS/JS - Dateien werden nicht gefunden

Postby Hanspeter Thöni » 25. May 2009 10:19

Wo liegen denn deine Dateien?
Wenn diese direkt im dokument-Root liegen (xampp/htdocs) wird es auch mit dem / am Anfang klappen (absoluter Pfad zum dokument-Root).

Liegen diese jedoch in einem Unterverzeichnis, wird es nur noch ohne den / gehen (relativer Pfad zur aktuellen Datei).

Ich vermute mal hier liegt der Unterschied.
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Re: Pfad zu Bildern/CSS/JS - Dateien werden nicht gefunden

Postby Wiedmann » 25. May 2009 10:23

Was muss ich ändern das auch "/img/bild.png" angezeigt wird? Also mit vorangestelltem Schrägstrich.

a) deine Dateien an die Stelle kopieren wo sie dein Script/HTML erwartet
b) oder das Script korrekt konfigurieren, so das die Links passend, zu der Lage der Dateien im Dateisystem, erzeugt werden.

(Hint: Der erste "/" einer URI ist der "DocumentRoot" (htdocs) im Dateisystem).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Pfad zu Bildern/CSS/JS - Dateien werden nicht gefunden

Postby fehler_sind » 25. May 2009 13:04

Vielen Dank für den Tip. Da hatte ich wohl ein Brett vor dem Kopf. :)
fehler_sind
 
Posts: 2
Joined: 25. May 2009 09:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests