Erstinstallation - Kriege Apache nicht zum laufen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Erstinstallation - Kriege Apache nicht zum laufen

Postby trinity2003 » 04. December 2003 02:04

hi,

habe probleme das teil zum laufen zu bekommen. habe mich hier im forum durchgelesen und einiges probiert.
zuerst meckerte apache bei port 443, den hab ich dann in der httpd.conf kommentiert. scheint dann auch zu klappen, aber jetzt meckerte er bei port 80. also auch dort laut forum den port in der httpd.conf auf 81 umgestellt. läuft nicht. auf allen anderen ports 82-90, 8080 etc. auch nicht. kriege immer wieder diese fehlermeldung, egal welchen port ich da einstelle.

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
[Thu Dec 04 01:47:56 2003] [crit] (OS 10038)Socket operation on non-socket: make
_sock: for address 0.0.0.0:80, apr_socket_opt_set: (SO_KEEPALIVE)
no listening sockets available, shutting down
Unable to open logs

hab xampp auf c:/ installiert. den personal webserver von ms runtergeschmissen und alle firewalls ausgeschaltet, wobei diese allerdings immer auf fragen eingestellt sind.

xampp hab ich mit 1, also mit mod-perl installiert, was immer das sein mag. bin anfänger in apache, php und mysql. system win98 (sorry alter privat-rechner ;))

ach ja. ich hab nicht vor meinen pc als server nach draussen zu öffnen. ich hab mir den xampp nur dazu installiert, damit ich lokal auf meinem pc mich in php und mysql einlernen kann. also will ich auch nicht meinen norton av oder die firewall deinstallieren. wie gesagt, ziel ist es dass ich php und my-sql in der praxis erlernen möchte und dafür weder webspace kaufen möchte noch nen zweiten pc oder so...

kann jemand helfen ?

lg
trinity2003
 
Posts: 2
Joined: 04. December 2003 01:54

Postby nemesis » 04. December 2003 03:57

Hi trinity2003,

noch wach? ;)

hab xampp auf c:/ installiert. den personal webserver von ms runtergeschmissen und alle firewalls ausgeschaltet, wobei diese allerdings immer auf fragen eingestellt sind.
es könnte sein, falls du die Firewall auf "fragen" eingestellt hast, und sie temporär beendest, undefinierte Ports automatisch geblockt werden. Entweder läßt du sie an, oder deinstallierst sie gleich richtig :)
Win98 ist nicht gerade das beste wenn man ins Internet gehn will...
Du könntest dir auch mal Knoppix zum reinschnuppern ansehen (Live-Boot Linux CD).

Gruss, nemesis
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby trinity2003 » 04. December 2003 15:49

wenn ich die firewalls anlasse, wird bei allen programmen gefragt ob ich die permission erteile. starte ich den apache wird nicht gefragt.

was ist knoppix ?

wie gesagt ich will am system win98 nicht viel ändern, da es mein einziger pc ist und ich da alles drauf habe. ich will ja nur mit php und mysql üben.

brauch ich den apache unbedingt oder kann ich z.b. mit dem personal webserver von ms auch php-seiten lokal anschauen ? oder gibt es vielleicht freewebspace mit php wo ich dann online arbeite ?

lg
trinity2003
 
Posts: 2
Joined: 04. December 2003 01:54

Postby nemesis » 06. December 2003 07:24

deinstalliere mal deine Firewall komplett!

Und zu Knoppix, das ist eine Linux Version wo du nur beim einschalten des PC's die CD im Laufwerk lassen musst, und im Bios ggf. die Bootreihenfolge verändern, das er erst im CD-Laufwerk nach einem bootbaren Datenträger sucht.
Knoppix ist nicht gerade das beste bei wenig Arbeitsspeicher, aber dafür gibts die CD meistens als Beilage in verschiedenen Zeitschriften.
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests