PHP als Apachemodul

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby raik » 26. July 2004 19:26

hab grad mal nachgeschaut: gzip ist aktiviert:
httpd.conf
AddEncoding x-compress Z
AddEncoding x-gzip gz tgz

ist es möglich, das temporär per php-script auszuschalten, oder müsste ich es dazu aus der config des apache rausschmeissen?
bzw. müsste encoding:gzip nicht auch im responseheader auftauchen?
wie kann ich das überprüfen, ob es gzip't gesendet wird?
raik
 
Posts: 21
Joined: 17. February 2003 03:17

Postby raik » 28. July 2004 20:17

inzwischen hat sich im selfhtml-forum jemand gefunden, auf dessen IIS 5 mit php 4.2.2 das hier vorgestellte script läuft, wie erwartet.
hat evtl. noch jemand ne idee, wo es klemmen könnte?
im response-header steht jedenfalls nix von komprimierung, obwohl der IE es ja könnte (laut request-header).
raik
 
Posts: 21
Joined: 17. February 2003 03:17

Postby raik » 15. November 2004 05:08

kleiner nachtrag:
ini_get(output_buffering) = <?php
echo ini_get('output_buffering').str_repeat(' ', ini_get('output_buffering'))."\n";
flush();
static
$i = 0;
while (
$i > 10) {
++
$i;
echo
"<br>".str_repeat(' ', 4096).$i."\n";
sleep(1);
flush();
}
?>

so läuft es. schuld ist also unter windows der output-buffer, der sich nicht flushen lässt, wenn er nicht gefüllt ist.
raik
 
Posts: 21
Joined: 17. February 2003 03:17

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests