Session startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Session startet nicht

Postby LeChuck » 25. April 2009 13:25

Tach zusammen,

ich habe eine Seite, die vorher im Inet wunderbar funktionierte. Nun habe ich mir xampp installiert und es scheint, dass die Session nicht gestartet wird.
Ich habe xampp in einem Jungfräulichen Zustand, also nichts an den Konfigurationsdateien verändert. Hat jemand eine Idee was ich einstellen muss?

phpinfo sagt folgendes:
Code: Select all
session
Session Support    enabled
Registered save handlers    files user sqlite
Registered serializer handlers    php php_binary wddx

Directive   Local Value   Master Value
session.auto_start   Off   Off
session.bug_compat_42   On   On
session.bug_compat_warn   On   On
session.cache_expire   180   180
session.cache_limiter   nocache   nocache
session.cookie_domain   no value   no value
session.cookie_httponly   Off   Off
session.cookie_lifetime   0   0
session.cookie_path   /   /
session.cookie_secure   Off   Off
session.entropy_file   no value   no value
session.entropy_length   0   0
session.gc_divisor   100   100
session.gc_maxlifetime   1440   1440
session.gc_probability   1   1
session.hash_bits_per_character   4   4
session.hash_function   0   0
session.name   PHPSESSID   PHPSESSID
session.referer_check   no value   no value
session.save_handler   files   files
session.save_path   C:\xampp\tmp   C:\xampp\tmp
session.serialize_handler   php   php
session.use_cookies   On   On
session.use_only_cookies   Off   Off
session.use_trans_sid   0   0


Das ganz läuft unter Vista mit SP1
LeChuck
 
Posts: 5
Joined: 25. April 2009 13:21

Re: Session startet nicht

Postby Wiedmann » 25. April 2009 13:34

ich habe eine Seite, die vorher im Inet wunderbar funktionierte.

Was nicht bedeutet, das der Code korrekt ist, bzw. das die Konfiguration der Seite (der Seite/Scripte, nicht XAMPP), falls nötig, auch für deinen lokalen XAMPP stimmt.

Nun habe ich mir xampp installiert und es scheint, dass die Session nicht gestartet wird.

Sessions tun "automatisch". Verifizieren kannst du das z.B. mit phpMyAdmin, der ohne Sessions nicht funktionieren würde.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Session startet nicht

Postby LeChuck » 25. April 2009 13:39

Danke, es hakt anscheinend an anderer Stelle, phpmyadmin geht.

Ich denke ich habe die STelle auch gefunden. Irgendwie akzeptiert der den Benutzernamen nicht, den ich (hoffentlich an richtiger Stelle) für die mysql-DB vergeben habe.
Dieser muss doch unter phpmyadmin->mysql->user eingetragen werden, oder?
Reicht es, wenn ich alle Felder auf N lasse, wenn ich nur die Standardbefehle Insert, Update und Select verwenden will?
LeChuck
 
Posts: 5
Joined: 25. April 2009 13:21

Re: Session startet nicht

Postby LeChuck » 25. April 2009 13:53

Okay,
ich habe dasProblem auf folgendes eingegrenzt:
Code: Select all
      if(mysql_select_db($db,$con)) echo "ja";
      else echo "ne";

$con ist durch eine andere if-Abfrage gesichert, es kann also nur noch an $db liegen. Die DB habe ich aber angelegt.
Hat jemand eine Idee?

Edit:
Code: Select all
      mysql_select_db($db,$con)
         or die ('<div class="error">Database error: ' . mysql_error().'</div>');


ergibt:
Database error: Access denied for user ''@'localhost' to database 'datenbank'
LeChuck
 
Posts: 5
Joined: 25. April 2009 13:21

Re: Session startet nicht

Postby Wiedmann » 25. April 2009 15:35

Code: Select all
 mysql_select_db($db,$con)

Database error: Access denied for user ''@'localhost' to database 'datenbank'

Da stimmt was nicht mit deinem vorausgegangenen mysql_connect().
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Session startet nicht

Postby LeChuck » 25. April 2009 17:44

Hast Du eine Idee, was da falsch gelaufen sein könnte?

Ich habe den Benutzer angelegt unter der DB mysql unter users. Muss ich bei der Datenbank direkt noch etwas einstellen, sodass der Benutzer Rechte bekommt? Ich meine bei der "test" DB geht es oder auch, wenn ich als Benutzer "root" eintrage.

Ich habe für den Benutzer Select, Insert, Delete und Update freigegeben.

Code: Select all
   $con = mysql_connect($server, $user, $pw)
      or die ('<div class="error">Database error: ' . mysql_error().'</div>');


ergibt aber keine Fehlermeldung
LeChuck
 
Posts: 5
Joined: 25. April 2009 13:21

Re: Session startet nicht

Postby LeChuck » 25. April 2009 17:57

Okay, danke.

Jetzt funktioniert es, nach einem Neustart. Keine Ahnung ob das so sein muss, oder ob mein Rechner gesponnen hat.
LeChuck
 
Posts: 5
Joined: 25. April 2009 13:21

Re: Session startet nicht

Postby Wiedmann » 25. April 2009 17:58

Ich habe den Benutzer angelegt unter der DB mysql unter users.

Du hast was genau gemacht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests