Xampp & Windows7Beta

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp & Windows7Beta

Postby Samuel2005 » 13. April 2009 09:20

Hallo erstmal und frohe Ostern......

Ich habe Windows 7 Beta auf meinem rechner laufen und ich weiss auch das da probleme auftreten können.... ist ja ne Beta. Aber vieleicht kennt ja jemand das Problem. Ich brauche den xampp server version 1.4.5 für CAO und meinen Webshop XTC. Bis Windows Vista Ultimate gab es keine probleme doch jetzt unter windows 7 kann ich nur den xampp Ordner aus dem htdocs verzeichnis im broser öffnen. versuche ich nen anderen ordner zu öffnen bekomme ich folgende info:

Not Found

The requested URL /t/xtc_installer/ was not found on this server.

Apache/2.0.50 (Win32) mod_ssl/2.0.50 OpenSSL/0.9.7c PHP/5.0.0 Server at localhost Port 80

/t/ ist mein Testordner

In meiner Firewall ist der Server freigegeben. Ich weiss keinen Rat und beim googeln hab ich auch nichts gefunden. muss ich irgendwo was freigeben oder so??

Oder brauche ich ne neuere version von Xampp?? dann bekomm ich aber Probleme mit SQL. CAO läuft nur mit mysql 4.


Hilfe ich verzweifel !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Danke schon mal im Vorraus
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04

Re: Xampp & Windows7Beta

Postby Nobbie » 13. April 2009 09:57

>/t/ ist mein Testordner

Was heißt das? Wo liegt der Testordner, bitte den komplette Pfadnamen angeben.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Xampp & Windows7Beta

Postby Samuel2005 » 13. April 2009 12:00

Hallo,

der Testordner liegt im Ordner htdocs also c:/apachefriends/xampp/htdocs/t/

MFG

Sebastian
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04

Re: Xampp & Windows7Beta

Postby Nobbie » 13. April 2009 13:53

Und da gibt es einen Unterordner xtc_installer und in diesem Unterordner gibt es eine Datei index.php oder index.html? Und diese Dateien (soweit vorhanden) sind nicht durch UAC geschützt?
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: Xampp & Windows7Beta

Postby Samuel2005 » 14. April 2009 19:21

Ja das mit dem Unterordner stimmt..... dabei ist es egal welche dateien (shop//forum//oder eine einfache php weiterleitung) sich in dem Ordner (oder einen anderen) befinden. Ich bekomme immer die selbe info..

UAC Benutzerkontensteuerung ist abgeschaltet.

mfg
Sebastian
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04

Re: Xampp & Windows7Beta

Postby Wiedmann » 14. April 2009 19:46

doch jetzt unter windows 7 kann ich nur den xampp Ordner aus dem htdocs verzeichnis im broser öffnen.

Damit meinst du "http://localhost/xampp/"?

versuche ich nen anderen ordner zu öffnen

Du hast also z.B. (bitte nachmachen!) im Verzeichnis:
"\xampp\htdocs"

Diesen Ordner angelegt:
"\xampp\htdocs\test"

In diesem Verzeichnis liegt dann eine Datei mit dem Namen "test.php" und diesem Inhalt:
Code: Select all
<?php phpinfo(); ?>


In der "httpd.conf" hast du nichts geändert, und auch sonst keine Dateien in "\xampp\htdocs" geändert, bzw. dort keine ".htaccess" hinzugefügt.

bekomme ich folgende info: Not Found

Wenn du jetzt im Browser folgende URI aufrufst:
"http://localhost/test/test.php"

bekommst du also einen "Not Found"?
--> Was steht dann im "error.log"?


BTW:
CAO läuft nur mit mysql 4.

Es steht dir ja auch frei, einen MySQL Version 4.x separat zu installieren. Das würde natürlich nur etwas bringen, wenn es das Problem auch mit einem unverändertem XAMPP 1.7.x geben würde.

Ansonsten:
Installiere doch einfach MySQL 4.x und nimm den Webserver der bei deinem System dabei ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Xampp & Windows7Beta

Postby Samuel2005 » 14. April 2009 20:03

Nein Ich habe keine dateien geändert. nur xampp installiert.... shop in htdocs kopiert, xampp gestarten und url aufgerufen.

wie gesagt bist windows server 2008 als betriebssystem hat xampp funktioniert.

nur mit windows 7 funzen nur die xampp eigenen scripte.
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04

Re: Xampp & Windows7Beta

Postby Samuel2005 » 14. April 2009 20:05

achso bei der test.php bekomm ich auch nur Not Found......

aber wo ist nochmal die error.log??
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04

Re: Xampp & Windows7Beta

Postby Samuel2005 » 15. April 2009 19:48

FEHLER BEHOBEN!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Ich kanns kaum glauben....... nachdem ich die error log gefunden habe stand da folgender pfad drin: c:/apachefriends/xampp/xampp/xampp/htdocs/t/xtc_installer File not found....

ist ja auch klar, der shop lag ja auch in .../xampp/htdocs/....

Also kein Problem mit Windows sonder mit der installation. Ich frag mich nur woher 3 xampp verzeichnisse kamen. kann mich nicht erinnern xampp 3x installiert zu haben. naja hauptsache es funzt jetzt.


Danke für die Hilfe!!!!!


mfg
sebastian
Samuel2005
 
Posts: 6
Joined: 13. April 2009 09:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests

cron