Xampp 1.7.0 mit gdlib

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.7.0 mit gdlib

Postby KrickelD » 01. April 2009 11:10

Hallo,

soeben habe ich auf einem neuen Rechner Xampp installiert und alle Daten (htdocs) von der alten Installation rüber kopiert. Nun ist mir leider aufgefallen, dass die gdlib gar nicht mit installiert ist (trotz der jungfräulichen Xampp-Installation).

In der php.ini steht zwar extension=php_gd2.dll (ohne Semikolon) aber es klappt nicht :( Was mich wundert ist, dass unter "Command Line" in der PHPinfo() der Eintrag "--without-gd" steht. Wie kann ich dieses beeinflussen?

Bin für jeden Hinweis dankbar da mir leider Apache-Kenntnisse fehlen... DANKE
KrickelD
 
Posts: 3
Joined: 01. April 2009 10:59

Re: Xampp 1.7.0 mit gdlib

Postby Wiedmann » 01. April 2009 11:36

aber es klappt nicht

Was klappt nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Xampp 1.7.0 mit gdlib

Postby KrickelD » 01. April 2009 12:02

Da habe ich ja das Wichtigste vergessen :)

Ich kann die GD-Funktion (z.B. imagecreate) nicht nutzen, es kommt nur "Serverfehler! Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist."

In der PHPinfo() wird die gdlib auch nicht aufgeführt, nur in der Command-Line der Eintrag "--withoud-gd"... Kann ich dies irgendwie beeinflussen? Die php_gd2.dll existier im /ext-Ordner und wird auch in der php.ini aufgerufen

Image
KrickelD
 
Posts: 3
Joined: 01. April 2009 10:59

Re: Xampp 1.7.0 mit gdlib

Postby Wiedmann » 01. April 2009 12:05

Xampp 1.7.0 ... In der PHPinfo()

Die Ausgabe von phpinfo() ist aber nicht vom PHP, welches beim XAMPP 1.7.0 dabei ist...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Xampp 1.7.0 mit gdlib

Postby KrickelD » 01. April 2009 12:51

Unter "Loaded Configuration File" stand eine Datei des Zend-Studios welches ich ebenfalls installiert habe, die die von Xampp selber - dein Hinweis hat mich auf die richtige Spur gebracht!

Es lag also nicht an Xampp sondern an meiner Blindheit :) Eine Mittagspause kann Wunder wirken!

VIELEN DANK für deine Hilfe!!!
KrickelD
 
Posts: 3
Joined: 01. April 2009 10:59


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests