mysql starten und stoppt gleich wieder

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mysql starten und stoppt gleich wieder

Postby Torsten » 26. November 2003 02:44

hi

mein msql will einfach nicht laufen habe mysql als Service installiert
wenn ich mysql_start.bat versuche kommt "mysql is starting..." und das wars
bei winmysqladmin.exe sehe ich ganz kurz ein grüne Ampel wird aber gleich wieder rot

Weiß jemand Rat

Gruß Torsten
Torsten
 

Postby Shurakai » 27. November 2003 14:40

Hi,
dieses Problem habe ich leider auch :cry:

Habe schon gesucht, gegoogelt usw., aber niemand kann helfen...

Es lief ein halbes jahr ohne probleme, dann innerhalb von 10stunden am gleichen Tag gehts auf 3verschiedenen PC-Systemen und 5verschiedenen Betriebssystemen nicht mehr.

Kann mir einer helfen? :?: :?:

Wäre sehr nett, denn das ist schon ziemlich doof... :cry:
PHP ist mein Leben.... ;)
Shurakai
 
Posts: 3
Joined: 26. November 2003 19:51
Location: Bergisch Gladbach

mysql startet und stoppt wieder

Postby atze » 27. November 2003 19:44

ich habe das neue xampp installiert und hatte das gleiche phänomeen.
dachte auch, daß dies ein fehler sei. aber dem ist nicht so.

apache starten ---> dosfenster geöffnet lassen
mysql starten ---> ebenfalls geöffnet lassen

die meldung beim test von wegen eine andere version auf dem
server erscheint beim testen bei mir auch, aber es funktioniert trotzdem.
habe bei mir postnuke .72x istalliert und das läuft super.
angelegte datenbank perfekt angelegt. siehe phpmyadmin :lol:
atze
 

Postby Shurakai » 28. November 2003 14:28

Hi,
das Problem: Ich kann das Fenster nicht offen lassen.
Es schließt sich ja sofort wieder... aber es lief ca. ein halbes jahr!

Außerdem kommt bei mir beim Test "es ist kein sql-server gestartet", und ein blick in die test-php-datei zeigt: wenn keine verbindung aufgebaut werden kann (was hier der fall ist), dann kommt die fehlermeldung.

Kann niemand helfen?
PHP ist mein Leben.... ;)
Shurakai
 
Posts: 3
Joined: 26. November 2003 19:51
Location: Bergisch Gladbach

Postby DJ DHG » 28. November 2003 15:16

Shurakai wrote:Hi,
das Problem: Ich kann das Fenster nicht offen lassen.
Es schließt sich ja sofort wieder... aber es lief ca. ein halbes jahr!


Moin Moin

geh mal so vor.

start -> ausführen -> cmd (wenn du win9x hast "command") -> enter

cd c:\xampp -> enter
mysql_start.bat -> enter

jetzt sollte das dos fenster offenbleiben und eventuelle fehlermeldungen
preisgeben..

und schau mal bitte in den logs nach, da steht oft drin woran es happert.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Shurakai » 29. November 2003 16:03

Hi,
das Fenster bleibt offen, es kommt keine Fehelrmeldung.
Der Server wird trotzdem nicht gestartet, mySQL Funktioniret nicht.

In welchen Logs muss ich nachgucken? Da gibts einige ;)

Naja, werde es mal mit ner neuen XAMPP Version probieren, mal sehen... aber 50MB mit ISDN... :roll:
PHP ist mein Leben.... ;)
Shurakai
 
Posts: 3
Joined: 26. November 2003 19:51
Location: Bergisch Gladbach

Postby Torsten » 03. December 2003 19:58

ich habe auch immer noch das problem mysql startet nicht ich hatte das vor längerem schonmal habe aber vergessen was das war

Gruß Torsten
Torsten
 
Posts: 17
Joined: 03. December 2003 19:56

Startprobleme

Postby cyberfreak » 16. December 2003 10:18

Hi!

Hatte auch so ein Problem! Also ich würde einfach mal nachsehen, ob nicht irgendwer oder irgendwas die "c:\my.cnf" gelöscht hat. Dann der Installservice funktioniert anscheinend nur mit "Windows XP Proffessional" allerdings funktionierts bei mir auch mit der Home-Edition. Dann würde ich wenn die Konsole sich dauernd selber beendet. Würde ich mal schauen, ob schon ein MySQL-Server läuft. Denn 2 nebeneinander können sich nicht ausstehen! Dann entweder eben den Installservice oder das Konsolenfenster! Und für WinMySQLAdmin muss im "windows"-Verzeichnis eine my.ini angelegt werden!

mfg
cyberfreak
cyberfreak
 
Posts: 7
Joined: 13. December 2003 14:22

Postby Straffi » 16. December 2003 10:26

Moin,

Aus dem ersten Post:
... habe mysql als Service installiert
wenn ich mysql_start.bat versuche kommt "mysql is starting..." und das wars ...


Ist das nur ein Schreibfehler, oder versuchst du wirklich den Dienst über die Batchdatei zu starten?


straffi
User avatar
Straffi
 
Posts: 120
Joined: 07. October 2003 17:48

Postby Torsten » 24. December 2003 02:54

Hi

danke für die Tipps aber irgendwie läuft mysql nicht weder über die Batch Datei noch als Dienst.

Ich benutze X win XP Professional kann es sein das sich das mit irgenwas nicht verträgt.
Jemand ein Idee

Gruß Torsten
Torsten
 
Posts: 17
Joined: 03. December 2003 19:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 22 guests