Problem mit Mercury

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit Mercury

Postby D@rKrieger91 » 26. February 2009 20:44

Hallo Leute,
ich habe mir jetzt einen kleinen Testserver mit Xampp eingerichtet. Nun wollte ich die mail() Funktion verwenden, dazu habe ich Mercury Mail konfiguriert, auserdem habe ich die php.ini und sendmail.ini angepasst.

php.ini
Code: Select all
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
sendmail_from = admin@localhost

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "D:\xampp\sendmail\sendmail.exe -t"

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =


sendmail.ini
Code: Select all
; configuration for fake sendmail

; if this file doesn't exist, sendmail.exe will look for the settings in
; the registry, under HKLM\Software\Sendmail

[sendmail]

; you must change mail.mydomain.com to your smtp server,
; or to IIS's "pickup" directory.  (generally C:\Inetpub\mailroot\Pickup)
; emails delivered via IIS's pickup directory cause sendmail to
; run quicker, but you won't get error messages back to the calling
; application.

smtp_server=127.0.0.1

; smtp port (normally 25)

smtp_port=25

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=local

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

;error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

;debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

auth_username=admin
auth_password=main_passwort

; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines

;pop3_server=
;pop3_username=
;pop3_password=

; to force the sender to always be the following email address, uncomment and
; populate with a valid email address.  this will only affect the "MAIL FROM"
; command, it won't modify the "From: " header of the message content

;force_sender=

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting.  you can manually set the ehlo/helo name if required

;hostname=localhost


Wenn ich jetzt allerdings die mail() FUnktion verwende kommt folgende Fehlermeldung:
Code: Select all
Warning: mail() [function.mail]: SMTP server response: 552 Site policy requires a SIZE declaration with the MAIL command. in D:\xampp\htdocs\test.php on line 2


die test.php sieht so aus:
Code: Select all
<?php
mail("meine@email.de", "Dies ist ein Test", "Hallo Welt!", "From:admin@slocalhost");
?>


Könnt ihr mir helfen?

Vielen Dank im voraus
D@rKrieger91
 
Posts: 1
Joined: 26. February 2009 20:36

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests