MySQL-Datenbank DEAKTIVIERT

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL-Datenbank DEAKTIVIERT

Postby th1alb » 19. February 2009 22:14

Moinsen Kollegas!
Viele meinen nun dieses Problem wurde schon in anderen Beiträgen gelöst... Jedoch habe ich mich schon durch die Foren gelesen und nichts brauchbares zu meinem Problem gefunden.
Folgendes:
(Habe Vista 32bit)
Ich habe Xampp installiert. Wenn ich das Xampp Control Panel starte habe ich keine Probleme den Apache Server und MySQl zum laufen zu bekommen. Unter http://localhost ist auch alles erreichbar (habe schon in cfg localhost durch 127.0.0.1 ersetzt).
So wenn ich mir den Status anschaue was alles aktiviert ist, habe ich folgende Auflistung:

MySQL-Datenbank DEAKTIVIERT
PHP AKTIVIERT
HTTPS (SSL) AKTIVIERT
Common Gateway Interface (CGI) AKTIVIERT
Server Side Includes (SSI) AKTIVIERT
SMTP Server DEAKTIVIERT
FTP Server DEAKTIVIERT

Mein Problem ist nun ----> MySQL-Datenbank DEAKTIVIERT. Aus diesem Grund kann ich auch nicht auf mein phpMyAdmin zugreifen.
Des weiteren ist ein Problem, dass sich MySQl unter dem Xampp Control Panel nicht beenden lässt. Starten ist kein Problem nur das Stoppen will er nicht so ganz machen.

Würd mich freuen wenn ein paar prodktive Beitrage kämen die mich weiter bringen.

GreEtZ
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: MySQL-Datenbank DEAKTIVIERT

Postby Wiedmann » 19. February 2009 22:17

Startest du MySQL als Dienst (SVC) oder nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySQL-Datenbank DEAKTIVIERT

Postby th1alb » 19. February 2009 22:31

Nein mach ich nicht

Edit: Beides getestet macht keinen unterschied
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: MySQL-Datenbank DEAKTIVIERT

Postby Wiedmann » 19. February 2009 22:50

Nein mach ich nicht

Was wird dann angezeigt, wenn du MySQL mit der Batchdatei startest?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySQL-Datenbank DEAKTIVIERT

Postby th1alb » 20. February 2009 15:35

Also hab dir ma ein paar Screens gemacht:

Xampp_Start.exe:
http://mr3.mr.ohost.de/Xampp/xampp_start.jpg

Xampp_Stop.exe:
http://mr3.mr.ohost.de/Xampp/xampp_stop.jpg

MySQL_start.bat :
http://mr3.mr.ohost.de/Xampp/mysql_start.jpg


Bei xampp_stop.exe is schon zu erkennen das was net stimmt. Hab aber keine Plan was.
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: MySQL-Datenbank DEAKTIVIERT

Postby Wiedmann » 20. February 2009 16:00

Also der mysql_start.bat nach läuft der MySQL.

Wenn du es ganz genau wissen willst, schau
a) in den Taskmanager
b) ins *.err Log vom MySQL.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySQL-Datenbank DEAKTIVIERT

Postby th1alb » 20. February 2009 18:04

Hey!
Bin weiter gekommen...
Hab nun fast alles zum laufen bekommen.
Bei meinen phpmyAdmin kommt aber diese Meldung:

#2005 - Unknown MySQL server host 'localhost' (11004)

bzw schau dir das bild ma an:

http://mr3.mr.ohost.de/Xampp/phpmyadmin.jpg
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: MySQL-Datenbank DEAKTIVIERT

Postby th1alb » 20. February 2009 21:08

pies digga.
passt nu alles! hat iwie an firewall gehangen
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Re: MySQL-Datenbank DEAKTIVIERT

Postby Wesley67 » 12. March 2009 01:11

Schade, dass die Antwort nicht ausführlicher war, was du da gemacht hast.
Ich habe das gleiche Problem vom Erscheinungsbild her. Hab Vista Home.

Inzwischen habe ich xampp mehrfach de- und neuinstalliert und jede Menge herumprobiert. Einiges führte zu partiellen Verbesserungen, wie z.B. das Umsetzen des Ports von Skype. Aber letzten Endes kann ich trotzdem nicht mit MySQL arbeiten.

Mein momentanes Erscheinungsbild:
Ich bekomme MySQl als Dienst zum laufen. Ich bekomme MySQL auch von der Konsole aus zum Laufen. Aber gehe ich auf die Status-Seite von XAMPP, wird mir trotzdem angezeigt, dass MySQL deaktiviert ist.

Historie:
Ich hatte ursprünglich XAMPP 1.0.7. installiert gehabt und bekam MySQL überhaupt nicht zum laufen, weder als Dienst, noch von der Console. Beim Dienst sagte die Ereignisanzeige, dass der Dienst unerwartet beendet wurde - ohne weiteres Detail.
Von der Konsole aus erhielt ich den Systemfehler 1067.
Ich habe in der my.ini die Einträge für User und Password an die vorgezogene Stelle gesetz, wie es in einigen Beiträgen empfohlen wurde. verschwand, aber MySQL hing irgendwie.

Dann deinstallierte ich Version 1.0.7 und installierte dafür Version 1.6.6. - nun startete MySQL zwar ( auch im Taskmanager zu sehen), aber in der Statusseite von XAMPP blieb das "DEAKTIVIERT". Auch phpMyAdmin startet nicht, sonder gab die Ausschrift "Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration." Doch das Paket sollte doch eigentlich ohne weitere Konfiguration funktionieren, oder? Auch nach dem kompletten Abschalten der Firewall änderte sich nichts am Fehlerbild.

Ich habe auf meinem Laptop ebenfalls XAMPP unter Vista installiert und es lief auf Anhieb problemlos. Also habe ich eine 1:1-Übernahme gemacht. Das Fehlerbild blieb weiterhin.
Bin inzwischen echt am Verzweifeln, weil ich nicht weiss, wo ich noch suchen soll. Für hilfreiche Tipps wäre ich unendlich dankbar!

Beste Grüße
Wes
Wesley67
 
Posts: 2
Joined: 12. March 2009 00:49

Re: MySQL-Datenbank DEAKTIVIERT

Postby Wesley67 » 12. March 2009 01:14

Hab versäumt den Thread zu abonieren - hiermit geschehen...
Wesley67
 
Posts: 2
Joined: 12. March 2009 00:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests