phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Postby Flattersatz » 03. February 2009 13:54

Guten Tag Community,

ich habe mir auf meinem Notebook parallel zu meinem Desktoprechner (beides Vista) das Programm Xampp (nicht die Mini Version) installiert.

Auf dem Desktop-PC läuft Xampp einwandfrei. Damit ich aber auch auf meinem NB* xampp unterwegs benutzen kann, wollte ich mir dieses Installieren. Zwecks dessen bin ich dazu auch die FAQ's von apachefriends durchgegangen und habe für Vista u.a. die Benutzerkontensteuerung ausgeschaltet.

Mittlerweile habe ich das dritte mal das PRogramm installiert (jetzt mit Diensten) und erhoffe mir, dass es funktioniert. Der Fehler bisher und immer noch ist oben in dem Threadtitel beschrieben: phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Wichtig ist noch folgendes: Damit das phpMyAdmin funktionierte habe ich in der config.inc.php die "auth" auf "http" umgestellt. Der Username ist "root" und ich habe kein PW vergeben. Trotzdem erhalte ich immer noch den Fehler:
phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Ich hoffe hier in dem Forum auf Hilfe zu stoßen...


EDIT: Habe ich vergessen:
Ich kann auch nicht den Status in dem localhost prüfen. Irgendwie scheint der da auch Probleme zu haben.....


Grüße, der Flattersatz

Legende:
(*Notebook)

PS Anhaltspunkte aus dem Forum:

- die Firewall blockt nicht die mysqld.exe
- Prozesse laufen: 2x apache.exe und einmal mysqld.exe
Flattersatz
 
Posts: 1
Joined: 03. February 2009 13:42

Re: phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Postby GHO » 22. February 2009 21:10

Hallo, ich schalte mich da mal mit auf.

Hatte unter vista die xampp 1.6 installiert vor wenigen Monaten, lief alles prima.
Zwischenzeitlich nichts groß geändert, einige windows updates wurden durchgeführt.

Jetzt habe ich dieselben Probleme sowohl beim Versuch der Neuinstallation 1.6. als auch 1.7. wie folgt:

die Fehlermeldung #2003 bei Browser eingabe localhost/xampp kommt wenn ich weiterklicke auf myphpadmin - allerdings sehe ich keinen mysql Prozess laufen - Der Status check zeigt daß die Datenbank deaktiviert ist..

Beim click auf die beiden Start Knöpfe im control panel von Apache und SQL kommt die Meldung ... started, aber nicht die gewohnte- glaub ich grüne - Anzeige

Im Control Panel ist das Häkchen bei SVC - mysql gesetzt,
Es kommt die Meldung: busy und dann MySQL Service started.
Versuche ich den Haken wegzunehmen (früher hatte ich den nie gesetzt) so kommt click OK to uninstall the MySQL Service
aber wenn klicke tut sich nichts.



Vielleicht hat jemand einen Tip was zu tun ist und woher plötzlich ein "Nichtfunktionieren" kommt.

Danke.
Günter
GHO
 
Posts: 35
Joined: 07. December 2008 18:19

Re: phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Postby bassclarinet » 25. February 2009 09:56

XAMPP 1.7.0 mit PHP 5.2.8 und MySQL 5.1 ?

Beim Ausführen einer Query, bzw. manchmal schon beim DB connect, stürzt PHP ab, und zieht, weil es als Apache handler läuft, den Apache Thread mit in den Abgrund, der den HTTP request bearbeitet. Somit kommt es dann beim Client zu der erwähnten Fehlermeldung. Apache startet den Thread neu, so dass der nächste Request dann möglicherweise wieder funktioniert.

Scheint ein Problem mit libmysql.dll zu sein. Folgendes hatte ich im englischsprachigem Board gepostet:

=====================================================
Look in both the apache\bin and php folders for the file libmysql.dll (or libmysql_*.dll, don't remember the exact name).

libmysql.dll is dated 17-dec-2008 19:48 and has 1646592 bytes.
Replace it by the file libmysql_*.dll dated 04-aug-2008 with 2068480 bytes.

If you don't have this file, download the PHP 5.2.8 binaries from php.net and extract this libmysql.dll.
After replacing the file, restart the server. Done.
=====================================================

mfg
bassclarinet
 
Posts: 2
Joined: 25. February 2009 09:45

Re: phpMyAdmin - Fehler #2003 - Der Server antwortet nicht.

Postby Wiedmann » 25. February 2009 10:12

Scheint ein Problem mit libmysql.dll zu sein.

Yup.

Folgendes hatte ich im englischsprachigem Board gepostet

"Korrekt" wäre:
- in "\xampp\apache\bin\" und "\xampp\php\" die "libmysql_5.0.51a.dll" jeweils nach "libmysql.dll" zu kopieren.

-in "\xampp\php\ext\" die "php_mysql_5.0.51a.dll" nach php_mysql.dll und die "php_mysqli_5.0.51a.dll" nach "php_mysqli.dll" zu kopieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests