Windows Vista und MySQL

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows Vista und MySQL

Postby badblacklion » 03. February 2009 13:36

Hiho,

ich habe heute den ganzen Vormittag damit zu gebracht, hier im Forum nach einer Lösung für mein Problem zu suchen. Leider ohne Erfolg.
Also hier meine Fehlerbeschreibung.
Ich habe XAMPP für Windows 1.7 über den Installer installiert und anschließend das Control-Panel(XCP) ausgeführt. Ich habe die UAC ausgeschaltet und XAMPP in c:/xampp installiert.
In dem XCP wird mir angezeigt, das MySQL als Service läuft, obwohl ich das bei der Installation nicht angewählt hatte. Wenn ich das Häckchen anklicke kommt eine Sicherheitsabfrage, welche ich mit OK bestätige. Allerdings wird dann das Häkchen automatisch wieder eingesetzt. :?:
Wenn ich das mal außer acht lasse und Versuche den Apache und MySQL zu starten dann startet er zwar den Apache, aber bei SQL bekomme ich die Meldung:
Code: Select all
ERROR: MySQL service not started [-1]!


Wäre toll wenn mir jemand helfen könnte. :cry:

MfG
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 03. February 2009 14:00

In dem XCP wird mir angezeigt, das MySQL als Service läuft, obwohl ich das bei der Installation nicht angewählt hatte.

Dann hattest du früher wohl mal einen MySQL als Service installiert, und dieser Service ist noch vorhanden.

Wenn ich das Häckchen anklicke kommt eine Sicherheitsabfrage, welche ich mit OK bestätige. Allerdings wird dann das Häkchen automatisch wieder eingesetzt.

Um Service zu manipulieren, musst du das Control-Panel als Administrator starten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 03. February 2009 16:42

Wiedmann wrote:
In dem XCP wird mir angezeigt, das MySQL als Service läuft, obwohl ich das bei der Installation nicht angewählt hatte.

Dann hattest du früher wohl mal einen MySQL als Service installiert, und dieser Service ist noch vorhanden.

Wenn ich das Häckchen anklicke kommt eine Sicherheitsabfrage, welche ich mit OK bestätige. Allerdings wird dann das Häkchen automatisch wieder eingesetzt.

Um Service zu manipulieren, musst du das Control-Panel als Administrator starten.

Auch wenn ich das XCP als Admin starte ist das Problem noch immer vorhanden. Auch hatte ich vorher kein MySQL als Service installiert. :(
Das schärfste ist ja, dass er den MySQL-Service beibehält obwohl ich XAMPP deinstalliere. Muss ich das auch noch als Admin ausführen? :?:
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 03. February 2009 16:50

Muss ich das auch noch als Admin ausführen?

Was ist das? XAMPP deinstallieren, oder die Service deinstallieren?

Aber der einfach halb halber, sollte man beides als Administrator machen (insb. wenn du den Installer benutzt).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 03. February 2009 18:20

Soooo
ich habe XAMPP noch einmal installiert und mir mal den MySQL-Dienst angesehen, der Pfad führt nach C:/xampp/mysql/bin/mysqld-shareware.exe, welche aber gar nicht existiert? :?:
Wie bekomme ich den Dienst jetzt aus meiner Diensteliste, weil mit XAMPP bekomm ich das Ding nicht weg. :cry:
Und wenn ich XAMPP neu installiere bleibt der alte Dienst leider erhalten. :?:
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby badblacklion » 03. February 2009 19:50

badblacklion wrote:Soooo
ich habe XAMPP noch einmal installiert und mir mal den MySQL-Dienst angesehen, der Pfad führt nach C:/xampp/mysql/bin/mysqld-shareware.exe, welche aber gar nicht existiert? :?:
Wie bekomme ich den Dienst jetzt aus meiner Diensteliste, weil mit XAMPP bekomm ich das Ding nicht weg. :cry:
Und wenn ich XAMPP neu installiere bleibt der alte Dienst leider erhalten. :?:

Damit ihr auch mitbekommt das sich hier was getan hat antworte ich lieber mal anstatt meinen eigenen Beitrag zu editieren.
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 03. February 2009 19:57

der Pfad führt nach C:/xampp/mysql/bin/mysqld-shareware.exe, welche aber gar nicht existiert? ... Wie bekomme ich den Dienst jetzt aus meiner Diensteliste,

Als erstes machst du eine Eingabeaufforderung als Administrator auf. Darin gibst du ein:
Code: Select all
sc delete mysql


Wenn du den MySQL jetzt noch korrekt als Dienst installieren willst, startest du in dieser Konsole "\xampp\mysql\mysql_installservice.bat".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 03. February 2009 20:04

Wiedmann wrote:
der Pfad führt nach C:/xampp/mysql/bin/mysqld-shareware.exe, welche aber gar nicht existiert? ... Wie bekomme ich den Dienst jetzt aus meiner Diensteliste,

Als erstes machst du eine Eingabeaufforderung als Administrator auf. Darin gibst du ein:
Code: Select all
sc delete mysql


Wenn du den MySQL jetzt noch korrekt als Dienst installieren willst, startest du in dieser Konsole "\xampp\mysql\mysql_installservice.bat".

Ich bin grundsätzlich Admin und habe es sowohl mit cmd als auch einfach über das ausführen im startmenü versucht.
Beim Ausführen passiert, oh Wunder, nix.
Beim cmd befehl bekomme ich die meldung: [SC] OPEN SERVICE Fehler 5: Zugriff verweigert.
Ich habe allerdings die UAC wieder aktiviert, sollte es daran liegen.
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 03. February 2009 20:22

Ich bin grundsätzlich Admin und habe es sowohl mit cmd als auch einfach über das ausführen im startmenü versucht.

Es ging nicht darum ob du mit deinem User "Computeradministrator" bist, sondern dass du eben im Startmenü die Eingabeaufforderung mit rechts anklickst, und sagst: "Als Administrator starten".

Ich habe allerdings die UAC wieder aktiviert, sollte es daran liegen.

Zumindest wenn man den XAMPP mit dem Installer de/installiert, sollte dieses solange aus sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 03. February 2009 20:32

badblacklion wrote:Beim cmd befehl bekomme ich die meldung: [SC] OPEN SERVICE Fehler 5: Zugriff verweigert.

SO da wir das nu geklärt hätten. Wie sieht es mit dieser Fehlermeldung aus?
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 03. February 2009 21:09

Wie sieht es mit dieser Fehlermeldung aus?

Hast du jetzt die Eingabeaufforderung als Administrator gestartet?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 04. February 2009 06:55

Wiedmann wrote:
Wie sieht es mit dieser Fehlermeldung aus?

Hast du jetzt die Eingabeaufforderung als Administrator gestartet?

Ich verfluche schonjetzt den Tag an dem ich auf Vista umgestiegen bin. :evil:
Wie mache ich das mit der Eingabeaufforderung als Admin?
Normalerweise mit ausfürhren und dann cmd oder nicht?
Gibt es noch eine andere Eingabeaufforderung??
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby Wiedmann » 04. February 2009 08:18

Wie mache ich das mit der Eingabeaufforderung als Admin?

Wie führe ich einen Befehl mit erhöhten Rechten aus?:
http://windowshelp.microsoft.com/Window ... 1.mspx#E5E
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Windows Vista und MySQL

Postby badblacklion » 04. February 2009 08:22

Wiedmann wrote:
Wie mache ich das mit der Eingabeaufforderung als Admin?

Wie führe ich einen Befehl mit erhöhten Rechten aus?:
http://windowshelp.microsoft.com/Window ... 1.mspx#E5E

Ja na endlich. :D
SC delete erfolgreich durchgeführt.
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Re: Windows Vista und MySQL

Postby badblacklion » 04. February 2009 08:37

Soo, hab XAMPP neu installiert in dem ich es als Admin ausgeführt habe. Nun läuft auch wie gewünscht der MySQL-Service nicht. So an sich scheint auch alles zu funktionieren, nur leider komme ich nicht auf die Sicherheitscheck-Seiten. :?
Image
badblacklion
 
Posts: 10
Joined: 03. February 2009 13:23

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests