MySQL-Probleme nach xampp-Patch

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL-Probleme nach xampp-Patch

Postby Innocentus » 01. February 2009 15:40

Ich habe mein xampp (ehemals Version 1.6.7) mit einem Patch ( Upgrade 1.6.7 auf 1.6.8 ) von der xampp Webseite auf Version 1.6.8 geupdatet.
Danach habe ich den nachfolgenden Patch ( Upgrade 1.6.8 auf 1.7.0 ) verwendet, um xampp auf Version 1.7.0 zu updaten.
Zuletzt habe ich dann noch den letzten aktuellen Patch ( Patch2 für 1.7.0 ) für xampp Version verwendet.

Der Server läuft wunderbar - eigentlich keine Probleme -
Alledings tritt jetzt aber ein Fehler auf, wenn ich in meinem MySQL-Frontend (Navicat, phpMyAdmin, whatsoever, ...) eine Datenbank öffne.
Die Verbindungsherstellung funktioniert ohne Probleme - aber beim Öffnen einer Datenbank erhalte ich folgende Fehlermeldung:
1577 - Cannot proceed because system tables used by Event Scheduler were found damaged at server start


Was kann ich machen? Der Patch (die Patches) hat aus welchen Gründen auch immer den MySQL-Server wahrscheinlich an dieser Stelle beschädigt.
Das ist natürlich sehr ärgerlich - denn ich brauche den Zugriff auf die Datenbank ständig. Und zurzeit kann ich das deswegen leider nicht.

Vielleicht weiss jemand ja einen Tipp oder eine Lösung.
- Ich danke euch für eine rasche Antwort.
Mit freundlichen Grüßen
Innocentus
Innocentus
 
Posts: 32
Joined: 28. January 2009 14:10

Re: MySQL-Probleme nach xampp-Patch

Postby Innocentus » 01. February 2009 20:52

Ich habe einmal zwischen zwei Datenbanken hin- und hergewechselt und sie zu öffnen versucht
- und dann ging es plötzlich.
Allerdings tritt der Fehler leider trotzdem ab und zu auf.

Mit freundlichen Grüßen
Innocentus
Innocentus
 
Posts: 32
Joined: 28. January 2009 14:10

Re: MySQL-Probleme nach xampp-Patch

Postby Innocentus » 06. February 2009 14:17

Ich habe eine Lösung gefunden:
viewtopic.php?f=4&t=32506#p131490

Bei Vista-Benutzern hat mysql_upgrade übrigens das Problem, auf den Ordner C:\temp zuzugreifen
(dieser wird ja mit dem Parameter -t angegeben (s. Anleitung, Link oben)).
Stattdessen sollte irgendwo auf dem Benutzer-Desktop ein Ordner angelegt werden
und dessen Pfad als temporärer Ordner angegeben werden (z.B. -t C:\Users\...\...\[usw.]).

Mit freundlichen Grüßen
Innocentus
Innocentus
 
Posts: 32
Joined: 28. January 2009 14:10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests