httpd.conf geändert - Console macht es net mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 29. January 2009 13:13

Hallo zusammen,

ich habe jetzt schon mehrere Tage ohne Ergebnis gesucht.
Folgendes Problem:
Ich habe aus Sicherungsgründen mein htdocs Verzeichnis auf ein Netzlaufwerk verschoben, da von diesem abendlich eine Spiegelung gemacht wird.
Ich habe dann die httpd.conf angepasst und zwar an beiden Stellen wo ich htdocs finden konnte (DocumentRoot && <Directory...).

So weit so gut. Wenn ich den Rechner nun hochfahre wird XAMPP nachwievor gestartet, allerdings nur noch der SQL Dienst, nicht aber APACHE.
Der Server wird also nicht hochgefahren. Eine Fehlermeldung gibt es nicht.

Wenn ich nun die Konsole schließe und XAMPP mittels xampp_start.exe starte, dann erhalte ich die Fehlermeldung:
Warning: DocumentRoot [C:/xampp/htdocs] does not exist...

WTF?? Ich habe doch in der Conf das Verzeichnis geändert.
Lustig ist aber, dass APACHE dann trotzdem gestartet wird und ich ganz normal mittels localhost auf die Dienste zugreifen kann.

Kennt jemand diesen BUG? Oder hat einen Tipp für mich?

Danke und Grüße

ToM80

EDIT: Habe gerade noch manuell alle Einträge in der registration mittels regedit umgetragen, auch dies hat keine Änderung herbeigeführt. :x
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03

Re: httpd.conf geändert - Console macht es net mehr

Postby glitzi85 » 29. January 2009 15:22

Was genau hast du in deiner httpd.conf eingetragen? Ein Netzlaufwerk oder einen UNC-Pfad (\\server\pfad)?

Ein Netzlaufwerk existiert beim starten des Service natürlich noch nicht, da ja Netzlaufwerke erst bei der Anmeldung gemappt werden. Du musst also den UNC-Pfad verwenden.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 29. January 2009 15:24

Hi Glitzi,

danke für deinen Beitrag, aber auch beim manuellen Start der über die Konsole schlägt der Apachedienst fehl :(

Grüße

ToM80
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03

Re: httpd.conf geändert - Console macht es net mehr

Postby glitzi85 » 29. January 2009 16:05

Deinstallier mal bitte den Service, dann starte Apache über die apache_start.bat im XAMPP Verzeichnis. Da sollte dann eine Fehlermeldung inkl. Zeilennummer in der Datei kommen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 29. January 2009 16:22

So ist deinatalliert. Die DOS-Konsole bei Start mittels apache_start.bat gibt aber weiterhin nur die Warnmeldung wie vorhin bereits beschrieben aus:

Apache 2 is starting ...
Warning: DocumentRoot [C:/xampp/htdocs] does not exist :x
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03

Re: httpd.conf geändert - Console macht es net mehr

Postby glitzi85 » 29. January 2009 16:29

Seltsam. Hab das grad bei mir getestet. Ändere mal die DocumentRoot und Directory Angaben auf dieses format:

Code: Select all
DocumentRoot "//server/path/to/htdocs"

<Directory "//server/path/to/htdocs">
[...]


Wenn das nicht funktioniert, poste bitte mal die komplette httpd.conf.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 29. January 2009 17:19

Fehlermeldung bleibt die gleiche

Hier die httpd.conf, ich habe die Kommentare mal rausgenommen wg. Übersichtlichkeit
Code: Select all
ThreadsPerChild 250
MaxRequestsPerChild  0
ServerRoot "C:/xampp/apache"
Listen 80
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule include_module modules/mod_include.so
LoadModule info_module modules/mod_info.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule status_module modules/mod_status.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule autoindex_color_module modules/mod_autoindex_color.so
ServerAdmin admin@localhost
ServerName localhost:80
DocumentRoot "//master/user/uname/eigene dateien/htdocs"
<Directory "//master/user/uname/eigene dateien/htdocs">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
<IfModule dir_module>
    DirectoryIndex index.php index.php4 index.php3 index.cgi index.pl index.html index.htm index.shtml index.phtml
</IfModule>
<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
</FilesMatch>
ErrorLog logs/error.log
LogLevel warn
<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>
    CustomLog logs/access.log common
</IfModule>
<IfModule alias_module>
    ScriptAlias /cgi-bin/ "C:/xampp/cgi-bin/"
</IfModule>
<Directory "C:/xampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>
DefaultType text/plain
<IfModule mime_module>
    TypesConfig conf/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddHandler cgi-script .cgi
   AddType text/html .shtml
   AddOutputFilter INCLUDES .shtml
</IfModule>
EnableMMAP off
EnableSendfile off
Include conf/extra/httpd-xampp.conf
Include conf/extra/httpd-multilang-errordoc.conf
Include conf/extra/httpd-autoindex.conf
Include conf/extra/httpd-languages.conf
Include conf/extra/httpd-userdir.conf
Include conf/extra/httpd-info.conf
Include conf/extra/httpd-vhosts.conf
Include conf/extra/httpd-manual.conf
Include conf/extra/httpd-dav.conf
Include conf/extra/httpd-default.conf
Include conf/extra/httpd-ssl.conf

<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>


Auch unter "conf/extra/httpd-xampp.conf" habe ich den Pfad geändert, Problem bleibt bestehen *grml* Ist zum in die Tischkante beißen!
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03

Re: httpd.conf geändert - Console macht es net mehr

Postby Wiedmann » 29. January 2009 18:05

Code: Select all
Include conf/extra/httpd-ssl.conf

SSL ist ein VHost, bei dem natürlich auch ein DocumentRoot definiert ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 29. January 2009 18:18

Jo danke, dort habe ich das übersehen. Habe SSL nun deaktiviert, da ich es in meiner Testumgebung eh nicht benötige.
Fehlermeldung ist nun getilgt, aber das Problem mit dem Start aus dem XAMPP Control Panel besteht weiter :( Bekomme für Apache kein Running :(( Und eine Verbindung zum "localhost" ist nicht möglich.

Grüße

ToM80
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03

Re: httpd.conf geändert - Console macht es net mehr

Postby glitzi85 » 29. January 2009 20:07

Wenn du versuchst den Apachen aus dem CP heraus zu starten, ist dann der Service installiert oder nicht? Falls Service installiert ist, schau doch bitte mal in den Eventlogs (Start -> Ausführen -> eventvwr.msc) nach Fehlermeldungen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: httpd.conf geändert - Console macht es net mehr

Postby ToM80 » 30. January 2009 11:06

Meckert rum wg. Syntaxfehler und das Document Root ein Ordner sein muss (Bei Systemstart und auch bei manuellem "Nachstartversuch").
Ich blick das nicht. Mittels xampp_start.exe gibt es keine Fehlermeldung und alles läuft. Glaub ich übernehme einfach die .exe in den Autostart und lasse 5gerade sein.
ToM80
 
Posts: 6
Joined: 29. January 2009 13:03


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests