vhost mit xampp 1.7.0

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 21:40

Hallo,

ich habe meinen Webserver (W2k3) neu aufgesetzt und bei der Gelegenheit auch das neue xampp installiert. Leider funzt jetzt das virtual hosting nicht mehr. Wenn ich in der httpd.conf die httpd-vhosts "include" lässt sich der apache nicht mehr starten. Meine httpd-vhost sieht folgendermaßen aus:

Use name-based virtual hosting.
NameVirtualHost *:80

NameVirtualHost msnetwork.dyndns.org:80
<VirtualHost msnetwork.dyndns.org:80>
ServerName msnetwork.dyndns.org
ServerAlias msnetwork.dyndns.org
ServerAdmin webmaster@msnetwork.dyndns.org
DocumentRoot w:/webroot/htdocs/
CustomLog w:/webroot/apache/logs/access.log combined
ErrorLog w:/webroot/apache/logs/error.log
ScriptAlias /cgi-bin w:/webroot/apache/cgi-bin
<Directory w:/webroot/apache/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/htdocs/>
Options +Indexes
</Directory>
</VirtualHost>


NameVirtualHost claudias.hobby-site.com:80
<VirtualHost claudias.hobby-site.com:80>
ServerName claudias.hobby-site.com
ServerAlias claudias.hobby-site.com
ServerAdmin webmaster@claudias.hobby-site.com
DocumentRoot w:/webroot/virtual/claudias.hobby-site.com/html
CustomLog w:/webroot/virtual/claudias.hobby-site.com/logs/access.log combined
ErrorLog w:/webroot/virtual/claudias.hobby-site.com/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/claudias.hobby-site.com/cgi-bin
<Directory w:/webroot/virtual/claudias.hobby-site.com/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/claudias.hobby-site.com/html>
Options +Indexes
</Directory>
</VirtualHost>


NameVirtualHost giulia-marie.no-ip.org:80
<VirtualHost giulia-marie.no-ip.org:80>
ServerName giulia-marie.no-ip.org
ServerAlias giulia-marie.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/giulia-marie.no-ip.org/html
CustomLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/html>
Options +Indexes
</Directory>
</VirtualHost>



NameVirtualHost logistic.no-ip.org:80
<VirtualHost logistic.no-ip.org:80>
ServerName logistic.no-ip.org
ServerAlias logistic.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/logistic.no-ip.org/html
CustomLog w:/webroot/virtual/logistic.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/logistic.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/logistic.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/logistic.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/logistic.no-ip.org/html>
Options +Indexes
AllowOverride All
</Directory>
</VirtualHost>

Der erste Block ist meine Hauptseite, welche ohne Einbindung der httpd-vhosts auch einwandfrei läuft.
Der Pfad "w" ist ein Netzlaufwerk, sollte aber nicht weiter stören da ich den apache nicht als Service laufen lasse.

In der httpd.conf habe ich nichts geändert ausser bei folgende Zeilen die Raute zu entfernen:

Include conf/extra/httpd-info.conf
Virtual hosts
Include conf/extra/httpd-vhosts.conf

Ich kann den (die) Fehler nicht finden und bin für jeden Hinweis dankbar!

Gruß Micha
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04

Re: vhost mit xampp 1.7.0

Postby glitzi85 » 27. January 2009 21:53

Ich hoffe schwer dass du die Kommentarzeichen nur für das Forum entfernt hast, sonst kann das nicht funktionieren.

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
ServerName msnetwork.dyndns.org
ServerAlias msnetwork.dyndns.org
ServerAdmin webmaster@msnetwork.dyndns.org
DocumentRoot w:/webroot/htdocs/
CustomLog w:/webroot/apache/logs/access.log combined
ErrorLog w:/webroot/apache/logs/error.log
ScriptAlias /cgi-bin w:/webroot/apache/cgi-bin
<Directory w:/webroot/apache/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/htdocs/>
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName claudias.hobby-site.com
ServerAlias claudias.hobby-site.com
ServerAdmin webmaster@claudias.hobby-site.com
DocumentRoot w:/webroot/virtual/claudias.hobby-site.com/html
CustomLog w:/webroot/virtual/claudias.hobby-site.com/logs/access.log combined
ErrorLog w:/webroot/virtual/claudias.hobby-site.com/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/claudias.hobby-site.com/cgi-bin
<Directory w:/webroot/virtual/claudias.hobby-site.com/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/claudias.hobby-site.com/html>
Options +Indexes
</Directory>
</VirtualHost>


<VirtualHost *:80>
ServerName giulia-marie.no-ip.org
ServerAlias giulia-marie.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/giulia-marie.no-ip.org/html
CustomLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/html>
Options +Indexes
</Directory>
</VirtualHost>



<VirtualHost *:80>
ServerName logistic.no-ip.org
ServerAlias logistic.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/logistic.no-ip.org/html
CustomLog w:/webroot/virtual/logistic.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/logistic.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/logistic.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/logistic.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/logistic.no-ip.org/html>
Options +Indexes
AllowOverride All
</Directory>
</VirtualHost>


mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 22:01

Nein habe ich nicht.
Die Konfiguration lief genau so auf meinem alten xampp.
Erstellt habe ich das Ganze damals mit Apanatschi.

Was muss ich denn auskommentieren?
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04

Re: vhost mit xampp 1.7.0

Postby glitzi85 » 27. January 2009 22:06

new_micha wrote:Die Konfiguration lief genau so auf meinem alten xampp.

Kurzum, das ist schlicht unmöglich. Konfigurationsanweisungen wie
Code: Select all
Use name-based virtual hosting.
würden den Apachen definitiv nicht mehr starten lassen!

Kopier einfach die von mir gepostetet Konfiguration und ersetze alles in der httpd-vhosts.conf damit.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 22:13

Ok, habe ich gemacht - meine conf sieht jetzt so aus:

#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.


NameVirtualHost *:80

<VirtualHost *:80>
ServerName msnetwork.dyndns.org
ServerAlias msnetwork.dyndns.org
ServerAdmin webmaster@msnetwork.dyndns.org
DocumentRoot w:/webroot/htdocs/
CustomLog w:/webroot/apache/logs/access.log combined
ErrorLog w:/webroot/apache/logs/error.log
ScriptAlias /cgi-bin w:/webroot/apache/cgi-bin
<Directory w:/webroot/apache/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/htdocs/>
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName claudias.hobby-site.com
ServerAlias claudias.hobby-site.com
ServerAdmin webmaster@claudias.hobby-site.com
DocumentRoot w:/webroot/virtual/claudias.hobby-site.com/html
CustomLog w:/webroot/virtual/claudias.hobby-site.com/logs/access.log combined
ErrorLog w:/webroot/virtual/claudias.hobby-site.com/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/claudias.hobby-site.com/cgi-bin
<Directory w:/webroot/virtual/claudias.hobby-site.com/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/claudias.hobby-site.com/html>
Options +Indexes
</Directory>
</VirtualHost>


<VirtualHost *:80>
ServerName giulia-marie.no-ip.org
ServerAlias giulia-marie.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/giulia-marie.no-ip.org/html
CustomLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/giulia-marie.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/giulia-marie.no-ip.org/html>
Options +Indexes
</Directory>
</VirtualHost>



<VirtualHost *:80>
ServerName logistic.no-ip.org
ServerAlias logistic.no-ip.org
ServerAdmin webmaster@giulia-marie.no-ip.org
DocumentRoot w:/webroot/virtual/logistic.no-ip.org/html
CustomLog w:/webroot/virtual/logistic.no-ip.org/logs/access.log combined
ErrorLog w:/webroot/virtual/logistic.no-ip.org/logs/error.log
ScriptAlias /cgi-bin w:/webroot/virtual/logistic.no-ip.org/cgi-bin
<Directory w:/webroot/virtual/logistic.no-ip.org/cgi-bin>
Options ExecCGI
</Directory>
<Directory w:/webroot/virtual/logistic.no-ip.org/html>
Options +Indexes
AllowOverride All
</Directory>
</VirtualHost>

...und der apache startet nicht :-(
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04

Re: vhost mit xampp 1.7.0

Postby glitzi85 » 27. January 2009 22:23

Dann starte den Apache mal bitte mit der Batch-Datei im XAMPP-Ordner.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 22:39

Super Tipp, der Fehler wurde mir angezeigt. Es muss so in der httpd.conf aussehen:

Include conf/extra/httpd-info.conf
#Virtual hosts
Include conf/extra/httpd-vhosts.conf

und nicht:

Include conf/extra/httpd-info.conf
Virtual hosts
Include conf/extra/httpd-vhosts.conf

Jetzt startet der apache, aber nun habe ich einen Error 404 - Zugriff verweigert bei den vhosts.

Gruß Micha
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04

Re: vhost mit xampp 1.7.0

Postby glitzi85 » 27. January 2009 22:51

OK, das mit der httpd.conf hab ich übersehen.

Schau doch bitte mal im error.log des entsprechenden vHosts nach, woran das liegt mit dem 404er.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 22:58

Hallo,

ich habe jetzt vor die vhosts folgendes gelegt:

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>

Jetzt funzt alles - aber habe ich damit ein Sicherheitsrisiko generiert?

Gruß Micha
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04

Re: vhost mit xampp 1.7.0

Postby glitzi85 » 27. January 2009 23:27

OK, dann war's wohl kein 404er, sondern ein 403er.

Ein richtiges Loch ist es nicht, aber ganz sauber ist was anderes. Ersetze

Code: Select all
<Directory />

durch
Code: Select all
<Directory w:/webroot>


mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: vhost mit xampp 1.7.0

Postby new_micha » 27. January 2009 23:34

Perfect!!!

Es funzt alles so wie es sollte!

Meinen heissen Dank an dieses super Forum und einen speziellen Gruß an glitzi.
Mir wurde bisher noch nie so schnell und so kompetent in einem Forum geholfen.


Weiter so!
Gruß Micha
new_micha
 
Posts: 6
Joined: 27. January 2009 21:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests