Error 403 Zugriff verweigert bei 1.7.0

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Error 403 Zugriff verweigert bei 1.7.0

Postby kingacid23 » 23. January 2009 04:05

Hallo !

XAMPP gestartet, läuft,

Folgendes am Ende der httpd ergänzt:

include "G:/WebServer/apache/conf/raptor_vhosts.conf"
(1 korrekt konfigurierter vHost)

Error 403 Zugriff verweigert auf http://localhost/xampp

Wat soll dat ?! Ging früher auch immer ganz problemlos.
Hatte im Oktober noch die 1.6.8 drauf, warum funktioniert
das nun nicht mehr ?!

Apache log:
[Fri Jan 23 04:01:38 2009] [error] [client 127.0.0.1] client denied by server configuration: G:/Projekte/xampp, referer: http://localhost/xampp/

Ideen ?! Danke, vg
Jeder fängt mal klein an ;-)
User avatar
kingacid23
 
Posts: 7
Joined: 03. February 2006 10:10

Re: Error 403 Zugriff verweigert bei 1.7.0

Postby Wiedmann » 23. January 2009 08:32

Wat soll dat ?!

Keine Ahnung, was steht in der Datei drin?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Error 403 Zugriff verweigert bei 1.7.0

Postby kingacid23 » 23. January 2009 13:39

Meinst du das jetzt echt ernst ?! ... oder haste schneller gelesen als ....



NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
ServerName projekte
ServerAlias 127.0.0.1
DocumentRoot G:/Projekte
</VirtualHost>

...
Jeder fängt mal klein an ;-)
User avatar
kingacid23
 
Posts: 7
Joined: 03. February 2006 10:10

Re: Error 403 Zugriff verweigert bei 1.7.0

Postby kingacid23 » 23. January 2009 14:25

Lösung

deny from all in httpd.conf auf Allow from all setzen

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>

so jet gehen meine vHosts wieder
Jeder fängt mal klein an ;-)
User avatar
kingacid23
 
Posts: 7
Joined: 03. February 2006 10:10

Re: Error 403 Zugriff verweigert bei 1.7.0

Postby Wiedmann » 23. January 2009 14:29

deny from all in httpd.conf auf Allow from all setzen

Damit erlaubst du natülich für "alles und jeden" Zugriff auf deine ganze Platte...

Wie du schon in der "httpd.conf" sehen kannst, ist die korrekte Lösung, für das DocumentRoot einen entsprechenden Directory-Block anzulegen. (Den Block für "/" langt man natürlich nie an...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests