Frage zu SSL

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Frage zu SSL

Postby admin-x » 18. November 2003 17:30

Hi,

Unter \Quickstart liegt der Order \Typo3 für die Administration. Dieser kann nicht verschoben werden.

Dass Problem ist nun, dass ich eben so das Adminmenü auch über http aufrufen kann. Dass soll aber nicht sein !!http://R273WW2P/Typo3/index.php

Wie stelle ich es am besten an, dass der Ordner nur über SSL erreichbar ist ?

Hier ein Auszug aus der httpd.conf:

LoadModule ssl_module modules/mod_ssl.so
# mod_ssl configuration
SSLMutex sem
SSLRandomSeed startup builtin
SSLSessionCache none
SSLLogLevel warn

<VirtualHost R273WW2P:443>
ServerName R273WW2P
DocumentRoot "C:/Apache/htdocs/quickstart"
SSLEngine On
SSLCertificateFile cert/test-zertifikat.crt
SSLCertificateKeyFile cert/test-zertifikat.key
</VirtualHost>

<VirtualHost R273WW2P:80>
ServerName R273WW2P
DocumentRoot "C:/Apache/htdocs/quickstart"
</VirtualHost>

-------------------------------------------------
\apache\htdocs\quickstart\typo3
-------------------------------------------------

So hats jedenfalls nicht funktioniert:

<VirtualHost R273WW2P:80>
ServerName R273WW2P
DocumentRoot "C:/Apache/htdocs/quickstart"
<Directory /Typo3>
Order Deny,Allow
Deny from all
Allow from *:443
</Directory>
</VirtualHost>

Gruß
Marcus
admin-x
 
Posts: 1
Joined: 18. November 2003 09:55

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests