XAMPP und SSI

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP und SSI

Postby j4leo » 16. January 2009 21:19

Habe die Version 1.6.8 auf meinem Windows PC (XP) installiert. Die Standardfunktionalität ist soweit ok.
Nun möchte ich Server Side Includes einbinden. Soweit ich beurteilen kann, ist die Funktion standardmässig freigeschaltet.
Ich kann die Seite aufrufen, aber nichts passiert.

Gibt es dazu Erfahrungen?

Vielen Dank.

Mfg
Jürgen
j4leo
 
Posts: 3
Joined: 16. January 2009 21:06

Re: XAMPP und SSI

Postby Nobbie » 16. January 2009 21:53

>Soweit ich beurteilen kann, ist die Funktion standardmässig freigeschaltet.

Woran beurteilst und erkennst Du das?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: XAMPP und SSI

Postby j4leo » 17. January 2009 15:20

Hallo Nobbie,
ich habe die XAMPP-Distribution mit CMS von der CD C't extra Webdesign von 2008 installiert. Joomla
funktioniert damit ganz gut. In derselben Zeitschrift gibt es einen Artikel über SSI.

Ich habe im Verzeichnis htdocs eine Datei mit dem Namen show.shtml mit folgendem Inhalt
<!-- #printenv -->
angelegt und die Datei über den Apache-Webserver mit dem Browser Firefox aufgerufen. Die Ausgabe war
eine leere Seite.
In den Logdateien war nichts verdächtiges zu sehen.

In der Standardkonfiguration scheint SSI aktiv zu sein - siehe

Auszüge ausd der Konfigurationsdatei httpd.conf:
...
LoadModule include_module modules/mod_include.so
...
<Directory "/xampp/htdocs">
...
Options Indexes FollowSymLinks Includes ExecCGI
...
<IfModule mime_module>
...
#
# Filters allow you to process content before it is sent to the client.
#
# To parse .shtml files for server-side includes (SSI):
# (You will also need to add "Includes" to the "Options" directive.)
#
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>


Gruß Jürgen
j4leo
 
Posts: 3
Joined: 16. January 2009 21:06

Re: XAMPP und SSI

Postby Wiedmann » 17. January 2009 15:40

Code: Select all
<!-- #printenv -->
    ^---

Da darf kein Leerzeichen rein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP und SSI

Postby j4leo » 18. January 2009 11:24

vielen Dank,
es funktioniert nun.

In der Vorlage sah interpretierte ich unbewusst das Leerzeichen mit ein.

Gruß Jürgen
j4leo
 
Posts: 3
Joined: 16. January 2009 21:06


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests