Frage zu Neuinstallation

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Frage zu Neuinstallation

Postby tcgass » 16. January 2009 07:10

Hallo zusammen
ich hatte xampp lange Zeit erfolgreich auf meinem Laptop eingesetzt (installiert hatte ich auf Laufwerk D, also nicht auf der Systemdisk), nun wurde es jedoch leider nötig, den Rechner komplett neu aufzusetzen (dh Laufwerk C, das Laufwerk D ist mit allen Daten inklusive Xampp-Ordner nach wie vor komplett vorhanden).
Xampp läuft jetzt natürlich nicht mehr (weil Dateien auf dem Systemlaufwerk fehlen???) und ich denke, dass ich deswegen eine Neuinstallation vornehmen muss. Wie gehe ich am besten vor, um anschliessend meine alten Daten, also htdocs und Datenbanken, wieder zur Verfügung zu haben?
Danke für Eure Hilfe

Thomas
tcgass
 
Posts: 7
Joined: 30. January 2007 13:49

Re: Frage zu Neuinstallation

Postby glitzi85 » 16. January 2009 11:23

XAMPP installiert nichts im System, es sollte auch weiterhin lauffähig sein. Das Teil läuft ja sogar vom USB-Stick. Was genau läuft denn nicht bzw bekommt du eine Fehlermeldung?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Frage zu Neuinstallation

Postby tcgass » 18. January 2009 12:42

Nun, es lief gar nichts, beim Start von Apache blieb das Dos Fenster einfach stundenlang offen... Nun, ich hab' mittlerweile eine Kopie von meinem Xamp Folder auf D:\ als Backup gemacht, und Xamp neu installiert. Nun läuft zwar alles an, allerdings kann ich MySQL nicht mehr starten. Im Control Panel kann ich zwar den Start button drücken, aber nix passiert...
Thomas
tcgass
 
Posts: 7
Joined: 30. January 2007 13:49

Re: Frage zu Neuinstallation

Postby glitzi85 » 19. January 2009 00:08

Stand denn etwas in dem Fenster?

Versuch MySQL mit der Batch-Datei zu starten, da sollte dann eine Fehlermeldung ausgegeben werden.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Frage zu Neuinstallation

Postby tcgass » 19. January 2009 10:10

Hallo glitzi
ich hab's schlussendlich hingekriegt, weiss eigentlich selber nicht weshalb, aber jetzt startet es auf, nachdem ich im Control Panel den Svc für MySql abgewählt habe. All meine Datenbanken sind verfügbar, und für den Moment ist mein Problem gelöst (obschon ich gerne wüsste, weshalb ich MySql nicht als Dienst laufen lassen kann...)
Herzlichen Dank und Grüsse
Thomas
tcgass
 
Posts: 7
Joined: 30. January 2007 13:49

Re: Frage zu Neuinstallation

Postby glitzi85 » 19. January 2009 13:43

Bin mir grad nicht sicher, kann aber dran liegen weil du XAMPP auf eine andere Partition verschoben hast. Dienste müssen natürlich in der Registry eingetragen werden. Führ mal die setup_xampp.bat aus und versuch danach den Dienst wieder zu installieren.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests