Fehler beim Aufruf des Sicherheitschecks

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: Fehler beim Aufruf des Sicherheitschecks

Postby glitzi85 » 23. January 2009 16:34

@leenash: Kannst du mal den Inhalt dieser Dateien posten:

Code: Select all
C:\TMforeverSERVER\apache\logs\access.log
C:\TMforeverSERVER\apache\logs\error.log
C:\TMforeverSERVER\apache\conf\extra\httpd-xampp.conf


mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Fehler beim Aufruf des Sicherheitschecks

Postby Thor79 » 26. January 2009 16:52

EDIT: Problem hat sich erledigt. Habe in der ttpd-xampp.conf Datei den localhost durch 127.0.0.1 in der falschen Zeile ersetzt. Statt in der Zeile bei Alias /security "C:/xampp/security/htdocs/" hatte ich es erst bei Alias /phpmyadmin "C:/xampp/phpMyAdmin/" abgeändert... :mrgreen:
Naja, jetzt klappt es. :)


Hallo erstmal,
ich habe die nötige Einstellung in der httpd-xampp.conf Datei von "localhost" auf "127.0.0.1" vorgenommen. Leider kommt bei mir (weiterhin) folgende Fehlermeldung, wenn ich den Sicherheitscheck aufrufe über xampp:
Zugriff verweigert!

Der Zugriff auf das angeforderte Objekt ist nicht möglich. Entweder kann es vom Server nicht gelesen werden oder es ist zugriffsgeschützt.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403
localhost
01/26/09 16:51:48
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

Habe ich trotzdem noch etwas falsch gemacht oder woran liegt das, dass ich nicht auf den SIcherheitscheck komme?

Gruß
Thorsten
Thor79
 
Posts: 5
Joined: 26. January 2009 16:48

Re: Fehler beim Aufruf des Sicherheitschecks

Postby Johnny Rocket » 29. January 2009 01:58

hi alle zusammen,

ich hab da ne lösung für euch:

1. ruft die datei: httpd-xampp.conf zu finden unter: c:\xampp\apache\conf\extra
2. sucht nach folgenden eintrag:

Code: Select all
    Alias /security "D:/xampp/security/htdocs/"
    <Directory "D:/xampp/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order deny,allow
        Deny from all
        Allow from localhost
    </Directory>


der eintrag Deny from all verhindert den zugriff auf den sicherheitscheck von xampp. löscht diesen einfach oder ersetzt den o.g. code-abschnitt durch:

Code: Select all
    Alias /security "D:/xampp/security/htdocs/"
    <Directory "D:/xampp/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order deny,allow
        Allow from localhost
    </Directory>


nach dem entfernen, hat man den gewohnten zugriff. hab mich eben im forum registriert - offenbar haben einige von euch probleme mit vista & xampp. helfen wird dies:

1. ruft folgenden dateipfad auf: C:\Windows\System32\drivers\etc
2. öffnet die datei hosts. den eintrag:

Code: Select all
127.0.0.1       localhost
::1             localhost


löschen. danach sollte es keine probleme mehr mit der weboberfläche von xampp geben. hoffe die kleinen tips helfen euch.

gruß@all
Johnny Rocket
 
Posts: 2
Joined: 29. January 2009 01:34

Re: Fehler beim Aufruf des Sicherheitschecks

Postby glitzi85 » 29. January 2009 08:01

Johnny Rocket wrote:ich hab da ne lösung für euch:

Bitte zuerst die Dokumentation lesen bevor du sowas behauptest. Mit Deny from all wird zwar zuerst der Zugang geblockt, allerdings wird er in der nächsten Zeile durch Allow from localhost für localhost wieder freigegeben. Theoretisch funktioniert das so, praktisch gibt es unter Windows Probleme damit, die durch deine Lösung NICHT lösbar sind. Dazu ist es nötig localhost durch 127.0.0.1 zu ersetzen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Fehler beim Aufruf des Sicherheitschecks

Postby Johnny Rocket » 29. January 2009 13:05

hi glitzi85,

du hast recht, dass "allow from localhost" nach dem "deny from all" wieder ins reine bringt. zudem ist es nicht die beste lösung am quellcode selbst zu basteln, aber sie war effektiv und der sicherheitscheck konnte aufgerufen werden. zudem ist mir dieser eintrag als erster aufgefallen.

die methode funktioniert - ich hab es doch so zum laufen bekommen, selbst unter vista x64. allerdings sollte man den eingriff in der hosts-datei unter windows vornehmen. daher hab ich dies auch gleich gepostet. ohne diesen eingriff wird windows den localhost blocken.

gruß
Johnny Rocket
 
Posts: 2
Joined: 29. January 2009 01:34

Re: Fehler beim Aufruf des Sicherheitschecks

Postby udo1977 » 01. February 2009 14:58

Hallo
Ich habe Windows XP und den gleichen Fehler.
Wollte die host datei ändern, aber da steht bei mir nichts drin....

Bleibt mir nun nichts anderes übrig als den Code zu ändern? Also das "Deny from all" löschen in httpd-xampp.conf zu finden unter: c:\xampp\apache\conf\extra

Ich habs ausprobiert. Das würde bei mir funktionieren.

Gruß, udo
udo1977
 
Posts: 1
Joined: 01. February 2009 14:47

Re: Fehler beim Aufruf des Sicherheitschecks

Postby wolfgangftl » 13. February 2009 16:52

storm7 wrote:Durch die Veränderung in der conf Datei funktioniert der Sicherheitscheck jetzt.
Was hast du den genau verändert, wo war das Problem?

Ich rufe das Script so auf: http://localhost/security/index.php ...

Inhalt von der Host Datei:
Code: Select all
# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
::1             localhost


Bei mir steht schon das in der Host-Datei drin-geht trotzdem nicht.
Lässt sich unter Vista auch nicht ändern.
Herzliche Grüße aus Freital
Wolfgang
User avatar
wolfgangftl
 
Posts: 45
Joined: 20. April 2005 19:22
Location: Freital

Re: Fehler beim Aufruf des Sicherheitschecks

Postby Penguin91 » 20. February 2009 19:47

Kann man mir vielleicht mal helfen? Bei mir funktionierts auch nicht. Hier mal die Codes:
Code: Select all
# XAMPP settings
#
<IfModule alias_module>
<IfModule mime_module>
    #ScriptAlias /php/ "C:/tmforeverserver/xampp/php/"
    #Action application/x-httpd-php "/php/php-cgi.exe"
    LoadModule php5_module "C:/tmforeverserver/xampp/apache/bin/php5apache2_2.dll"
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt

   <Directory "C:/tmforeverserver/xampp/htdocs/xampp">
      <IfModule php5_module>
         <Files "status.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
   </Directory>

Alias /security "C:/xampp/security/htdocs/"
    <Directory "C:/xampp/security/htdocs">
     <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order deny,allow
        Allow from localhost
    </Directory>

    Alias /phpmyadmin "C:/tmforeverserver/xampp/phpMyAdmin/"
    <Directory "C:/tmforeverserver/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
    </Directory>

    Alias /webalizer "C:/tmforeverserver/xampp/webalizer/"
    <Directory "C:/tmforeverserver/xampp/webalizer">
      <IfModule php5_module>
         <Files "webalizer.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
    </Directory>

      Alias /contrib "C:/tmforeverserver/xampp/contrib/"
    <Directory "C:/tmforeverserver/xampp/contrib">
      <IfModule php5_module>
         <Files "webalizer.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>

        Order deny,allow
        Deny from all
        Allow from localhost
    </Directory>
</IfModule>
</IfModule>


# Access restriction via Remote
<IfModule auth_remote_module>
    <Directory "C:/tmforeverserver/xampp/htdocs/fonts">
    AllowOverride All
    AuthType           Basic
    AuthName           "AUTH REMOTE TEST"
    AuthRemoteServer   localhost
    AuthRemotePort     80
    AuthRemoteURL      /forbidden/
    Require            valid-user
    #User: user / Password: pass
</Directory>
</IfModule>

# Access restriction via MySQL
<IfModule mysql_auth_module>
<Location /restricted>
     AuthMySQLEnable On
    AuthName "MySQL Secured Place"
    AuthType Basic
    require valid-user
    AuthMySQLHost localhost
    AuthMySQLUser root
#   AuthMySQLPassword
    AuthMySQLDB webauth
    AuthMySQLUserTable user_pwd
    AuthMySQLNameField name
    AuthMySQLPasswordField pass
    AuthMySQLPwEncryption none
</Location>
</IfModule>


Code: Select all
# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host



Hab ich da irgendeinen Fehler? :(

PS: Benutzerkontensteuerung (Vista x32) aus.
Installiert in C:/ tmforeverserver


Schonmal danke für Antworten,
viele Grüße,
Penguin
Penguin91
 
Posts: 1
Joined: 17. February 2009 19:39

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 2 guests