Aufruf von 127.0.0.1 funktioniert nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Aufruf von 127.0.0.1 funktioniert nicht

Postby NiAlMa » 16. December 2008 16:22

Hallo,

habe die aktuelle Xampp unter c:/xampp installiert und die conf mit
DocumentRoot "E:/Projekte/"
<Directory "E:/Projekte/">

angepasst. Unter E:/Projekte ist derzeit der Ordner /hahn/

Wenn ich nun 127.0.0.1 aufrufe kommt

Index of/

und ist leer! Was läuft da quer? Habe es auch mit 127.0.0.1/hahn/ versucht und bekomme

Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
127.0.0.1
12/16/08 16:21:41
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
XAMPP 1.8 for local development/testing
Codeigniter for programming
YAML for Structure
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NiAlMa
 
Posts: 50
Joined: 28. March 2008 07:22
Location: Schwabenland
Operating System: WU7x64

Re: Aufruf von 127.0.0.1 funktioniert nicht

Postby Wiedmann » 16. December 2008 16:33

Error 500

Bitte das "error.log" lesen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Aufruf von 127.0.0.1 funktioniert nicht

Postby NiAlMa » 16. December 2008 20:43

Dort steht

[Tue Dec 16 16:14:17 2008] [alert] [client 127.0.0.1] E:/Projekte/hahn/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[Tue Dec 16 16:14:37 2008] [alert] [client 127.0.0.1] E:/Projekte/hahn/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[Tue Dec 16 16:21:41 2008] [alert] [client 127.0.0.1] E:/Projekte/hahn/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Ist eine Standardinstallation gewesen
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
XAMPP 1.8 for local development/testing
Codeigniter for programming
YAML for Structure
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NiAlMa
 
Posts: 50
Joined: 28. March 2008 07:22
Location: Schwabenland
Operating System: WU7x64

Re: Aufruf von 127.0.0.1 funktioniert nicht

Postby glitzi85 » 16. December 2008 21:01

Und in der Standardinstallation ist das Rewrite-Modul eben nicht aktiviert.

C:\xampp\apache\conf\httpd.conf im Editor öffnen, die Zeile

Code: Select all
#LoadModule rewrite_module modules/mod_rewrite.so


suchen und das # davor entfernen. Danach den Apachen neu starten.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Aufruf von 127.0.0.1 funktioniert nicht

Postby NiAlMa » 16. December 2008 22:07

danke, das war es! Hätt ich auch selbst drauf kommen können, aber manches Mal sieht man den Wald vor lauter Bäumen nicht
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
XAMPP 1.8 for local development/testing
Codeigniter for programming
YAML for Structure
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NiAlMa
 
Posts: 50
Joined: 28. March 2008 07:22
Location: Schwabenland
Operating System: WU7x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 5 guests