Navigationspfade stimmen nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Navigationspfade stimmen nicht!

Postby LL.Denny » 11. December 2008 01:53

Hallo zusammen.

Nachdem ich auf meinem Xampp-Server eine 1:1 Backup meiner Homepage eingespielt habe, sieht soweit alles ganz gut aus.
Dann fiel mir auf, dass wenn ich auf einen Link klicke, automatisch auf die ursprüngliche Adresse im Internet geleitet werde.

Also statt:

http://localhost/joomla1015/index.php?o ... &Itemid=86

kommt dann dieser Pfad:

http://www.beispiel12345.de/index.php?o ... &Itemid=86

Vielleicht hat ja jemand ne Anregung für mich.

Lieben Gruß

LL.Denny
LL.Denny
 
Posts: 1
Joined: 11. December 2008 01:46

Re: Navigationspfade stimmen nicht!

Postby Nobbie » 11. December 2008 11:39

Das geht eben nicht, eine 1:1 Kopie einer Webanwendung lokal auf dem PC zu testen. Weil in den Daten der Name des Servers (der Domain) auch angegeben ist (die beispiel12345 in diesem Fall) und die Anwendung (Joomla) aus diesen Angaben Links generiert.

Es gäbe einen Trick, das ganze dennoch einfach so zu portieren - zu dem Preis, dass Du (zumindest vorübergehend) keinen Zugriff auf die echte Seite http://www.beispiel12345.de von diesem PC aus hast. Das kann man aber jederzeit rückgängig machen und braucht dafür nicht einmal neu zu booten:

Editiere die Datei c:/windows/system32/drivers/etc/hosts und trage diese Zeile ein:

Code: Select all
127.0.0.1 www.beispiel12345.de


Ohne neu zu booten (und auch ohne Apache Neustart) ist ab sofort Dein Rechner zu Hause (aber nur für Dich) die Domain http://www.beispiel12345.de - Du kannst dann auch schon Joomla selbst mit http://www.beispiel12345.de/joomla1015 erreichen, anstatt mit localhost (was allerdings auch noch geht).

Und dann ist es egal, wenn Joomla Dich nach http://www.beispiel12345.de leitet - ist ja immer noch Dein Rechner zu Hause. Zum Testen finde ich das sogar besser, als wenn man mit localhost arbeitet, weil es jetzt wirklich eine 1:1 Kopie ist. Wenn es nicht mehr benötigt wird, lösche diese eine Zeile wieder aus der hosts-Datei.
Nobbie
 
Posts: 8761
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests