probleme mit .htacces datei, hilfe

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

probleme mit .htacces datei, hilfe

Postby maxxx » 01. December 2008 19:25

hallo leute,
ich habe jahre lang meine apache benutzt, doch mit der neuen version tritt "error 500" auf. ich benutze windows xp.
ich vermute das es an meiner .htaccess datei liegt, da ich der so eine weiterleitung habe. hier mal zum anschauen^^

RewriteEngine on
RewriteCond %{HTTP_HOST} !^xxxxx\.de [NC]
RewriteCond %{HTTP_HOST} !^$
RewriteRule ^(.*) http://xxxxxx.de/$1 [L,R]

könnte das sein? kenn mich damit überhaupt nicht aus, aber als ich die "leer" gespeichert hab kam ich immerhin auf meine index.php seite, konnte allerdings nicht weiter ;)

blicks überhaupt nicht mehr und wäre superfroh wenn ihr mir helfen könntet!
mäx.

p.s. (andere seiten klappen übrigens, also es liegt nicht am verzeichniss oder so ;)
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Postby Wiedmann » 01. December 2008 19:41

doch mit der neuen version tritt "error 500" auf. ich benutze windows xp.
ich vermute das es an meiner .htaccess datei liegt,

In der "error.log" steht genau drin woran es liegt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maxxx » 02. December 2008 18:01

naja, vielleicht stehts da drin, aber dann check ich s nicht....
wenn ich alels lasse wie gehabt steht folgendes:

[Tue Dec 02 17:58:48 2008] [alert] [client 127.0.0.1] C:/Programme/xampp/htdocs/fabhome/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration


wenn ich die htacces datei lösche klappt es auch nicht :(
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Postby Wiedmann » 02. December 2008 18:24

Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Das Apache Modul "mod_rewrite" wird in der "httpd.conf" nicht geladen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby maxxx » 02. December 2008 20:16

okay. d.h. kann ich da was ändern dass es funktioniert? und falls ja, was?^^
danke schonmal ;)
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Postby Wiedmann » 03. December 2008 07:48

d.h. kann ich da was ändern dass es funktioniert?

In der Zeile:
#LoadModule rewrite_module ...

musst du das "#" am Anfang wegmachen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: probleme mit .htacces datei, hilfe

Postby maxxx » 04. December 2008 20:41

hey ES KLAPPT!
vielen vielen dank, da wär ich im leben nich alleine drauf gekommen ;)
alora, macht weiter so, grüßle max.
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Re: probleme mit .htacces datei, hilfe

Postby maxxx » 04. December 2008 20:55

...leider zu früh gefreut.
jetzt klappt die weiterleitung auch im webserver, d.h. ich komme jetzt einfach auf die website -_-
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Re: probleme mit .htacces datei, hilfe

Postby Wiedmann » 04. December 2008 21:52

jetzt klappt die weiterleitung auch im webserver, d.h. ich komme jetzt einfach auf die website

Was ist dein Problem jetzt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: probleme mit .htacces datei, hilfe

Postby maxxx » 05. December 2008 16:56

das was in der .htacces seite steht is ne weiterleitung auf ne andere url.
und wenn ich jetzt die seite im localhoste aufrufe, werde ich sozusagen direkt auf meine website geleitet. also die seite im internet halt, und nicht die auf meinem computer^^
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18

Re: probleme mit .htacces datei, hilfe

Postby Wiedmann » 05. December 2008 17:35

und wenn ich jetzt die seite im localhoste aufrufe, werde ich sozusagen direkt auf meine website geleitet. also die seite im internet halt, und nicht die auf meinem computer^^

Naja, in deiner ".htaccess" (siehe 1. Post) willst du ja diese Umleitung mit diesem Ziel und hast angegeben das du
- dorthin umgeleitet werden willst wenn der Hostname nicht "xxxxx.de" ist
- und dorthin umgeleitet werden willst wenn der Hostname nicht leer ist

Deinem Post nach willst du dann wohl auch noch:
- und dorthin umgeleitet werden willst wenn der Hostname nicht "localhost" ist
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: probleme mit .htacces datei, hilfe

Postby maxxx » 27. December 2008 15:15

hm, ich gebs langsam auf....
nachdem ich meine .htacces datei um folgendes erweitert habe:

RewriteCond %{HTTP_HOST} !^localhost\.de [NC]
RewriteCond %{HTTP_HOST} !^$

werde ich zwar nicht mehr auf meine "online-seite" weitergeleitet, dafür komm ich nur auf meine startseite, und egal was ich anklicke, ich komm nicht weiter (obwohl sich die url oben verändert^^)
(meine homepage ist mit diesem php "include" befehl aufgebaut...)

auf jeden fall vielen vieln dank für eure hilfe soweit, ich bin dem ziel immerhin näher gekommen ;)
maxxx
 
Posts: 9
Joined: 01. December 2008 19:18


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests