Xampp (Port 80) und Mailserver von Port 81 einbinden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp (Port 80) und Mailserver von Port 81 einbinden

Postby quickie_007 » 13. November 2008 18:44

Moin,
ich habe ein kleines Problem. Ich habe einen Mailserver mit Web-UI auf Port 81 laufen, nur leider kann man aus manchen Netzwerken (Firmen, Uni usw..) den Port 81 nicht ansprechen. Also wollte ich auf meiner Page, die auf Port 80 läuft, den 81er irgendwie einbinden, so dass der 81er nur intern verwendet wird und ich die Web-UI des Mailservers ganz normal über Port 80 von extern erreichen kann. Wie könnte man das bewerkstelligen?
quickie_007
 
Posts: 4
Joined: 13. November 2008 18:32

Postby glitzi85 » 13. November 2008 19:00

Geht ganz einfach über mod_proxy: http://httpd.apache.org/docs/2.2/mod/mod_proxy.html

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby quickie_007 » 13. November 2008 19:26

jap vielen dank, sieht vielversprechend aus!
nur leider weiß ich nicht, wie ich es einrichten soll..

edit: soweit ich das begriffen habe, benötige ich einen reverse-proxy, richtig?

ich habe folgendes zur httpd.conf hinzugefügt:

ProxyPass /mail/ http://localhost:81/
ProxyPassReverse /mail/ http://localhost:81/

nur leider will es nicht funzen?
quickie_007
 
Posts: 4
Joined: 13. November 2008 18:32

Postby Wiedmann » 13. November 2008 21:35

nur leider will es nicht funzen?

Warum nicht?

Wir können hier halt gar nicht sehen, was bei dir im Browser nicht so aussieht wie es soll, bzw. ob es Fehlermeldungen im Borwer/Logs gibt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby quickie_007 » 14. November 2008 09:49

Habe jetzt noch manuell mod_proxy_html nachinstalliert und weitere module aktiviert, jedoch hat es den Anschein, als ob alle Programme angepasst werden müssen, das URL-rewriting nicht geht.. z.B. habe ich mal die utorrent-WebUI auf Port 82 gelegt und probiert, die ich auch per http://domain/torrent jetzt erreichen kann, allerdings fehlt der komplette Style und es sieht nicht so aus, wie es soll..
quickie_007
 
Posts: 4
Joined: 13. November 2008 18:32

Postby quickie_007 » 15. November 2008 11:19

Moin,
entschuldigt den Doppelpost, aber ich möchte euch sagen, wie ich es nun doch hinbekommen habe: Um mod_proxy_html.so nutzen zu können, brauchte ich verschiedene Updates sowie das Modul selber (gibt es auf apachelounge). Damit alles läuft, brauchte ich noch C++ Runtimes, die konnte ich allerdings erst nach dem "Rollup 1" für mein W2kSP4 installieren.. Nachdem das getan war, funzte dann auch soweit alles nach Anleitung (Laden der Module, Dateien Conf's..).

Also der MailServer von Port 81 geht jetzt perfekt, nur leider will utorrent noch nicht wie es soll.. Da fehlen wohl noch ein paar module? naja, wenn ich das auch noch solven kann, werd ich euch mitteilen wie.

*edit: so jetzt gehts auch mit utorrent! Einfach mal ab hier weiterlesen.
quickie_007
 
Posts: 4
Joined: 13. November 2008 18:32


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests