fehler beim starten von mysql und xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

fehler beim starten von mysql und xampp

Postby ossilampe » 24. October 2008 20:07

wenn ich xampp starte nach der neuinstallation, startet sql nicht mit..

Wenn ich den dienst manuell starten möchte bekomme ich die meldung

Der Dienst mysql kann nicht gestartet werden Fehler 21

kann mir jemand helfen...
ossilampe
 
Posts: 16
Joined: 17. April 2006 15:42

Postby Wiedmann » 24. October 2008 20:14

wenn ich xampp starte nach der neuinstallation,

- Neuinstallation vom OS, XAMPP, sonstiger Software?

Im Falle vom XAMPP:
- Wie wurde die Neuinstallation genau durchgeführt
- Wie wurde der XAMPP ursprünglich genau installiert?


Der Dienst mysql kann nicht gestartet werden Fehler 21

Genaueres zu Dienstefehlern erhält man bei Windows generell im Ereignislog.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ossilampe » 24. October 2008 20:20

Ich habe vorher versucht xampp auf den u3stick zu installieren denn ich möchte es nur für eine hilfe wiki verwenden und daher eigendlich portable gestalten.

Aber da hat die installation zwar geklappt aber dann könnte ich den dienst apache nicht starten.. und dann habe ich versucht xampp auf den laptop zu installieren..

Keine fehler bei der installation
ossilampe
 
Posts: 16
Joined: 17. April 2006 15:42

Postby ossilampe » 24. October 2008 20:32

so noch einmal neu installiert und jetzt klappt es.. denoch danke...
ossilampe
 
Posts: 16
Joined: 17. April 2006 15:42

Postby ossilampe » 05. November 2008 17:10

heute habe ich mein stick wiedermal gebraucht nach eine woche und nun habe ich wieder das selbe problem das ich beim starten von xampp nach dem einstecken des sticks die fehlermeldung das der Dienst nicht gestartet werden kann...

Ich weis auch warum, denn ich habe ein externes Laufwerk eingesteckt mit dem LWB F:/

In den windows Diensten ist aber Apache2.2 mit dem pfad
F:\xampp\apache\bin\apache.exe" -k runservice
aber der Portables Stick hat in diesem fall LWB I:/


Gibt es eine möglichkeit ein LWB für eine bestimmtes Laufwerk zu reservieren ober bessernoch oder den stick so einrichten das er auch auf fremden PC immer den selben LWB bekommt...

Gruß Tom
ossilampe
 
Posts: 16
Joined: 17. April 2006 15:42

Postby Wiedmann » 05. November 2008 17:34

Gibt es eine möglichkeit ein LWB für eine bestimmtes Laufwerk zu reservieren

Gäbe es.

ober bessernoch oder den stick so einrichten das er auch auf fremden PC immer den selben LWB bekommt...

Nein.

und nun habe ich wieder das selbe problem das ich beim starten von xampp nach dem einstecken des sticks die fehlermeldung das der Dienst nicht gestartet werden kann...

Was XAMPP auf einem USB-Stick generell betrifft:
- nicht als Dienst installieren (wegen anderen LW-Buchstaben)
- direkt nach \xampp entpacken
- nicht die setup_xampp.bat ausführen (oder halt jedesmal, wenn man an einem anderen Rechner ist, wegen anderen LW-Buchstaben).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ossilampe » 05. November 2008 17:38

Hallo Wiedmann,

Danke für die schnelle antwort!!!

welche version von xampp muss ich da nehemen, und reicht es wenn ich xampp dann auf den stick nur kopiere und nicht installiere.. wie geht das dann das der gestartet wird???

gruß Tom
ossilampe
 
Posts: 16
Joined: 17. April 2006 15:42


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests