AwStats funktioniert nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

AwStats funktioniert nicht!

Postby full-mann » 08. October 2008 07:25

Hai,
ich will auf einem Webserver AwStats installieren.
Bin aber schon während der Installation überfragt.

-----> Check for web server install
awstats_configure did not find your Apache web main runtime.

Please, enter full directory path of your Apache web server or
'none' to skip this step if you don't have local web server or
don't have permission to change its setup.
Example: c:\Program files\apache group\apache
Apache Web server path ('none' to skip):

welchen Ort soll ich hier angeben?
"Installationspfad\xampp\apache"
oder
"Installationspfad\xampp\htdocs"
oder einen komplett anderen?

Now, enter full config file path of your Web server.
Example: /etc/httpd/httpd.conf
Example: /usr/local/apache2/conf/httpd.conf
Example: c:\Program files\apache group\apache\conf\httpd.conf
Config file path ('none' to skip web server setup):
> D:\Programme\xampp\apache\conf\httpd.conf

hoffe einfach mal, dass das die richtige Config-Datei ist.

wenn ich dann versuche die Demo anzusehen, bekomme ich folgende Fehlermeldung:
Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
couldn't create child process: 720003: awstats.pl

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500
localhost
10/08/08 08:24:26
Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5


Kann mir jemand weiterhelfen?

Danke schon mal im Voraus.

Wenn ihr mehr Informationen braucht, einfach fragen!
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Re: AwStats funktioniert nicht!

Postby glitzi85 » 08. October 2008 11:30

Hallo,

bei der ersten Frage xampp\apache angeben. Wird vermutlich verwendet um die httpd.exe direkt anzusprechen (um die geladenen Module zu erfahren z.B.). Der zweite Pfad zur httpd.conf ist richtig.

Wohin hast du denn AwStats installiert? Da das ganze ein Perl-Script ist musst du das entweder in den cgi-bin Ordner packen (xampp\cgi-bin) oder CGI für die Endung pl in htdocs aktivieren.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 08. October 2008 12:12

Hai,
danke für deine Anwort!

Habe AWStats mittlerweile anders installiert. Und es funktioniert.

Aber eine andere Frage, vielleicht kann mir da auch jemand helfen. Und zwar bekomme ich in den Statistiken auch die Seiten von AWStats angezeigt. Was natürlich wenig Sinn macht. Weiß jemand wie ich die raus bekomme?

Danke schon mal im Voraus
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 08. October 2008 12:26

Hallo,

in dem Fall müsstest du für AwStats einen eigenen vHost definieren.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 08. October 2008 13:53

Hai,

gibt es da etwas was ich beachten muss?
Habe es jetzt nach folgender Doku gemacht -> Link
(sorry wegen dem Link zu nem anderen Forum, aber ich will, dass alle wissen was ich gemacht habe)

Aber es funktioniert nicht. Ich bekomme nur die Datei "awstat.pl" in Klartext angezeigt.
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 08. October 2008 14:13

Poste doch mal deine Konfiguration, speziell jetzt die vom vHost.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 08. October 2008 14:30

Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
##NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
##<VirtualHost *:80>
##    ServerAdmin webmaster@dummy-host.example.com
##    DocumentRoot /www/docs/dummy-host.example.com
##    ServerName dummy-host.example.com
##    ServerAlias www.dummy-host.example.com
##    ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
##    CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
##</VirtualHost>

##<VirtualHost *:80>
##    ServerAdmin webmaster@dummy-host2.example.com
##    DocumentRoot /www/docs/dummy-host2.example.com
##    ServerName dummy-host2.example.com
##    ErrorLog @rel_logfiledir@/dummy-host2.example.com-error_log
##    CustomLog @rel_logfiledir@/dummy-host2.example.com-access_log common
##</VirtualHost>

NameVirtualHost *:80

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/htdocs
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/cgi-bin
    ServerName awstats
    DirectoryIndex awstats.pl?config=servername
    <Directory "D:/Programme/xampp/cgi-bin">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>
</VirtualHost>
Last edited by full-mann on 05. February 2014 10:53, edited 1 time in total.
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 08. October 2008 15:57

Ja, das sieht schonmal nicht schlecht aus. Allerdings muss die URL beim DirectoryIndex %-Codiert werden. Dann fehlt eigentlich nur noch das Logfile:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/htdocs
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/cgi-bin
    ServerName awstats
    DirectoryIndex awstats.pl%3Fconfig%3Ddebghzndwww0001
    CustomLog logs/awstats.log Common
    <Directory "D:/Programme/xampp/cgi-bin">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>
</VirtualHost>


Dann halt noch awstats in die hosts-Datei eintragen und schon sollte es funktionieren.

Keine Ahnung ob die %-Codierung so stimmt, hab das auf ner Seite gemacht wo das eigentlich für JS gedacht ist.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 09. October 2008 06:46

Hai,

sieht jetzt bei mir so aus:
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/htdocs
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/cgi-bin
    ServerName awstats
    DirectoryIndex awstats.pl%3Fconfig%3Dservername
   CustomLog logs/access.log combined
    <Directory "D:/Programme/xampp/cgi-bin">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>
</VirtualHost>


Aber jetzt bekomme ich einen 403 Fehlercode beim öffnen der Seite.
Last edited by full-mann on 05. February 2014 10:54, edited 1 time in total.
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 09. October 2008 14:44

Beim Aufruf welcher Seite?
Was sagt das Logfile?
Liegt die awstats.pl auch in D:\Programme\xampp\cgi-bin?
Was passiert wenn du http://awstats/awstats.pl?config=debghzndwww0001 aufrufst?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 10. October 2008 05:58

Hai,
diese Meldung kommt, wenn ich nur http://awstats aufrufe.
Wenn ich den Link aufrufe, den du angegeben hast, kann ich die Datei awstats.pl runterladen (also es kommt direkt die Abfrage, ob ich die Datei öffnen, speichern oder ob ich den Downloadvorgang abbrechen will.)

Und welche Logfile meinst du? Die von Apache, in der drinsteht, welche Dateien von wem abgerufen wurden?

Noch was, das cgi-bin ist ja nicht im Ordner htdocs vorhanden. Spielt das auch eine Rolle?

Danke schon mal im Voraus.
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 10. October 2008 15:30

OK, dann scheint das mit dem Directory-Index nicht zu funktionieren, hab das auch nur aus der Doku abgepinselt, ich selber hab das noch nie probiert. Vielleicht kann sich da ja jemand mit Erfahrungen diesbezüglich melden.

Dass es keinen Ordner cgi-bin in htdocs gibt ist richtig, der liegt nämlich neben htdocs im xampp Ordner.

Ich sehe grad dass du deinen VirtualHosts-Block nicht ganz so gemacht hast wie ich das vorgeschlagen habe. Dein CustomLog zeigt auf die Standard access.log, so bekommst du die awstats-Logs niemals aus deinen normalen Logs raus...

Jetzt zum eigentlichen Problem, gehen wir mal der Reihe nach druch was du machen musst:
Du installierst awstats nach D:\Programme\xampp\cgi-bin\, dann verwendest du diese Einstellungen:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/htdocs
    ServerName localhost
    CustomLog logs/access.log combined
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot D:/Programme/xampp/cgi-bin
    ServerName awstats
    DirectoryIndex awstats.pl
   CustomLog logs/awstats.log combined
    <Directory "D:/Programme/xampp/cgi-bin">
       Options Indexes FollowSymLinks Includes ExecCGI
       Order allow,deny
       Allow from all
       AllowOverride All
    </Directory>
</VirtualHost>


Dann schaust du mal ob in der httpd.conf diese Zeile hier:

Code: Select all
LoadModule cgi_module modules/mod_cgi.so


auskommentiert ist, wenn ja, dann das # vorne entfernen!

Danach Apache neu starten und http://awstats/awstats.pl?config=debghzndwww0001 aufrufen. Was passiert dann?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby full-mann » 13. October 2008 06:12

Hai,
habe es jetzt mal so gemacht, wie du es geschrieben hattest.

Wenn ich dann auf die Seite gehe, wird mir die Datei "awstats.pl" als Download angeboten.

Wegen der Log-Datei wäre halt die Frage, wie ich eine andere anlegen kann / wodurch eine neue angelegt wird?

Danke schon mal!
full-mann
 
Posts: 33
Joined: 15. June 2007 11:02
Operating System: Windows Server 2008 R2 SP1

Postby glitzi85 » 13. October 2008 12:36

Könntest du mal bitte deine komplette httpd.conf posten.

Wegen der Log-Datei:

Du wolltest ja, dass die Zugriffe auf die Stats NICHT inder Statistik auftauchen. Da du ja die Statistiken aus der Datei logs/access.log auswertest, solltest du die Zugriffe auf die Stats in eine andere Datei loggen lassen. Daher hab ich das hier eingefügt:

CustomLog logs/awstats.log combined

Damit werden alle Zugriffe auf http://awstats in diese Datei geloggt (die legt der Apache selber an).

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Wiedmann » 13. October 2008 12:55

Und zwar bekomme ich in den Statistiken auch die Seiten von AWStats angezeigt. Was natürlich wenig Sinn macht. Weiß jemand wie ich die raus bekomme?

in dem Fall müsstest du für AwStats einen eigenen vHost definieren.

Nur so nebenbei:
In der AWStats Konfig kann man festlegen, ob (und welche) URLs von der Statistik ausgenommen werden sollen. (Ein VHost ist also für sowas nicht notwendig.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests