memcache probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

memcache probleme

Postby Janus » 06. October 2008 17:41

ich habe folgendes problem und kann in den docs/threads nichts passendes finden;
habe mir eben die neueste version (1.6.8 mit PHP: 5.2.6) von xampp geladen, nach dem es mit der alten schon überhaupt nicht funktionierte und den fehler ausspuckte dass die funktion nicht gefunden wurde, funktioniert nun mit der neuen version zumindest dem anschein nach memcache....

allerdings kann ich mit diesem beispielsscript schon garkeine daten speichern.

Code: Select all
<?php
$memcache = new Memcache;
$memcache->connect('localhost', 11211) or die ("Could not connect");

$version = $memcache->getVersion();
echo "Server's version: ".$version."<br/>\n";

$tmp_object = new stdClass;
$tmp_object->str_attr = 'test';
$tmp_object->int_attr = 123;

$memcache->set('key', $tmp_object, false, 10) or die ("Failed to save data at the server");
echo "Store data in the cache (data will expire in 10 seconds)<br/>\n";

$get_result = $memcache->get('key');
echo "Data from the cache:<br/>\n";

var_dump($get_result);
?>


es kommt dann nur folgendes ergebnis:
Code: Select all
Server's version:
Failed to save data at the server


die richtige php.ini hab ich bearbeitet und memcache per semicolon entfernen aktiviert.

was läuft hier verkehrt? :?
Janus
 
Posts: 12
Joined: 12. May 2004 12:23

Postby glitzi85 » 06. October 2008 17:54

Naja, du musst memcache schon auch installieren um es zu benutzen. Allerdings wirst du da gleich auf das nächste Problem stoßen, bei mir kommt nämlich bei

Code: Select all
pecl install memcache


diese Fehlermeldung:

Code: Select all
ERROR: The DSP memcache.dsp does not exist.


mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Janus » 06. October 2008 18:00

ich hab mir bereits memcached 1.2.1 von http://jehiah.cz/projects/memcached-win32/ geladen und als dienst installiert und gestartet, wenn ich statt "localhost" etwas anderes verwende kommt z.b. eine fehlermeldung ansonsten aber leider garnichts

wenn ich den dienst stoppe kommt dann ein fehler:

Code: Select all
Warning: Memcache::connect() [memcache.connect]: Can't connect to localhost:11211, Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat. (10060) in E:\xampp\htdocs\memcache.php on line 3
Could not connect


das heisst ja schonmal dass es am server selbst liegen muss, ich hab nun auch die neuere version 1.2.6 probiert mit dem selben ergebnis, nähmlich garkeinem =/

auch in der registry kann ich scheinbar nicht großartig variablen verändern...
Janus
 
Posts: 12
Joined: 12. May 2004 12:23

Postby glitzi85 » 06. October 2008 18:33

Du hast also in der php.ini die Extension php_memcache.dll aktiviert. Und wo ist die bei dir? Bei meinem XAMPP ist die nämlich nicht dabei. Und deshlab solltest du die mit PECL nachinstallieren.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Janus » 06. October 2008 18:41

die php.ini ist ganz normal im xampp/apache/bin/ ordner und wie ich wohl rausgefunden habe liegt der fehler dann garnicht bei xampp sondern beim server selbst...

allerdings weiss ich noch nicht woran genau, denn der connect funktioniert, nur spuckt er weder server version noch sonst was aus...

laut tcpview läuft der memcached server auch auf ports 1388-1387 established und auf 11211 listening...hmm....

Edit: Problem gelöst! =)
die versionen 1.2.1 und 1.2.6 funktionierten leider beide nicht ,doch eine ältere version läuft nun problemlos! :)

http://jehiah.cz/projects/memcached-win32/ -> 1.1.12
Janus
 
Posts: 12
Joined: 12. May 2004 12:23


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests