Komponenten abschalten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Komponenten abschalten

Postby weinreich » 06. October 2008 08:23

Hallo, habe gerade frisch 1.68 installiert ... unter Status kann ich jetzt sehen welche Komponenten aktiviert sind.

SMTP und FTP Server stehen auf aktiviert, möchte ich aber nicht, wie kann ich die dauerhaft abschalten ?

Im Sicherheitscheck sagt er mir, Filezilla wäre sicher, weil ein Passwort vergeben wurde ... habe ich aber nie gemacht ??

wofür werden CGI und SSI benötigt ?

Ich werde ein VBulletin auf XAMPP installieren, brauche ich da evtl. CGI und SSI ?

Vielen Dank für Eure Antworten
weinreich
 
Posts: 38
Joined: 05. February 2005 14:14

Postby glitzi85 » 06. October 2008 10:07

Hallo,

das hört sich stark nach einem Windows-Server an, da ist der SMTP-Dienst in Windows integriert. Wie du den abschaltest? Keine Ahnung, aber dein vBulletin wird den mit Sicherheit benötigen.

FTP-Server kannst du deaktivieren, indem du FileZilla stopst.

SSI ist ein simples Include implementiert im Apachen, CGI bindet jede beliebige Script- oder Programmiersprache in den Webserver ein.

vBulletin läuft auf PHP, demnach werden beide Funktionen nicht benötigt. Abschalten kannst du die in der httpd.conf.

Ich geh mal davon aus, dass du das ganze in einem LAN und nicht im Netzwerk betreiben möchtest.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby weinreich » 08. October 2008 08:10

glitzi85 wrote:SSI ist ein simples Include implementiert im Apachen, CGI bindet jede beliebige Script- oder Programmiersprache in den Webserver ein.

vBulletin läuft auf PHP, demnach werden beide Funktionen nicht benötigt. Abschalten kannst du die in der httpd.conf.

mfg glitzi


Erstmal Danke, es läuft bei uns im eigenen Intranet ... auf einer VM Maschine 2003 Server ...

wo kann ich die nicht benötigten Funktionen SSI und CGI in der httpd.conf auskommentieren ?
und... kann ich FTP auch irgendwo rausnehmen, dass es beim Neustart
nicht wieder an ist ?
weinreich
 
Posts: 38
Joined: 05. February 2005 14:14

Postby glitzi85 » 08. October 2008 11:35

Hallo,

beides wird über Module geladen. Also httpd.conf öffnen und vor die zwei Zeilen:

Code: Select all
LoadModule cgi_module modules/mod_cgi.so
LoadModule include_module modules/mod_include.so


jeweils in # setzen. Dann suchst du im ganzen Dokument nach ExecCGI und löscht jedes vorkommen (allerdings nur das Wort, nicht die ganze Zeile).

Diesen Block hier kannst du auch auskommentieren oder löschen:

Code: Select all
<Directory "C:/xampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>


Außerdem musst du noch schauen ob irgendwo Script-Aliase definiert sind. Es sollte zumindest diesen hier geben (in einem IfModule alias_module Block):

Code: Select all
ScriptAlias /cgi-bin/ "C:/xampp/cgi-bin/"


Auch auskommentieren oder löschen.

Edit: Welcher FTP-Server läuft denn überhaupt? Poste mal die Ausgabe von xampp_portcheck.exe

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby weinreich » 08. October 2008 12:05

Danke für die Hilfe..... von mir aus kann alles aus was ich nicht brauche, Resourcen braucht, oder zu Angriffen einlädt.

Ich brauch nur den Apache und mySQL Server wenn ich es richtig verstanden habe. FTP läuft über einen anderen Rechner, Mail sowieso nicht.


kann ich hier nichts anhängen ?, finde den Upload Button nicht, hatte eine Hardcopy gemacht ... ?
weinreich
 
Posts: 38
Joined: 05. February 2005 14:14

Postby glitzi85 » 08. October 2008 12:22

Nein, Upload gibt's hier nicht. Du kannst aber auch einfach in dem Portcheck-Fenster in der Titelleiste rechts klicken, Bearbeiten -> Markieren auswählen. Dann selektierst du einfach den ganzen Bereich den du haben willst, drückst Enter und kopierst es hier rein.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby weinreich » 08. October 2008 13:17

Apache (HTTP) 80 c:\xampp\apache\bin\apache.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 c:\xampp\apache\bin\apache.exe

MySQL 3306 C:\xampp\mysql\bin\mysqld-nt.exe

FileZilla (FTP) 21 C:\WINDOWS\system32\inetsrv\inetinfo.exe
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
weinreich
 
Posts: 38
Joined: 05. February 2005 14:14

Postby glitzi85 » 08. October 2008 13:29

inetinfo.exe ist der IIS.

Wenn du den nicht benötigst, schalte ihn komplett ab. Ansonsten musst du die FTP und Mail Komponenten einzeln deaktivieren.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby weinreich » 09. October 2008 05:44

irgendwie ist alles grotten langsam .... ich versteh es nicht wirklich, wenn gleich das auch nicht unbedingt mein fachgebiet ist ...
Ich habe xampp so installiert wie ich es mir runtergeladen habe ...

seit der neuen xampp version brauchen manche anfragen bis zu 10 sekunden bis die seite aufgebaut wird .... am server liegt es nicht ...

ist auf einem notebook als zweite versuchsmaschine das gleiche ...

früher war es rattenschnell ..

hat sich denn soviel getan zwischen der "alten" xampp version von 2005 und der von heute ?
weinreich
 
Posts: 38
Joined: 05. February 2005 14:14


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests