Apache startet und kurz darauf ist Apache wieder gestopt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet und kurz darauf ist Apache wieder gestopt

Postby saila » 23. September 2008 08:51

Hi,

es handelt sich um Version 1.6.7

Wenn ich über das Control-Panel Apache starte, wird Apache nach ca. 3 - 5 Sekunden wieder gestopt. Woran kann das liegen?

- Die Version wurde neu installiert,
- Skype ist korrekt eingestellt (wobei bei den Tests Skype nicht aktiviert war),
- Diensteeinstellungen sind nicht verändert.
- Portcheck gibt alle Ports als Free aus
- Installation per Installer erfolgt


Was könnte das sein - evtl. doch ein Dienst?
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 08:54

Wird der Apache als Dienst (Svc) oder als Programm gestartet?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 08:55

Als Programm
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 09:12

Dann starte den Apache mal über die Batchdatei "apache_start.bat" und lies die Meldungen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 09:23

Hi,

das hatte ich bereits vorgenommen. Allerdings wird auch dann Apache nach ca. 3 - 5 Sekunden wieder gestopt bzw. beendet.

Edit:
Die Meldung ist korrekt. Nicht während des Betriebs die Eingabeaufforderung beenden bzw. nur durch apache_stop.bat.
Mehr steht da nicht.
Apache 2 running...

3 Sekunden später wird die Eingabeaufforderung bzw. das Fenster geschlossen.
end Edit

Gibt es eine Liste von Diensten, welche gestartet sein müssen?
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 09:45

Die Meldung ist korrekt. Nicht während des Betriebs die Eingabeaufforderung beenden bzw. nur durch apache_stop.bat.
Mehr steht da nicht.
Apache 2 running...

3 Sekunden später wird die Eingabeaufforderung bzw. das Fenster geschlossen.

- Ist das eine Neuinstallation vom XAMPP
- WiIe genau gemacht
. Irgendwas geändert.
- Usw., usw., ...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 10:00

Ja, ist eine Neuinstallation. Vorgenommen über den Installer (installer.exe). Die Installation lief sauber durch. Keine Fehlermeldungen oder sonst irgendetwas.

Geändert wurde nichts.
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 10:06

Ja, ist eine Neuinstallation.

- Betriebssystem?
- Wohin installiert?

BTW:
Apache 2 running...

3 Sekunden später wird die Eingabeaufforderung bzw. das Fenster geschlossen.

Normalerweise spricht das dafür, dass der Apache nicht auf das konfigurierte error.log zugreifen kann.

(Man kann natürlich trotzdem mal schauen, ob da was drinsteht.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 10:19

- Betriebssystem Win XP Pro SP3 (liegt auf Laufwerk E:)
- Laufwerk F:

In der error.log wird darauf hingewiesen, dass die Anwendung neu installiert werden sollte. Das habe ich aber bereits 3 x getan.
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 10:26

- Laufwerk F:

Also in "F:\xampp"?

In der error.log wird darauf hingewiesen, dass die Anwendung neu installiert werden sollte.

Wie sieht das "error.log" genau aus?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 10:42

Habe soeben mal Xampp deinstalliert, die Registry von WXP normalisiert und erneut installiert und das steht nun in der error.log:
Code: Select all
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\\xampp\\php\\ext\\php_pgsql.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0
[Tue Sep 23 11:40:19 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Tue Sep 23 11:40:19 2008] [notice] Server built: Jun 14 2008 19:02:12
[Tue Sep 23 11:40:19 2008] [notice] Parent: Created child process 2768
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\\xampp\\php\\ext\\php_pgsql.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0
[Tue Sep 23 11:40:21 2008] [notice] Child 2768: Child process is running
[Tue Sep 23 11:40:21 2008] [notice] Child 2768: Acquired the start mutex.
[Tue Sep 23 11:40:21 2008] [notice] Child 2768: Starting 250 worker threads.
[Tue Sep 23 11:40:22 2008] [crit] (OS 1450)Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.  : Child 2768: _beginthreadex failed. Unable to create all worker threads. Created 162 of the 250 threads requested with the ThreadsPerChild configuration directive.
[Tue Sep 23 11:40:22 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Sep 23 11:40:23 2008] [notice] Child 2768: Released the start mutex
[Tue Sep 23 11:40:24 2008] [notice] Child 2768: All worker threads have exited.
[Tue Sep 23 11:40:24 2008] [notice] Child 2768: Child process is exiting
[Tue Sep 23 11:40:24 2008] [notice] Parent: Child process exited successfully.
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\\xampp\\php\\ext\\php_pgsql.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0
[Tue Sep 23 11:40:37 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Tue Sep 23 11:40:37 2008] [notice] Server built: Jun 14 2008 19:02:12
[Tue Sep 23 11:40:37 2008] [notice] Parent: Created child process 4568
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\\xampp\\php\\ext\\php_pgsql.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0
[Tue Sep 23 11:40:39 2008] [notice] Child 4568: Child process is running
[Tue Sep 23 11:40:39 2008] [notice] Child 4568: Acquired the start mutex.
[Tue Sep 23 11:40:39 2008] [notice] Child 4568: Starting 250 worker threads.
[Tue Sep 23 11:40:39 2008] [crit] (OS 1450)Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen.  : Child 4568: _beginthreadex failed. Unable to create all worker threads. Created 147 of the 250 threads requested with the ThreadsPerChild configuration directive.
[Tue Sep 23 11:40:39 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Sep 23 11:40:40 2008] [notice] Child 4568: Released the start mutex
[Tue Sep 23 11:40:41 2008] [notice] Child 4568: All worker threads have exited.
[Tue Sep 23 11:40:41 2008] [notice] Child 4568: Child process is exiting
[Tue Sep 23 11:40:41 2008] [notice] Parent: Child process exited successfully.
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 10:57

[Tue Sep 23 11:40:22 2008] [crit] (OS 1450)Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen. : Child 2768: _beginthreadex failed. Unable to create all worker threads. Created 162 of the 250 threads requested with the ThreadsPerChild configuration directive.

Da scheinst du wohl ein grundlegendes Problem mit deiner Windows Konfiguration/Installation zu haben.
Zusätzlich zu der Fehlermeldung hier, kannst du auch mal im Windows Ereignislog nach einer dazugehörigen Fehlermeldung schauen, und damit in der Microsoft KB nachschlagen oder Newsgroup befragen.

PHP Warning: PHP Startup: Unable to load dynamic library 'F:\\xampp\\php\\ext\\php_pgsql.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0

Man könnte diese Extension auch mal testweise in der "php.ini" deaktivieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby saila » 23. September 2008 18:44

Hi,

habe nun Win XP PRO mal neu aufgezogen und dennoch - das gleiche Problem. In Windows gibt es folgenden Fehler: Microsoft.VC80.CRT nicht vorhanden. Frage mich nur, warum das nun plötzlich nicht mehr vorhanden ist, was zuvor da war und auch bei der Neuinstallation ist es nicht vorhanden.

Woran liegt das und vor allem - was ist "Microsoft.VC80.CRT"?
saila
 
Posts: 30
Joined: 15. September 2006 23:28

Postby Wiedmann » 23. September 2008 19:01

was ist "Microsoft.VC80.CRT"?

Eine Datei...

Die ist bei irgendeinem Microsoft Visual C++ Redistributable Package dabei. (und/oder bei einem .NET-Framework.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests