Konfiguration php.ini für den Mail Versand

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby jay.ka » 29. October 2008 20:10

Danke für das schnelle Feedback!

Die Logfiles sind m.E. aktiviert, so siehts in der sendmail.ini aus:

error_logfile=error.log

debug_logfile=debug.log

pop3 habe ich wieder deaktiviert, hat jedoch nichts gebracht. Schreibfehler sehe ich auch keine, habe das jetzt mehrmals gecheckt. Kann mir echt nicht erklären, wieso das nicht funzt.

Was müsste ich denn einstellen um es auf dem localhost zu testen?
jay.ka
 
Posts: 5
Joined: 29. October 2008 16:04

Postby Wiedmann » 29. October 2008 20:18

Die Logfiles sind m.E. aktiviert, so siehts in der sendmail.ini aus:

In dem Fall legt er die Dateien auch an, und schreibt auf jeden Fall was rein.

Kannst ja nochmal das error_reporting in PHP euf E_ALL setzten und schauen ob dann was kommt (bzw. ob evtl. noch was im error.log vom Apache steht).

BTW:
Du hast die PHP-EInstellungen aber schon mit phpinfo() überprüft?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jay.ka » 29. October 2008 20:38

Also in der php info steht

Loaded Configuration File: C:\xampp\apache\bin\php.ini

und dort habe ich ja auch den korrekten sendmail path angegeben.


In der php.ini steht:

error_reporting = E_ALL & ~E_NOTICE

Nun hab ich einen Anhaltspunkt, der Apache loggt den Error:

"You must configure the smtp_server and default_domain in:
C:\xampp\sendmail\sendmail.ini
or
HKLM\Software\Sendmail"

Aber das müsste doch stimmen, habe nun auch mail.web.de versucht, als default_domain ist immer noch mydomain.com drin aber das ist doch nicht von Belang oder ?!
jay.ka
 
Posts: 5
Joined: 29. October 2008 16:04

Postby jay.ka » 29. October 2008 20:42

Ok, ich habe mir die Antwort soeben selbst gegeben, nachdem ich vor default_domain ein ; gesetzt habe geht es nun. Sendmail reagiert, es gibt zwar noch einen Fehler aber den werde ich hoffentlich gleich beheben.
jay.ka
 
Posts: 5
Joined: 29. October 2008 16:04

Postby jay.ka » 29. October 2008 20:46

Danke dir für den Tipp mit den Logs, als Newbie ist das sehr hilfreich!

Gruß
jay.ka
 
Posts: 5
Joined: 29. October 2008 16:04

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests